Question about Visonik V128D4 Car Subwoofer

1 Answer

Not working I have 2 v127d4 visonik subwoofers that a friend said they stop working I tried hooking wires to each. One nothing the other a second of sound then nothing then I a minute later worked low sound for a second. I think it is sorting out like to much power but all I had to test it is my home stereo 8 ohm 60 watt per channel. Is this not enough power to test run these . what do they need to run???

Posted by on

  • Anonymous Feb 19, 2009

    Im have the same problem I have 2 15" subs that just randomly decided to stop working, my amp turns on..but my subs have no bump??



1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that has over 10 points.


    An expert whose answer got voted for 2 times.

  • Expert
  • 61 Answers

Sounds like the voice coils are cooked...try testing each speaker with no wires to them...use a multi-meter on set on ohms/resistance, low scale...should read either 2,4 or 8 ohms, no reading or very high reading means sub is shot.

Posted on Mar 16, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

How should i hook up a visonik class D vxd709 to my dual voice coil 12" Treo subwoofer?

if your amp is a monoblock 2 ohm stable amp wire the coils positive to positive and negative to negative into a single channel that will create a 2 ohm load turn your amp down and adjust by ear till it sounds good if your amp is a 2 channel amp 4 ohm per channel wire each coil one per channel turn amp down and adjust by ear till sounds good hope i was helpful

Feb 17, 2013 | Car Audio & Video

1 Answer

Visonik v543 speakers. there's a green wire with a black stripe and a black wire. which one is the ground?

Hello sir hi, the black wire is standard color for ground. if you are wiring a speaker, the wire is really not that sensitive, interchanging the wire only makes the sound drop to about 2%, barely not noticeable.

Sep 19, 2010 | Visonik Car Audio & Video

1 Answer

I have a visonik 800watt amp and i got it from a friend for free and i hooked it up right and as soon as i turned it on the 2 fuses blew then i replaced them and tryed it again and it stoped again so i...

Its the amp, do not put any more fuses in it
you need to get it checked out by a technician.

Its probably a power supply fault or blown output devices.

Hope this helps
Thanks for using FixYa

Aug 02, 2010 | Visonik V2508 2-Channel Amplifier

1 Answer

How do I hook up my 10 inch visonik sub woofers? they have 2 connections?

this is a dual voice coil sub. either have a 2 channel amp hook up to it. or have your mono amp have to sets of wires going out of it to your 2 connections. i dont suggest it but i have had one connection hooked up at a time played it when it blew hooked up the other connection as a back up. just make sure you have the right watt level for each voice coil.

Apr 14, 2010 | Visonik V10DV6W Car Subwoofer

1 Answer

I hooked up my two 10 inch JL Audio W3v2 2 ohms to a mono JL Audio 500.1 amp and the subs will not work. I have the subs wired in a series. I then hooked them up to my friends amp and the subs worked. Any...

try one at a time. if they work then try hooking them up differently. if none work, then check to see that your amp is not in protect mode. if amp is ok, then check to make sure you have your rcas connected to your amp. in other words, re-check all your wiring. if still nothing, try your amp on your friends car and vise versa.

Apr 01, 2010 | Jl Audio 10W3v2 Car Subwoofer

2 Answers

Visonik 350watt Amp Doesnt Come On....

With your multimeter set to DC volts, the black meter probe on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red probe alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Let me know if you have any other questions.

Oct 06, 2008 | Visonik V117SX Car Audio Amplifier

1 Answer

Ok this problem is killing me...

maybe the speaker is bad

First try one thing, switch the rca jacks around and see if the other speaker stops working this time.

If so the problem is in the rca jack or head unit.

If the same speaker is still not working, the problem will be the speaker, you will have no other options left since you changed amplifiers and checked all wiring.

Let me know if this helps you

Jun 18, 2008 | Visonik Dual Bass Box with Amplifier Car...

1 Answer

Installing visonik bass system

Here is a link to visonik to download manuals.

If you let me know your model number of the sub, vehicle make and model, and brand and model of headunit or CD player you have then i can provide wiring color codes, recommended wire routing locations, etc...

Jan 03, 2008 | Visonik 10" 500-Watt Single Bandpass...

3 Answers

Visonik 2-ch amp getting too hot and shutting down

first i have to ask if you ran the rcas on the same side as you did your power wires. that would result in the interference you're recieving. the rcas should be on one side of the vehicle and the power wires on the other. if you're unsure of the grounding site then take the time to properly clean it and reinstall. also understand that you amp having adequate breathing room is very important. without enough airspace your amp will surely overheat.

Dec 03, 2007 | Visonik V408XT 250W x 2 Car Amp Car Audio...

1 Answer

Visonik amps turn on into protection mode(where green not red for three days)...switched over the wires to some sony amps and they dont even turn the hell on

the fuze could be blown on the amp or the speakers are to much power for the amp at full power so try to turn the amp to half and not to turn the speakers all the way up,.

Jan 24, 2007 | Eclipse (XA1000) Car Audio Amplifier

Not finding what you are looking for?
Visonik V128D4 Car Subwoofer Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Visonik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Jerry Umali

Level 3 Expert

979 Answers


Level 2 Expert

269 Answers

Are you a Visonik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides