Question about JVC TH-M303 System

2 Answers

Subwoofer won't turn on

The dvd works fine, except the 'on' light on the subwoofer doesn't turn on, and I don't get any sound. Everything is hooked up, and the subwoofer is plugged in. Thanks.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Subwoofer won't turn on

I have the same problem but found that this JVC unit must have a special cord from the player to the subwofer in order to turn it on. Im looking for the cord now!

Posted on Mar 11, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert that hasĀ over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 322 Answers
Re: Subwoofer won't turn on

Try and see if it as internal fuse ? if not the bad news is that possibly the amp as gone

Posted on Jan 28, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

We bought a Samsung Soundbar x810 but the Subwoofer does not seem to be working properly although the blue and red led light up. I have tried rebooting/resetting per user manual instructions but it still...

Purchased a x810 & everything tests out fine except TV signal sounds from cable box. We have the Comcast cable box connected to the 50" Samsung Plasma TV hooked up to Samsung x810 Soundbar all using HDMI cables. But we are not getting cable shows sound through Soundbar. Please advise

Nov 04, 2009 | Samsung HT-X810T Theater System

1 Answer

The Subwoofer will not work but all other speakers do!

Hi look for a sub level control in the set up and turn it up,this may give it a kick start,also is ther a volume control on the sub? if so turn it up half way.


Aug 05, 2008 | Panasonic SC-PT1050 System

3 Answers


Is sub out turned on on the reciever? Some have a setting that doesnt use the sub out, like 2 channel.

Jul 30, 2008 | Home Theater Systems

2 Answers

No sound

please check cables between dvd and subwoofer.test with good new or working cables.

Jan 20, 2008 | JVC TH-M303 System

2 Answers

Subwoofer volume and sound

i had the same problem when i tried to adjust speaker output levels, distance and equalizer manually without using audessy i reset everything to factory setting (0s)..and then ran 
audessy setup..reduce volume on your subwoofer to slightly above minimum(behind the subwoofer) before running the setup..once audessy setup is completed successfully..i started changing setup
manually..changed speaker config for front speaker to small (it is set as large by audessy setup), this should automatically adjust center and other speaker configuration (if not make sure to set them to small as well), then set the cross over frequency to 120..increase the volume on your subwoofer and now you should hear it fire..if this does not help..try playing some rock music with all channel streo mode..if your subwoofer does not fire even for this..then take the system back for exchange..

Dec 28, 2007 | Onkyo HT-SR800 System

1 Answer


circular calem is probibly stuck

Oct 28, 2007 | Yamaha YHT-941 System

2 Answers

Onkyo subwoofer not working

I fixed my subwoofer. The resistor at R16 (right next to the fuse) was the fried component. I removed it and replaced it with a 13K ohm 5 watt metal oxide resistor (from Mouser Electronics if not available locally). Works fine now. I got the solution and the circuit schematic from an audio hobbiest at This is, evidently, a fairly common problem.

Sep 17, 2007 | Onkyo HT-S780 System

2 Answers

Can't get sound from the wireless subwoofer

There are 2 things you can try, first ensure that the digital transmitter is fully inserted into the slot of the main unit. Secondly do you have any other wireless devices near such as cordless phone or wireless network equipment? See page 5 of the installation manual as per this picture.......

Jul 25, 2007 | Panasonic SC-PT1050 System

1 Answer


Sounds like your original and this sub have bad amps. The amp for the sub is not the same as the amp for the other speakers. The old unit has a dead amp and this new one is on the way out. (Pulling too much current on high bass)

Mar 30, 2007 | JVC TH-M505 System

Not finding what you are looking for?
JVC TH-M303 System Logo

Related Topics:

1,170 people viewed this question

Ask a Question

Usually answered in minutes!

Top JVC Home Theater Systems Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

6993 Answers


Level 3 Expert

56797 Answers

Are you a JVC Home Theater System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides