Question about Pioneer GM-5100T Car Audio Amplifier

1 Answer

Subwoofer wont play

The amp turns on and the amp light is on. I am pretty sure the subwoofer is not blown. I actually tried another speaker off the amp and all I get is static when I hook up speaker. Is my amp blown? and sometimes my amp works. Let me know what yout think.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 34 Answers

Check your rca cables they might be loose or not connected to the amp or the radio. Sometimes those rca cable outlets get worn out by being bumped, moved, hooking up and pulling out connectors. Plug in your rca cords and wiggle them on the amp while radio is on and see if the music cuts in and out

Posted on Nov 20, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My kicker l7 shows nothing wrong with it but wont work all of a sudden. whats wrong with it/


Faulty speaker wire. Dry joint in amp. Take speaker out & play with + & - wires on actual speaker to see if bad conection before cone

Sep 15, 2012 | Kicker 02S10L74 Car Subwoofer

1 Answer

Hi i have problems with my subwoofer it wont play it's an alpine 12'' type e with alpine mrp m350 amp. there is light on the amp. how do I find out my subwoofer is blown or what else can be...


ok, your amp is in protect mode. either the speaker wires are crossed and shorting out, your woofer's vioce coils are melted and the speaker is blown or the amp is dead.

to determine if the speakers voice coils are melted, and thus the speaker being blown is the reason for the "protect" light, simply push in the cone of the woofer in gently with your hand. the woofer should move a little more than an inch, without any resistance, before bottoming out. if there feels to be any resistance, like a rubbing or scratching, before the woofer bottoms out, then your voice coils are fried, and you need a new woofer.

Nov 25, 2010 | Car Audio & Video

1 Answer

Fuse blows


Both 3 or 4 amp slow blow fuses are suitable replacements for the 3.125 amp subwoofer fuse.

It could be that the subwoofer is blowing the fuse because the one you installed was not slow blow.

But, more likely is the subwoofer has a short in the power supply which is causing the fuse to blow.

May 31, 2009 | JBL PB10 Subwoofer

1 Answer

Subwoofer pushing out problem


it sounds like one channel in your amp had shorted and letting dc go to the speaker...a speaker is an electromagnet and requires ac to make it pulse..the amp has a blown channel and would have to be repaired and a factory service center...there is no quick fix..

May 27, 2009 | Lightning Audio B1.10.4 Car Subwoofer

1 Answer

Only one thump when car is turned on. problem in amp strength or subwoofer?


try pluging in a diff, speaker to the amp see if u get sound.try powering the sub with a home radio just to see if u get sound at all if ur getting sound from the sub then its the amp but u could of damaged it when the amp over heated

May 03, 2009 | Kicker SoloX S10X2 Car Subwoofer

1 Answer

Subwoofer wont play


change your rca's you may have a bad one that is grounding out or one of your spkr

Apr 14, 2009 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

Subwoofers not bumpin, amp is still on


Check to make sure there is a good input to the amp. Next check each sub to another source to make sure they are good. Look for any reset on the amp.

Apr 26, 2008 | Kicker CVR12 Car Subwoofer

1 Answer

Subwoofer will not work when connected


cheak setting in sterio out put for sub on ect does woofer have sperk wire going in and out use them then ok

Feb 11, 2008 | Velodyne CT-80 Subwoofer

Not finding what you are looking for?
Pioneer GM-5100T Car Audio Amplifier Logo

450 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

74887 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77514 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...