Question about Kicker Car Audio & Video

1 Answer

Amp has power but now sound

When i got the amp i had two 12's and they blew. now i bought one 12 and hooked it up to the amp. it looks like it should be ready to bump but i have sound in the factory speakers just not my sub

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 20 Answers

You have not given any information on your models. Chances are you wired them incorrectly. either the first time, or both times. How do you know you burned up the sub and not the amp? chances are the amp is fried, most likely due to wiring the speakers to the wrong impedance.

Posted on Nov 19, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I hook up a amp with red and black wire from the car stereo, then the stereo stopped turning on, why?


You probably blew a fuse. The power wires for a stereo can not handle the current an amp needs. An amp has to get it's power directly off the battery. Get an amp kit that has the power wire, ground wire, turn on lead, and fuse w/fuse holder. fuse the power no less than 12" from the battery.

Apr 19, 2011 | Boss MP3-3030R CD Player

1 Answer

No power


may be the coil filter choke is wornout...DC supply stage inside your amplifier...go to the nearest electronic tech to repair that..

May 26, 2010 | AudioBahn A1300HCT Car Audio Amplifier

1 Answer

Just hooked up mtx 500d mono amp and 12 inch sub worked for a 1/2 hour then sub quite and led on top of amp just flashes.


either ur ohm load is way off ur pos n neg might be touchin or more than likely u blew u sub is it scratchy when u push in the middle of the cone ? does it push in at all?

May 14, 2010 | Car Audio & Video

1 Answer

I paid a store to hook up my lanzar vibe 241 amp and 2 lanzar 12" subs(all brand new). It sounds ok but i have a loud buzzing coming out of it constantly and when i use my power window buttons I hear a...


To get rid of the buzzing sound just go to walmart and in the car stereo section buy the $10 rca ground loop isolator, this is the best way to get rid of amp noise

Oct 11, 2009 | Lanzar VIBE241 Car Audio Amplifier

2 Answers

Kenwood KDC-MP202 sound turns off when headlights are turned on


just solved a similar problem on my car i bought a Cd/dvd player for my 2000 concord lxi i hooked it up and hooked a rear-view camera and it worked perfect but wen i turned the headlights on the cd player shuts of so i disconnected the orenge wire that came out of my cd player from the orange on the aftermarket harness then grounded the ping wire (rear con wire) it worked fine but i couldn't see any footage from the camera for that i bought a long red power wire and hooked it to the red camera power wire that hooked from camera to reverse light and took the other end of the new wire i bought and hooked it to the orange wire that came out of the cd player now every thing works fine. you probably dont have the right power to run both cd and head lights thats why you need constant power to run both just hook up an extra wire between a positive wire to the orange dimmer wire its simple;

ground to ground (black)
12+ positive to 12+ positive (red)
and an extra wire (usually a red 18 guage wire bought mine at walmart) to the dimmer wire from the back of the cd player (orange) edit.gif

Mar 21, 2008 | Car Audio & Video

1 Answer

No sound to speakers


is the sub dual or single?check sub first then try disconnecting all power including ground for 20min to discarge caps some amps mute if driven hard at low impedience .

Jul 01, 2007 | Hifonics BX1500D Car Audio Amplifier

1 Answer

My amp light is on but no sound from speaker


If the amp light is one and the protector light wasent on then I bet you blew your speaker??? take an ohm meter, measure each speaker with nit disconnected from the amp.. If they all measure what there suppose to( like 4 to 8 ohms) then the amp blew out and unless you have training on solid state electronic repair, you should seek a pro to fix the amp for ya.. Good Luck

Jun 28, 2006 | MTX 6001 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...