Question about Dell Computers & Internet

Open Question

Intervlan switching not working on multihome server

Have a Dell PowerConnect 6248 layer 3 with 4 VLANs configured for IP routing.  InterVLAN switching works correctly between hosts except in the following case.

VLAN Configuration 
-IP Routing enabled for all VLANs
-VLAN routing IP address is the  assigned to the VLAN access

VLAN 21
IP Subnet: 10.0.1.0/26
VLAN routing IP Address: 10.0.1.1

VLAN 22
IP Subnet: 10.0.2.0/26
VLAN routing IP address: 10.0.2.1

VLAN 24
IP Subnet 10.0.4.0/26
VLAN routing IP address: 10.0.4.1

VLAN 35
IP subnet 10.0.15.0/26
VLAN routing IP address: 10.0.35.1

Host A  has 2 NICs.
NIC 1 is configured with an ip address of 10.0.15.5 and no default gateway.  This LAN for internal server interconnects.

NIC 2 is configured with IP address 10.0.1.5 and default gateway of 10.0.1.1 (The VLAN IP address).

Host B has 2 NICs
NIC 1 is configured with IP address 10.0.15.10 and no default gateway.

NIC 2 is configured with IP address 10.0.2.10 and default gateway of 10.0.2.1 (again the VLAN IP address).

Pings from Host A to 10.0.15.10 on Host B work as expected - Layer 2 switching on same subnet LAN.

Pings from Host A to 10.0.2.10 on Host B fail.  A tracert shows the 10.0.1.1 VLAN IP as the first entry and then failures on rest of hops (there should be only 2 or 3 at most - see below.)

From my perspective it appears that VLAN 21 10.0.1.1 is directly switching the echo request packets to Host B at 10.0.2.10. Then host B sends the echo reply packets to VLAN 22 10.0.2.1 which switches directly to Host A 10.0.1.5.  I think this is the problem.  Host A is listening for and expecting the echo reply to come from the 10.0.1.1 interface. Instead the echo reply is coming from the 10.0.2.1 interface and so the reply is not properly forwarded to the correct listen process.

I think this is improper handling of the layer 3 switch on the part of the Dell 6248.  I think it should be Host A to VLAN 21 gateway IP address (i.e. 10.0.1.1) then from VLAN 21 gateway to  VLAN 22 gateway (i.e. IP 10.0.2.1) then to host B.  The reverse should happen for the reply from Host B to Host A.  This way Host A correctly sees the reply on the 10.0.1.0 subnet.

I have this same configuration on a Cisco 2848g Layer 3 switch and there is no problem with pings between the multihome servers.  Some how the Cisco layer 3 switching  knows to keep the subnets correct and still do layer 3 switching.

Is there some special (e.g. binding MAC to IP, static IP and MAC) that I need to add on the Dell switch to fix this problem?  Seems to me the layer 3 switching should be transparent to a multihome server just like it is on the Cisco switch.

Thanks in advance for any advice to fix this problem

Posted by on

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

SteveRand
  • 210 Answers

SOURCE: Sending DHCP request across diffrent vlans

Hmm... on your DHCP server, try setting the "default router" IP for each pool to be the VLAN ID on the switch.

scope 172.16.0.0 /24
router 172.16.0.1

scope 10.20.8.0 /22
router 10.20.8.1

I think the DHCP replies aren't going back where they should. I've never done this without a router doing all the DHCP, but it does work and i've done it many times. Your config looks spot on for the switch.

Posted on Feb 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sir I have 4200 series 26 ports Switch i want to Configure intra VLAN But I am Getting a problem to Configure that switch . After Cnfigure VLAN on Consol prompt. I am not accessing to my Server & WAN...


Hi,
If you are creating only Layer 2 VLANs on the switch , you wont be able to ping the servers and Routers as they are in default VLAN1.
you can do the below steps
1. Create sub interfaces on the router LAN interface
2. Provide a new ip range to the new sub interface
3. Make the switch port connecting router as trunk, so that it will carry both the VLAN info
4. on your Labtop/PC give the IP address in the newly defined range
5. Make your switch port to be in the new VLAN

This will work , if you wont be able to configure the above settings, let me know i will give you the detailed config

Nov 01, 2010 | 3Com 4500 24-Port Ethernet Switch

1 Answer

Hi,this is pavan i want to b configure the HP procurve 2626 J4900B managed switch pls help me through anybody by giving the programme to configure it


What do you need it configured to support? Multiple subnets? VoIP support?
Here's an example to support 2 subnets, VLAN 1 Data and VLAN 2 Voice. This switch is the VLAN router for the site and it is also the default gateway for all the devices on the network.

show running-config

Running configuration:

; J4899A Configuration Editor; Created on release #H.10.50

hostname "HP 2650 dot 11 layer 3"
snmp-server contact "Your contact info here"
snmp-server location "Server Rack - Upper Switch"
time timezone -5
time daylight-time-rule Continental-US-and-Canada
interface 49
name "Uplink to HP2650 port 49 - 192.168.105.12"
flow-control
exit
interface 50
name "Uplink to HP2650 port 49 - 192.168.105.13"
flow-control
exit
ip routing
timesync sntp
snmp-server community "public" Unrestricted
vlan 1
name "Data"
untagged 1-46
ip address 192.168.105.11 255.255.255.0
ip helper-address 10.50.3.2
tagged 49-50
no untagged 47-48
exit
vlan 2
name "Voice"
untagged 47-48
ip address 10.50.3.11 255.255.255.0
ip helper-address 10.50.3.2
tagged 1-46,49-50
exit
ip route 0.0.0.0 0.0.0.0 192.168.105.1
spanning-tree Always turn on Spanning Tree
spanning-tree priority 0 This switch is the master Spanning Tree operator.
password manager
password operator

Sep 20, 2010 | HP ProCurve 2626 (J4900B) 24x10/100 Mbps...

1 Answer

Problem Dell PowerConnect 6248


go to the web interface and disble storm control and flow control

Dec 08, 2009 | Computers & Internet

1 Answer

Inter-vlan routing


Unfortunately, the 5224 is a Layer 2 switch. In order to route between VLANs, you need a Layer 3 device somewhere else on your network. In other words, either a true router, or a multi-homed PC acting as a router, or a true Layer 3 switch. The 5224 is incapable of routing within itself. Sorry!!

Nov 09, 2009 | Computers & Internet

1 Answer

3 vlans, data,1; data 2,;voip,5. Ports carry voice tagged, and data. currently Windows 2000 DHCP server lives on Vlan 1 (AND WORKS). Need to upgrade. When we test the new servers we are unable to make both...


Here's what you need to do:

First, be sure to assign an ip address(in the proper subnet) to each VLAN.

Second, use the ip helper-address command in the context of each VLAN, the address used should be the address of the DHCP server

Third, Add a scope for each additional VLAN on the DHCP server.

The switch will route the DHCP request to the proper server based on the ip helper-address command parameter and based on the ip address of the VLAN that is passed tot he server, a DHCP address in the proper subnet is automatically configured.

Here is a sample:

ProCurve Switch 3500yl-24G-PWR# configure
ProCurve Switch 3500yl-24G-PWR(config)# vlan 33
ProCurve Switch 3500yl-24G-PWR (vlan-33)#ip address 192.168.33.254/24
ProCurve Switch 3500yl-24G-PWR (vlan-33)# ip helper-address 10.1.2.250

Aug 06, 2009 | HP ProCurve 4104gl Networking Switch

1 Answer

Static ip address to dell powerconnect switchport for backbone


try for 195.9.200.00 - 195.9.200.32 series hope it will works

Mar 23, 2009 | Dell PowerConnect 6024F (p624fnp)...

2 Answers

IP Addressing by dhcp for vlans


tell each vlan about DHCP server using

ip helper <DHCP servers ip adddress>.

in config mode.

Mar 03, 2009 | Cisco Catalyst 2950 24x10/100 Mbps...

2 Answers

Sending DHCP request across diffrent vlans


Hmm... on your DHCP server, try setting the "default router" IP for each pool to be the VLAN ID on the switch.

scope 172.16.0.0 /24
router 172.16.0.1

scope 10.20.8.0 /22
router 10.20.8.1

I think the DHCP replies aren't going back where they should. I've never done this without a router doing all the DHCP, but it does work and i've done it many times. Your config looks spot on for the switch.

Feb 01, 2009 | Cisco Catalyst 3750E-48PD

3 Answers

Routing vlans on 3com switch 4500


i can't set ip address over 4 vlans. the 3com switch 4500 always give error message "there's not enough routing resources available".please help....

Oct 28, 2008 | 3Com 4500 24-Port Ethernet Switch

2 Answers

Inter Vlan routing


Just For InterVLAN routing, Mark (enable) administration Access for ALL VLAN :P

Sep 18, 2007 | Computers & Internet

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

398 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dell Computers & Internet Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

mukhtar21 shaikh
mukhtar21 shaikh

Level 3 Expert

2017 Answers

Are you a Dell Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...