Question about Fusion FEW12PK Car Subwoofer

2 Answers

Amplifier problem i installed a fusion sub and amp in my car the other week and it came on how it should for about 5 minutes then went back off again and i couldnt get it to go back on. a couple of days later i re-wired it to make sure everything was how it should be and it came back on, this time it was on for longer and i thought i had sorted it but sure enough a couple of hours later off it went again.anyone got any ideas? cheers cerin

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: amplifier problem

Chceck if its not over heating. If its very hot move it to the different place or install a fan

Posted on Aug 23, 2007

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 62 Answers
Re: amplifier problem

Check your grounds, and all of your wiring. Does it just shut off or does it blink and go into protection mode?

Posted on Mar 25, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

I have got the Fusion FJL-1211 Class D Amplifier.When i turn the music up the amp switches off and back on until i reduce the volume and it plays fine.

your overloading the amp and its going into protect mode. turn the bass down on the deck or adjust the controls on the amp itself. get lower power rated sub(s) or more powerful amp since you won't be able to push the sub(s) you have with that one since the sub(s) is/are pulling too much power from the amp.

Aug 18, 2010 | Fusion Car Speakers & Subwoofers

1 Answer

Subwoofer not getting max bass

try using a ohm meter and if its not making what the factory specs are its most likly it will keep loosing more and more power then stop working which is what ive had happen to me before

Mar 11, 2010 | Fusion RE-PK2120 900W Bass Pack: Amplifier...

1 Answer

I have a 900 watt amp and 2 12" fusion subs.will this sound good?

Yes. It should sound good.
Try in the trunk, facing the back of the seats.
A simple Infinite Baffle/Free Air setup, should work fine.

Jan 04, 2010 | Fusion FEW12PK Car Subwoofer

1 Answer

Hi i have fusion sub woofer can u help me to install just let me know how to install many wires so dotn know who to install in my car

  1. Batt + or B+ or Positive.
    This is the connection directly to your automobiles battery. It should be a fused connection rated to about 15% higher than the fuse installed in your amplifier.
  2. Negative or '-' or Ground.
    This wire should be just as thick as the 'Batt + or B+ or Positive' wire. This wire can attach to any solid clean metal connation in the vehicle. Usually a trunk latch.
  3. Remote or amp startup wire.
    This wire is a thin 12V wire that will come from the deck. It's a signal wire that tells the amplifier to turn on.
  4. Inputs
    Low level inputs are in the form of RCA connectors and will require that your deck or head unit has low level or RCA outputs. High-level inputs are used for stereos that don't have low level or RCA outputs. They work by taking an audio signal directly from the vehicles speakers and then amplifying it as necessary.
  5. Speaker connection.
    Match the + and - these with the appropriate connectors on the speaker box. Red means + and Black means -.
    I hope this helps.

Jul 06, 2009 | Fusion FEW12PK Car Subwoofer

1 Answer

Sub keeps loosin bass

Its probably not your subwoofer- its likely that your amp is showing its age after 2 years of bumping -But it could be that you have partially roasted the coil on the sub which is tripping your amp into protect mode-thus shutting down throw a different sub in there for a week and listen to it and if it stops acting up then its probably the sub if it still shuts down then it may be time for a new amp

May 29, 2009 | Fusion FEW12PK Car Subwoofer

1 Answer

Sub cutting out

Check the 12v wire running from the battery to the amplifier. Also the sony explode is a garbage subwoofer compared to the Alpine.. sony (they say 1200w max but its more like 100w to power the thing) Amp could be going. Is the amplifier hot when running. If there is a burnt smell comming from the amp, its the amplifier

Mar 27, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

2 Answers


check all power coming to your amp remote especially

Jan 21, 2007 | Fusion FEW12PK Car Subwoofer

Not finding what you are looking for?
Fusion FEW12PK Car Subwoofer Logo

Related Topics:

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fusion Car Speakers & Subwoofers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers


Level 1 Expert

32 Answers

Are you a Fusion Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides