Question about AudioBahn A8000T Car Audio Amplifier

2 Answers

Protection Light On

Im posting this for my friend. So today while listening to his system in the car one of the audiobahn amps went into protection mode and smells like something was burning. Didnt even notice until we smelled it as there was no pop sound. Is the amp pretty much dead? or does it just need to be off for awhile since he did have it turned up a bit to show me everything. any hope for fixing it or does he need to get another amp?

Posted by on

  • 1 more comment 
  • Anonymous May 13, 2008

    i have the same problem.

  • MichMetz Aug 13, 2008

    i have a similiar problem with my A8000v amp. no sounds, just dead. let me guess, only the protect light is lit? everything lights up but no sound? it's possible the channel blew =/

  • Anonymous May 03, 2009

    Protection mode on and nothing playing at all :-(

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • AudioBahn Master
  • 637 Answers

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you didn't fry speakers as well. Please check speakers impedance. A thumbs up would be greatly appreciated if this answer is helpful to you

Protection Light On - protection-light-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Posted on Feb 03, 2015

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 9 Answers

If the speakers are still fine, then I'd say it blew the transistors in the amp.

Posted on Jan 15, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I Have a audiobahn a1800dt its almost identical to this amp, i played it for a while with no problems, until i hooked up some crappy subs to it and it went into protection mode without comming out of it....


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Please check speakers impedance A thumbs up would be greatly appreciated if this answer is helpful to you

audiobahn-a1800dt-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Feb 03, 2011 | AudioBahn A18001DQ Car Audio Amplifier

1 Answer

My protection Light came on. How do I get it to go off?


audiobahn went out of busnes 5-8 years ago i wold replace the amp with a class d diferant brand

Jun 17, 2010 | AudioBahn A4002T Car Audio Amplifier

1 Answer

Hi I have a problem with my amp and would like to know what the root cause is. My friend gave me the amp and it was stored for about 6 months. On Saturday I went to connect the amp and the protection light...


sounds like a thermal overheat protect issue, sorry to break it to you but sadly the way most amps are built these days it's either not worth the cost of trying to repair or impossible to do so by hand. you'd be better off just getting a new amp

Sep 27, 2017 | AudioBahn A8001DT Car Audio Amplifier

2 Answers

Audiobahn a8002t amplifier in protection mode


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. audiobahn-a8002t-amplifier-in-protection-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg

Dec 21, 2009 | AudioBahn A8002T Car Audio Amplifier

2 Answers

No sound protection light on.


Either blown subs, or bad amp.. Disconnect the subs, and try turning the amp on, if the amp is still in protect then your amp is bad, if the protect light goes off, then your subs are bad, or possibly wired at to low of an impedance, but I don't think that will trigger the protect on an Audiobahn amp.

Aug 21, 2009 | AudioBahn A2002T Car Audio Amplifier

1 Answer

Audiobahn A6601T amp. Protection light on. No Sound output.


Disconnect all speakers from the unit and then switch it on. If the protection light is still on then the output stage in the amplifier is blown.

May 12, 2009 | AudioBahn A6601T Car Audio Amplifier

1 Answer

ABR100T Audiobahn Bass remote not working correctly?


i had the same thing happen to me on my 2300hct audiobahn. it turned out to be the remote. but soon after my amp went dead. i than switched to JL no problems since.

but i still use audiobahn immortal 12's.

Apr 11, 2009 | AudioBahn ABR100T Remote Bass Control For...

1 Answer

Audiobahn DUB Mag Audio 2502 Amplifier


If the protection light is on, the amplifier likely has shorted output transistors. To eliminate other possible causes, read through the following page.

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Aug 07, 2008 | AudioBahn DUB Mag Audio DUB2502 Car Audio...

3 Answers

My amp is on but the protection light stay's on!!


Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If the protect light remains on, the amp likely has blown output transistors.

Feb 28, 2008 | AudioBahn A2801Q Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A8000T Car Audio Amplifier Logo

Related Topics:

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22359 Answers

Jerry Naidoo

Level 2 Expert

151 Answers

Robert Rankin

Level 2 Expert

356 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...