Question about JVC RX-E100 5-Channel Amplifier

1 Answer

Kenwood stereo control amplifier KC-206 doesn't work

Hi. Thanks for looking at my question. I have a KC-206 preamp which won't work. It lights up and the front controls appear to work but the digital volume indicated flashes 3 or 4 times when the unit is turned on then freezes at 4 on the volume scale. I got this along with a kenwood amp on ebay (I only needed the amp) and would hate to throw it away. I've seen on the internet where this might be a problem with the remote control (which I don't have). I haven't hooked the unit up to a power amp yet but assume this wouldn't change the problem. Turning the volume control knob does not alter the frozen volume position. Any help would be appreciated. Thanks. Ken

Posted by on

  • Anonymous Dec 09, 2008

    I have the same issue. Any way to disconnect the remote infrared? Any way to reset so the remote feature is off?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I found this thread when I was having the same problem with mine. Turns out that it's sort of a problem, but not really. Looking at the manual (which I found in another google search) I believe a "4" on the volume level corresponds to a default remote control setting. The remote varies the level between 0 and 10, but the "10" corresponds to the maximum volume setting on the preamp. So it actually works, it's just that the "4" reading doesn't change. There's probably a pin you can short somewhere to make that default to "10" which would be ideal. But I'm not sure where that is. Now on to my other problem. This particular preamp has a subtle 120 Hz hum...

Posted on Dec 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How can i hook up my kenwood stereo control amplifier KC-105 to my GPX home stereo system?


If the GPX has an headphone output you could use the a stereo headphone jack to two phono cables lead. Connect them to the "aux" socket of the amp, or another suitable - not a phono or deck - socket.
You would have to keep the volume level low on the GPX unit, but apart from that all the functions should work.

Aug 04, 2015 | Kenwood Audio Players & Recorders

1 Answer

I have a Kenwood KC 105 preamp and the volume is stuck on high. I turn the volume knob but it does nothing. Any suggestions?


Looks like you are going to have to replace the potentiometer, AKA volume control. It must be shorted out inside (probably) or knob came off the shaft. (doubtful)

Feb 02, 2015 | Kenwood Sc-75 Av Surround Processor...

1 Answer

Kenwood Stereo integrated amplifier A-58


hi i have bought kenwood hi fi with following parts -
integrated amplifier - A-58
cd player - DP-M58
stereo receiver - T-58L
twincassette player - X-58
turntable - P-38
but I can't get owner manuals from anywhere. Can you help me with it please ? marek922@vp.pl

Jun 29, 2012 | Kenwood Audio Players & Recorders

1 Answer

Have a kenwood stereo control amplifier kc-206.. stopped working only clicks and no power. is it fixable? is there a fuse? all other parts work.


Generally speaking, an amp protects itself from heat, shorts, overloads and operator exuberance by refusing to turn on or stay on.


Overloads can be from excessive periods of high output or marginally low impedance loading by the speakers; and shorts would be wiring issues or a speaker blowing up.


You should be able to feel if it's hot. WHY is it overheating? Make sure it has sufficient ventilation on all sides and that vent holes are not blocked by dust balls. Ensure the fan (if equipped) is running as designed (some only operate on demand). Clean dust and debris from it.


If the amp comes back on after cooling, you're lucky. They only have so many self-protection cycles in their lives so continuously resetting or cycling their power without addressing the cause can do more harm than good.


If it protects immediately on a cool power up you should disconnect the speaker connections and try it 'naked'. If it comes up then diagnose which lead(s) are shorted. If it does not come up the problem is internal and should be left to an experienced and competent hands-on tech.

Mar 11, 2011 | Audio Players & Recorders

1 Answer

Kenwood stereo control amplifier KC-206 doesn't work


I was able to use an universal remote control that I have, a Radio Shack Kameleon 6 in one remote control which I was able to program to run the audio portion of the Kenwood KC 206 control preamp. By adjust the remote sensor volume to max, I was able to get maximum volume out of the unit and drive the power section very nicely. Now I have to get up and manually turn the manual volume control for addition volume adjustment.

Hopefully Ken can find a remote that he can control the Kenwood control preamp the same way I did. Good luck here.

Dec 02, 2008 | Audio Players & Recorders

1 Answer

How do I hook up a Kenwood KR11000G Stereo Receiver with a Kenwood C2 Stereo Control Amplifier and a Marantz 1152DC Integrated Amplifier ?


hey spanky, no worries, just about to go to bed...11.40pm here. Will follow up tomorrow:) Cheers mate

robotek

Jul 21, 2008 | Audio Players & Recorders

3 Answers

Kenwood Home Stereo System


this outdated system,but a regular rca cable will inter connect the components.as or the remote Box i am not aware of any.

GoodLuck
BIGRED

Feb 17, 2008 | Audio Players & Recorders

3 Answers

Kenwood control amp KC-206


Sounds like a low voltage to the front panel as the indicators are there such as control window illumination is dim and the remote does not function.
The remote sends an invisible signal to a detector just behind the front panel and if the signal from the remote is nice and strong from your new batteries in the remote then it must be the panel electronics.

I have found that if you clean the output panel of the remote with a damp cloth and the same to the front panel glass you may be lucky. Just Damp please not dripping in water!!!!!

If ypu keep the amplifier system very clean then this wont be the problem...But this action has worked on TV's with remotes...

If this doesnt work then a service is due....sorry....no quick fix..

Cheers YOU BEUT

Oct 26, 2007 | Audio Players & Recorders

Not finding what you are looking for?
JVC RX-E100 5-Channel Amplifier Logo

843 people viewed this question

Ask a Question

Usually answered in minutes!

Top JVC Audio Players & Recorders Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

69955 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

Are you a JVC Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...