Question about Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum

3 Answers

No pwer Vavuum died won't come back on, I have power in the plug.

Posted by on

  • 4 more comments 
  • collinsd Dec 20, 2008

    second windtunnel just purchased and it just cuts off. power is in cord.

  • Anonymous Dec 28, 2008

    I have the same problem!! I waited several days and it still won't power on. I wonder if it has a reset switch somewhere near the motor?

  • rgrayjr Jan 01, 2009

    was vacumning when power went off. pickup tube was clogged, unplugged and waited for cool down, still won't work...Can anybody help, is there a reset button somewhere

  • mike644 Jan 09, 2009

    about 6 months old and it just stopped working. I waited 30 minutes and still nothing... will try again tomorrw, but I would highly discourage anyone from buying this vacuum. I also have a dirt devil that cost the same that sits in my garage because the beater bar loses traction even though the belt is new.

    I should've just bought the dyson, but instead I have 2 $200 vacuums that don't work :(


  • Anonymous Jan 31, 2009

    cant find reset button

  • Anonymous Feb 19, 2009

    This vacuum shuts off after 15 minutes of use and we have to wait a couple of hours before it will start up again. Thorough cleaning of filters helped a little, but didn't solve the problem.

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Our Hoover U5780-900 stopped working while using the attachment. We let it cool down for about 5 minutes and it fired back up. It appears to shut down when it overheats.

Posted on Nov 18, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Unplugg from wall and wait 30 minutes for the thermal protecor to cool off....

Posted on Jan 01, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Vacuum died no power when I was useing it. Tried changing outlet still doesn't work.

Posted on Nov 23, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My Electrolux Rapido wet&dry won't start. The battery is empty and the blue light flashes when I plug in the charger.


this sounds totally silly but is the power button on the vacuum actually off? Had the same problem, where the battery was completely empty i didn't know my son had switched the vacuum on put it on charge and the light was flashing. I took it off the charging stand pressed the power button then put it back....now charging perfectly. Anyone who doesnt have this appliance will think you sound stupid but its just a clicky button so visually the button looks the same on or off.

Apr 04, 2013 | Electrolux Zb4106wd Rapido Wet And Dry...

1 Answer

My kirby G6 2000 no pwer


More than likely you have a short in your power cord. however if you want to know for sure take machine apart until you can put an elec meter on switch where cord is attached. plug machine in and test the end of cord that is attached to switch if you have 120volts at that point its your switch thats bad. if you have no voltage or anything less than 110volts at the switch replace cord

Jan 14, 2013 | Kirby Ultimate G Bagged Upright Vacuum

3 Answers

I have a brand new KitchenAid mixer that is 5 years old and never used. I unpacked it this morning and it won't turn on, no noise, no movement, nothing. Help.


Please check manually the motor and see if it moves freely. Now make sure that the power plug and the connections to the switch are not tampered , check the continuity of the plug to the switch and to the motors.
If you notice any dirt or insects make sure that this has not clogged on the motor. If so clean using a degreasing spray- WD40- would be recommended.
If the motor is tight , lightly oil or degrease using the spray while manually rotating.
Once this is done connect the power while taking all precaution. Use the meter to check the flow of the circuit to the switch and to the motor. If there is a trip switch see that it is reset.
If there is power to the motor and still it does not work the brushes might be dirty and might need a cleaning/ reset.

Jul 07, 2011 | Vacuums

1 Answer

Cuisanart 10 c programmable coffeemaker won't work; no light comes on & it is plugged in. It has been working fine.


Check it's fuse inside, a blown or open fuse will cause won't work. Similar also happened if the cord wire is already open. Same goes also if the power switch is already defective. Either of those I mentioned will cause the unit not to work.
Thanks for asking.

Jun 25, 2011 | Vacuums

1 Answer

There is no power...seems like a motor problem. The bag is clean...the mouth is clean the plug us in...NOTHING! I took mouth off and manipulated/pushed in that power press area that engages the motor on...


The front safety switch must be pushed in by either the hose or head (or manually), before the on/off switch will operate. The most common reason for no power is a bad cord. Second most common is worn carbons in the motor, and third is a bad switch.

Dec 25, 2010 | Kirby G4 Bagged Upright Vacuum

1 Answer

Why wont the self propelled brush on the hoover wind tunnel work. large belt is ok. the small belt looks 0k.


no don't do that,have a little patience.check where the self propelled assembly is and see if anything got in there,something might be loose and the teeth are meeting each other.thats a good vavuum.i have 2 but their not self propelled.try taking the belt off the self propelled machanisn and try it again.if it works then something is keeping the propelled machanism from working.dig a little deeper,what do you have to lose?

Mar 24, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover power drive vacuum cleaner simply shut off and died


my hoover vacuum is very hard to push forward but easier coming back.Any help will do.

Jan 24, 2009 | Hoover U6311-930 Power Drive Bagged...

1 Answer

My hoover power drive vacuum simply died. It just shut off. I checked the plug, etc...I just can't get any power...Can you help?


If no light or motor sound cord is probably bad. Look near AC plug or just replace the plug end. Check with ohmmeter for continuity with switch ON.

Jan 24, 2009 | Hoover U6311-930 Power Drive Bagged...

1 Answer

Eureka 5892AVZ Bagless Upright Vacuum has become extremely noisy


This link will give you a copy of the owners manual that will help you some
http://www.eureka.com/service/manuals/80244.pdf
Hope this helps. biigg53566

Dec 06, 2008 | Eureka 5892AVZ Bagless Upright Cyclonic...

Not finding what you are looking for?
Hoover U5780-900 Windtunnel Cyclonic Bagless UprightVacuum Logo

554 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...