Question about Garden

Open Question

Flotec pump model#FPOS1775A stops pumping

Pump stops while water is still in hole. It starts and shuts off. Bastment is still getting water in. I thought pump would stay on as long as water was still in window well.

Posted by on

  • 1 more comment 
  • BlackToe Jan 02, 2009

    Just installed the same unit in my crawlspace. The manual states it will cycle for 15 minutes, and then run normally. It's been 30 minutes, and the pump is still cycling on/off, even though it's sitting in 4 inches of water.

  • mzzz1 Jan 07, 2009

    Related problem - my FPOS1775A will not shut down, even when it is sitting on dry floor.

  • Anonymous Mar 04, 2009

    same problem and soes not pump water out

×

1 Suggested Answer

  • 4 Answers

SOURCE: my Flotec pump runs 5 seconds shuts off for 30

fully submerse pump in bucket of water, tilt to get all air bubles out,(keep hose off) plug in and it should work fine

Posted on Apr 03, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Flotec Float switch did not automatically shut off,enginburn out


Hi Lamont .. I would first check test the float switch and make sure that it is faulty, set it up in a tub of water and manually move the float switch. see if it cycles on and off. sometimes the float will get hung up on its support or on the edges of the sump pit. If the float switch is faulty then YES it can be replaced,. try a building supply store like home depot or the pl;ace where you got the switch originally.

Please Vote !!

Jun 01, 2010 | Flotec 13 Hp Automatic Submersible Sump...

1 Answer

My Flotec pump runs 5 seconds shuts off for 30


fully submerse pump in bucket of water, tilt to get all air bubles out,(keep hose off) plug in and it should work fine

Dec 02, 2009 | Flotec 1/6 Hp 1260 Gph Utility Submersible...

1 Answer

No more then 30 pounds of presure and wont shut off. Flotec water


If the pressure does not get pass 30 psi, then check for leaks along the pipelines and on the tank itself. An air leak on the top portion of the tank can cause the pressure not to trigger the pressure switch. Use soap bubbles to detect any air leak. Although a stuck pressure is not more likely the problem, check it also.

Aug 31, 2009 | Flotec 1/2 Hp Stainless Steel Waterfall...

1 Answer

Flotec pump takes long time to pressure up. Has worked fine for ~15 years + but noticed the last month or so it runs and runs even after water use is shut off. It's like it's half the pump it use to be. We...


This could be a problem it the pump caused by freezing, check your drain plugs first to see if their cracked or loosened. They will quite often be made if a softer nylon that will crack first and drain pump in the fation of many fail safes. A place to try on-line for parts that may help is "Optimus Home" But I would check the plugs first.

Jul 19, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

What size submersible pump do i need to deliver 20000l/hr ,pump is 50 meter deep in bore hole.


That's a lot of water. In the U.S. , pumps are rated in GPM (gallons per minute. Your 20000 liters per hour converts to 88 GPM. So you need to find a pump that can produce at least 88 GPM.

Jul 11, 2009 | Flotec 1/2 Hp 3000 Gph Utility Submersible...

1 Answer

Switching off too soon.


you don't need to replace the switch just raise the upper stop up higher so the float can go higher before turning the pump on, it should have a rubber gromet on it slide it up the rail

Jun 21, 2009 | Flotec 3.4 Hp Floodmate Submersible Sump...

1 Answer

Pump is leaking oil


very iffy to get to seal properly and for the $40 bucks cheaper to get new one

Apr 29, 2009 | Flotec 1/6 Hp 1260 Gph Utility Submersible...

2 Answers

Flotec Sprinkler Pump not priming


it might be that the pump is prewired at 230 volt and you are running a 115 power supply to it, if motor just humms and little water comes out this might be your fix

Mar 13, 2009 | Flotec 1 - 1/2 Sprinkler Pump Composite...

1 Answer

Motor running but not pumping any water, why?


You very well could have a bunch of Sediment on the Intake for the Water OR The water table has Drpped Below the Pump.

Jan 19, 2009 | Flotec 1 Hp Deep Well Pump

Not finding what you are looking for?
Garden Logo

Related Topics:

666 people viewed this question

Ask a Question

Usually answered in minutes!

Top Garden Experts

EugenesDIYDen
EugenesDIYDen

Level 3 Expert

479 Answers

Dennis Key
Dennis Key

Level 3 Expert

2458 Answers

john h

Level 3 Expert

7409 Answers

Are you a Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...