Question about Hitachi 62VS69 62" HDTV

2 Answers

Hitachi 62vs69A no picture no sound steady blue power light only

Checked the 3 fuses, bulb, connections, everything that I could get to by removing rear panels and pulling the board out as far as possible. Four months out of warranty.

Posted by on

  • 3 more comments 
  • ChallengerTA Nov 19, 2008

    I just replaced the lamp and no change. The blue power light comes on if you hold the power button in. I does not flash and still no picture. The remote does not turn the power on or off either, new batteries in it too. I can hear the relay click on and off each time it is plugged in or unplugged but a single click only, does not click continuously.

  • ChallengerTA Nov 19, 2008

    I read some where too that it could be a ballast. Does it sound that that could be a possibility?

  • ChallengerTA Nov 19, 2008

    Thanks Fixyy and kevin0000. Looks like it may be this power board (for lack of a better name) and that I'll need to trouble shoot it at the component level. I'll down load a service manual and get back with you. Now the hard part, getting my big hands in there to unplug all of thos small connectors so that I can do the bench work.

  • ChallengerTA Nov 19, 2008

    fixyy - It's been unplugged since the 14th untill tonight (18th) when I tried the new bulb.

  • ChallengerTA Dec 08, 2008

    I'm still working on this as time and Hollidays allow. I did find the Service Manual online and downloaded it. I've got the Power Board out and just started to trobleshoot and have found nothing yet.

    As mentioned in another suggestion that someone would have to come in and read the codes and reset them. This would have to be by some kind of scan tool or device that could be plugged in some where because there is nothing that appears on the screen. Outside of forcing the blue light to come on by holding it in and hearing a relay click when it's plugged/unplugged, it's dead.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 181 Answers

Unplug the device for some time then reconnect it and check out. if this does not solves your problem then on the main board check out for any loose capacitor or any faulty burned or leaked capacitor,that has to be replaced as because of that faulty capacitor the circuit is not able to complete and showing this problem.just get it checked and replace it properly. u can get new capacitors and other spares at radishack websites. thanks.

Posted on Nov 19, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,847 Answers

Seem like the power supply is blown off.

Posted on Nov 18, 2008

  • Legin Varghese
    Legin Varghese Nov 19, 2008

    Ok you have the steady blue then it seem issue with the light engine. There's a good chance that it's not the worst, like a light engine failure... Bad news is you'll need a tech to do it. It need to have a memory initialization done from the I2C menu. There
    are a list of codes the tech will write down from the I2C menu then
    perform the MI.. Then he goes back in and resets the codes from his
    notes.. That's the boiled down version, but there is a lot to it - take
    my word..

    When calling around to shops to find someone qualified ask how much
    they charge for performing a memory initialization per Hitachi bulletin
    and see what their comeback is - - ...

    And let me know how this turns out for you.

    I have had people on this forum that wanted the instructions and tried doing it themselves, but one ended in disaster

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound, no picture.


Hitachi DLP Television Bulb

Most likely a bad lamp. I would replace it first to make sure.

Sep 06, 2015 | Hitachi Projection Televisions

1 Answer

Tele has sound but no picture


Time to replace your lamp on your tv.

Mar 20, 2015 | Hitachi 62VS69A

1 Answer

No sound/picture and red power light always on (Hitachi 43FDX15B)


When u turn the tv on,u hear alot of clicking?That mean the Ballast that help the projection bulb to work is dead.Change the Ballast,might as well change the bulb too.U don't know what is the condition of the projection bulb in.

May 29, 2010 | Hitachi 43FDX15B 43" Rear Projection...

2 Answers

Tv turns on for a few seconds then the picture and sound turns off and the blue power light just blinks


It will do the same thing, until a repairman comes out, and services the TV set...

Symptom: No power / Dead Unit / Comes On and protects itself, Power LED may blink in 3 or 4 times cycles.

Cause: Check/Confirm SDR buffer ICs are not shorted, follow link to check. If so, replace affected SDR PWB.

That's what MY Hitachi service portal says...
Do you have one?
It's kinda like a crystal ball or magic carpet....not many people have one, but Hitachi techs do....

Eeenie Meenie Chili Beanie the spirits are about to speak

Nov 07, 2009 | Hitachi 51F59 51" HDTV Projection...

1 Answer

I have a 50vs810 dlp. The blue and red lights flash in sequence when I turn it on.When they stop flashing the red light for the lamp is on. The yv has no volume and no picture. Is it just the bulb or does...


More than likely, it is the bulb. My hitachi 50v715 would come on(light up and show picture) 3 to 30 sec's with out the lamp indictor even lighting up. Put a new bulb in and works great. So I would try a new bulb. Look in your manual for the bulb number. Buy an original hitachi bulb they last a little longer.

Nov 05, 2009 | Hitachi 50VS810 50" Rear Projection HDTV

4 Answers

Hitachi 55" LCD projector tv


Pixiling problem--replace light engine
need your tv model # to get part #......T

Oct 16, 2007 | Hitachi 46F500 46" Rear Projection...

Not finding what you are looking for?
Projection Televisions Logo

Related Topics:

309 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Projection Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers

matt martin
matt martin

Level 3 Expert

1191 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Hitachi Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...