Question about Hitachi 62VS69 62" HDTV

2 Answers

Hitachi 62vs69A no picture no sound steady blue power light only

Checked the 3 fuses, bulb, connections, everything that I could get to by removing rear panels and pulling the board out as far as possible. Four months out of warranty.

Posted by on

  • 3 more comments 
  • ChallengerTA Nov 19, 2008

    I just replaced the lamp and no change. The blue power light comes on if you hold the power button in. I does not flash and still no picture. The remote does not turn the power on or off either, new batteries in it too. I can hear the relay click on and off each time it is plugged in or unplugged but a single click only, does not click continuously.

  • ChallengerTA Nov 19, 2008

    I read some where too that it could be a ballast. Does it sound that that could be a possibility?

  • ChallengerTA Nov 19, 2008

    Thanks Fixyy and kevin0000. Looks like it may be this power board (for lack of a better name) and that I'll need to trouble shoot it at the component level. I'll down load a service manual and get back with you. Now the hard part, getting my big hands in there to unplug all of thos small connectors so that I can do the bench work.

  • ChallengerTA Nov 19, 2008

    fixyy - It's been unplugged since the 14th untill tonight (18th) when I tried the new bulb.

  • ChallengerTA Dec 08, 2008

    I'm still working on this as time and Hollidays allow. I did find the Service Manual online and downloaded it. I've got the Power Board out and just started to trobleshoot and have found nothing yet.

    As mentioned in another suggestion that someone would have to come in and read the codes and reset them. This would have to be by some kind of scan tool or device that could be plugged in some where because there is nothing that appears on the screen. Outside of forcing the blue light to come on by holding it in and hearing a relay click when it's plugged/unplugged, it's dead.

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 181 Answers

Unplug the device for some time then reconnect it and check out. if this does not solves your problem then on the main board check out for any loose capacitor or any faulty burned or leaked capacitor,that has to be replaced as because of that faulty capacitor the circuit is not able to complete and showing this problem.just get it checked and replace it properly. u can get new capacitors and other spares at radishack websites. thanks.

Posted on Nov 19, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,847 Answers

Seem like the power supply is blown off.

Posted on Nov 18, 2008

  • Legin Varghese
    Legin Varghese Nov 19, 2008

    Ok you have the steady blue then it seem issue with the light engine. There's a good chance that it's not the worst, like a light engine failure... Bad news is you'll need a tech to do it. It need to have a memory initialization done from the I2C menu. There
    are a list of codes the tech will write down from the I2C menu then
    perform the MI.. Then he goes back in and resets the codes from his
    notes.. That's the boiled down version, but there is a lot to it - take
    my word..

    When calling around to shops to find someone qualified ask how much
    they charge for performing a memory initialization per Hitachi bulletin
    and see what their comeback is - - ...

    And let me know how this turns out for you.

    I have had people on this forum that wanted the instructions and tried doing it themselves, but one ended in disaster

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound, no picture.


Hitachi DLP Television Bulb

Most likely a bad lamp. I would replace it first to make sure.

Sep 06, 2015 | Hitachi Televison & Video

1 Answer

Hitachi Plasma P50S601 no picture sound OK


probably needs new scan drive board along with upper and lower buffer boards. it wont be cheap and its best to have a tv shop do it.

Aug 30, 2009 | Hitachi Ultravision P50S601 50 in. Plasma...

1 Answer

No Picture or sound


The lamp cover door was not secured tightly. Door does not "push" shut easily. Got a little rough with it and latched it shut, then the tv worked fine.

Jan 27, 2009 | Sony KDF-E50A10 50 in. LCD HDTV

4 Answers

Hitachi 55" LCD projector tv


Pixiling problem--replace light engine
need your tv model # to get part #......T

Oct 16, 2007 | Hitachi 46F500 46" Rear Projection...

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

309 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Televison & Video Experts

Jaime Hernandez

Level 3 Expert

2307 Answers

The Knight
The Knight

Level 3 Expert

73118 Answers

matt martin
matt martin

Level 3 Expert

1207 Answers

Are you a Hitachi Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...