Question about Hoover Floormate H3000 Upright Wet/Dry Vacuum

14 Answers

Not spraying liquid.

My floormate won't seem to spray the formula/water -because I only always use hot water without any agents- when I pull the trigger. I have taken it apart, and can't seem to find a problem with the plunger part...maybe there is a clog in the line that goes down? Any ideas? What a bummer having to use a spray bottle to wet the floor...

Posted by on

  • 11 more comments 
  • Anonymous Nov 03, 2007

    The cleaning solution does not dispense when I pull the trigger. Nothing comes out onto the floor at all. I have tried taking the entire thing apart & no luck.

  • Anonymous Nov 23, 2007

    I had the problem When i removed the handle (grip where you hand gows through) I found it Cracked and it did not allow the triger to move correctly. I found a handle online for $5.95 and replced it works like new

  • Anonymous Dec 01, 2007

    Doesn't spray liquid. So I don't know if it will pick it up. How do you solve the problem of it not dispensing the liquid and why do you have to go through so much trouble to get an answer?

  • scotty06 Dec 05, 2007

    My floormate won't seem to spray the formula/water -because I only always use hot water without any agents- when I pull the trigger. I have taken it apart, and can't seem to find a problem with the plunger part...maybe there is a clog in the line that goes down? Any ideas? What a bummer having to use a spray bottle to wet the floor...



    thanks

    scotty06

  • yukky Dec 08, 2007

    water will not come out~ vacuum working fine

  • Anonymous Dec 30, 2007

    i pull the trigger and can not get the solution to come out at all.. i can not see the clog - it sucks up - vacuum is fine but i need to wash the floor .. not sure what may have happened...

  • Anonymous Jul 06, 2008

    floor-mate not dispensing cleaning solution

  • joannieb51 Jul 19, 2008

    want spray water

  • tbruton Jul 20, 2008

    I pull the trigger and no liquid comes out. I have to wet the floor and use the unit to pickup the water. HELP I have 2 hoover products hoover floor mate and the hoover floor mate plus. They have the same problem

  • Anonymous Aug 08, 2008

    the solution does not come out of my floor mate, my daughter's and my son's. It worked fine for a short time, i loved it. i have checked it out several times. there seems to be a piece on all three broken off in same spot. this part should be a recall. we have used this product very gently. i can no longer recommend it.

  • tbolt96 Aug 08, 2008

    It works! Thanks! I didn't have the pieces you mentioned, so I clipped a tiny tip off a tine of a plastic fork and attached it to the post with Elmer's Glue. Problem solved. You guys are great!

  • roux3 Aug 28, 2008

    I've been using my Floormate for about 7 years, I think. It has stopped dispensing the cleaning liquid, but it does suction and scrub okay. I'll welcome any ideas. Thanks.

  • Anonymous Aug 29, 2008

    I had the same problem with my H3000 Floormate and I used the "dab of hot glue" method mentioned. It WORKED! Thank you so much for the help!

    : ) Laura


×

Ad

14 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This is where you attach the Lego.

Not spraying liquid. - not-spraying-liquid-pi02cr1kttkrastpy2vlmywc-3-1.jpg

Posted on Dec 01, 2014

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I used a round lego piece and used a hot glue gun to glue it to the plastic piece on the base that pushes in on the plunger on the water container. It fit perfectly on the round plastic piece. Works great now! Thanks for all the suggestions.....we were ready to throw it away.

For a picture of the lego piece I used go here:
http://us.factory.lego.com/pab/?warning=false
and search for "round plate" in the box labeled "brick name"

Posted on Jan 16, 2008

Ad

I used the glue stick trick it worked great ty!!! I was worried i would have to go back to a nasy old mop again

Posted on Jul 13, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

My model is H3010 so may be slightly different than the H3000. I used just a small "blob" of the hot glue stick on the tip top of the post (that sits in the centre of the round black rubber grommet over which the release valve of the liquid holder sits). The additional length when the glue hardened and cooled was only about 1/16".
Note: First I had tried the 1/4" glue stick solution but that must have been too much additional length on the post on my model, because the liquid kept leaking out when I replaced the liquid container over the post (I suspect the bottom of the container was being pushed up so much it didn't seal against the grommet).

Posted on Jun 15, 2008

  • a54321 Aug 15, 2011

    I had the same problem and someone suggested re-seating the plug in the liquid dispenser. Empty the cleaning solution and press down the little pop-up thing inside it a little bit. When you turn it over there should be two little black things on the plug that should extend about 1/16th of a inch below the bottom of the tank. Perfect!

×

I am still confused about where to put the piece from the glue stick. Can anyone help. It seems like that will fix the problem.

Thanks!

Posted on Jan 11, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The glue stick works great but make sure you put it on the place that pushes on the tank where cleaning solution or water is. I was confused at first where to put the glue stick. It goes on the tank it self or the little post that releases the water in the tank.

Posted on Nov 12, 2007

Thank you so much for helping me out. I was lost without my floor mate and I could not afford a new one. The glue stick solution worked for me. Many thanks

Posted on Sep 26, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I just started having the same problem and I have to say - I love the internet!!! What did people do before being able to 'google' answers to problems!! I messed around with the plunger thingy and it works great! (like my technical jargon?)

Posted on Aug 30, 2007

I FOUND THAT MY PROBLEM WAS THERE WASN'T ENOUGH PRESURE ON THE SEAL OF THE SOLUTION TANK FOR THE WATER TO COME OUT. I TRIED THE GLUE STICK METHOD AND USED JUST ABOUT A 1/4 INCH SLICE, MELTED IT AND PLACED IN ON THERE USEING TONGS AND IT WORKED! JUST WHEN I WAS ABOUT TO GO OUT AND BUY SOMETHING ELSE. THANKS GUYS.

Posted on Aug 04, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Our floormate had the same problem. I did the Lego trick - a Lego rubber tire fit perfectly! And it worked like a dream! Thanks, Kannas Dennis

Posted on Jul 05, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

The real problem is the rubber seal slides down on the plunger shaft and this does't allow the seal to move far enough away from the seat when to let water flow. All that is needed is to remove the plunger and reseat the seal correctly on the shaft of the plunger. Check by veiwing the plunger move up at least a 1/4 in from seat on container. This will cure the water flow problem.

Posted on Jun 25, 2007

Wow.. you guys are good!!.. I didn't find a lego or a tire for a hot wheel.. but I found a glue stick for a hot glue gun. I cut off a piece about a 1/4 of inch.. made it soft by heating over a candle.. and placed it on the plunger. POOF.. it works again!!.. now can ya tell me how to get the scrub brushes to work again?? Thanks!!!

Posted on Mar 23, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I saw the lego solution, but couldn't find a lego that worked for me. I tore a wheel off of a matchbox car and glued it to the part that pushes down the plunger. Score! My vac now dispenses the cleaning stuff/water. Thanks so much Kannas!

Posted on Mar 04, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem and eventually tracked it down to the tank not seating far enough onto the plunger part. You can test this by taking the tank out and seeing if water goes down when you pull the trigger. I found I could push down on the tank while operating and this would work, but it's not a really good solution. I finally put a small piece over the metal post in the plunger and this gives a tighter fit. I used a small round lego piece, seems like I've seen rubber caps or feet that might fit and do the trick as well.

Posted on Feb 06, 2007

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Won't pick up water from the clean water side


I couldn't view u'r clip but it seems if the pipe is blocked try to remove the blockage by using a hose where you spray hot water and normal dishwashing liquid, through the pipe, to unblock it. Just do not immerse the whole machine in water! Because I do not know what machine you have. Good luck my friend!

Mar 23, 2013 | Vacuums

1 Answer

When button is pressed, water does not come out of the holding canister. still seems to have suction, but water doesn't come out to rinse/clean carpet.


Please check the following with liquid in both tanks.


- Check to see if the machine will spray through the hose with the setting on tools. If it does, the pump is fine. Continue troubleshooting.

- Check for debris on spray tips. Clean them with a soft brush (on old tooth brush works well). The spray tips may be lifted out for easier access.

- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly. Depress the x on this gasket to ensure this depresses and release back out. Liquid from the tank should dispense.

- Remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.


If the machine continues to not spray, check the following:


REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Nov 22, 2010 | Bissell 9200 Upright Vacuum

1 Answer

Hey there, a friend of mine has a bissell pro heat 2x turbo, that is spraying no water on the floor setting, the pump works i assume, as the machine vibrates when the trigger is pulled, how would i...


Check the following with liquid in both tanks.


- Check to see if the machine will spray through the hose with the setting on tools. If it does, the pump is fine. Continue troubleshooting.

- Check for debris on spray tips. Clean them with a soft brush (on old tooth brush works well). The spray tips may be lifted out for easier access.

- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly. Depress the x on this gasket to ensure this depresses and release back out. Liquid from the tank should dispense.

- Remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.


If the machine continues to not spray, check the following:


REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Nov 22, 2010 | Bissell Vacuums

1 Answer

I have a Bissell Proheat 2x cleaner which has worked perfectly on every occasion. Today I filled the machine as usual with water and formula and switched on, the motor ran, the lights were on and the...


Please check the following with liquid in both tanks.


- Check to see if the machine will spray through the hose with the setting on tools. If it does, the pump is fine. Continue troubleshooting.

- Check for debris on spray tips. Clean them with a soft brush (on old tooth brush works well). The spray tips may be lifted out for easier access.

- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly. Depress the x on this gasket to ensure this depresses and release back out. Liquid from the tank should dispense.

- Remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.


If the machine continues to not spray, check the following:


REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

If these suggestions do not resolve the issue contact BISSELL Consumer Services.

1-800-237-7691
Mon-Fri: 8am to 10pm ET
Sat: 9am to 8pm ET

Sep 27, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

We cannot get the water and soap to dispense in out Bissell steamcleaner


Check to ensure there is liquid in the water tank and the formula bottle.
Note: This machine will spray with liquid in the Water tank only if the machine is set to the Water Rinse setting. On any other setting, you need to have liquid in the formula tank as well.

If no: add liquid to the Water tank and the Formula tank.
If yes: check each of the following....

- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly.
- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
-If everything is seated and attached properly, prime the machine by turning off the power, waiting one minute, and then turning the power back on and depressing the trigger on the handle.
- If priming the unit fails to fix the problem, remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.
If the machine continues to not spray, check the following:

REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Aug 13, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Pressing the handle to release cleaning solution does nothing. The cleaning solution does not come out. Carpet is dry.


Check to ensure there is liquid in the water tank and the formula bottle.
Note: This machine will spray with liquid in the Water tank only if the machine is set to the Water Rinse setting. On any other setting, you need to have liquid in the formula tank as well.

If no: add liquid to the Water tank and the Formula tank.
If yes: check each of the following....

- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly.
- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
-If everything is seated and attached properly, prime the machine by turning off the power, waiting one minute, and then turning the power back on and depressing the trigger on the handle.
- If priming the unit fails to fix the problem, remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.
If the machine continues to not spray, check the following:

REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

If your machine continues to not spray, please take your machine to a local BISSELL Authorized Service Center for inspection and repair. BISSELL provides you with a one year warranty for any defective or malfunctioning part.

To locate your nearest BISSELL Authorized Service Center, go to www.bissell.com. Click on the Customer Support tab near the top of the homepage and enter your zip code in the Service Center locator box to perform your search.

You can also locate a Service Center by phone, 24 hours a day, by calling 1-800-237-7691 and choosing option #1.

Aug 03, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

My bissell steam cleaner will not spray any water


Check to ensure there is liquid in the water tank and the formula bottle.

Note: This machine will spray with liquid in the Water tank only if the machine is set to the Water Rinse setting. On any other setting, you need to have liquid in the formula tank as well.

If no: add liquid to the Water tank and the Formula tank.
If yes: check each of the following....

- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly.
- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
-If everything is seated and attached properly, prime the machine by turning off the power, waiting one minute, and then turning the power back on and depressing the trigger on the handle.
- If priming the unit fails to fix the problem, remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.
If the machine continues to not spray, check the following:

REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Jun 15, 2010 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

I have the Bissell heat pro 2x 8920 and the water doesn't come out. The soap just mixes with water tank and the carpet stays dry


Check to ensure there is liquid in the water tank and the formula bottle.

Note: This machine will spray with liquid in the Water tank only if the machine is set to the Water Rinse setting. On any other setting, you need to have liquid in the formula tank as well.

If no: add liquid to the Water tank and the Formula tank.
If yes: check each of the following....

- Check the bottom of the Water Tank and the Formula Tank to make sure each has a red auto-load gasket attached. Make sure the Water Tank and the Formula Tank are seated properly.
- Ensure the tank lid is properly attached to the bottom of the tank. To attach this properly, remove the Water Tank from the machine. Hook the front window onto the lip of the bottom container and then allow the window with lid to cover the complete tank. Secure the latch on the back of the bottom tank to the back of the tank lid. THE TANK LID CANNOT BE ATTACHED PROPERLY IF THE BOTTOM TANK IS ALREADY INSTALLED IN THE MACHINE.
-If everything is seated and attached properly, prime the machine by turning off the power, waiting one minute, and then turning the power back on and depressing the trigger on the handle.
- If priming the unit fails to fix the problem, remove the handle completely and re-attach. Once the handle is re-attached, re-attempt to spray.
If the machine continues to not spray, check the following:

REMOVE THE COLLECTION TANK:
• Make sure the unit is set to water rinse
• Remove the smart mix bottle and fill it with water only
• Place the smart mix bottle into the collection tank reservoir
• Run the unit and try to spray. If the machine sprays, you will be able to see the water level decreasing in the smart mix bottle and you will need to replace the bottom tank. It is possibly warped.

Jun 14, 2010 | Bissell 8920 ProHeat 2XTM Upright Vacuum

2 Answers

Does not spray cleaner


It helps to always run hot water in the soap holding tank after you have cleaned the carpet to make sure the soap does not dry inside and clog. Make sure that the dirty tank water filter is clear of debris, I have noticed that if it is clogged it won't spray out solution. Another thing to try is, it usually will always spray out of handheld cleaning attatchment. steve

Jun 06, 2010 | Bissell 1699 ProHeat Clear View Upright...

15 Answers

Hoover FloorMATE 3000 won't dispense cleaning solution.


I had the same problem with my Hoover Floormate H3000 and found the solution elsewhere on this website. Try doing a search for Hoover Floormate H3000. The posted solution is basically as follows:

Remove the liquid dispenser tank and set it aside. Look into the cavity of the machine where the tank attaches and find the plastic "plunger" piece (the one on my machine is a blue/grey color) that is surrounded by a black rubber circle. Put a small drop of hot glue on the tip of this plastic "plunger" piece and let it harden. Replace the liquid dispenser tank and try the machine again. My machine dispensed liquid properly after this fix-it.

I really appreciate the poster who provided this simple solution!

Nov 19, 2006 | Hoover Floormate H3000 Upright Wet/Dry...

Not finding what you are looking for?
Hoover Floormate H3000 Upright Wet/Dry Vacuum Logo

1,191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18425 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...