Question about Car Amplifiers

1 Answer

Amp not working

Kenwood kac-ps201t will not come on power terminal hook up remote hook up both have power blue light just flashes and slide cover does not slide when hit botton thanks again

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Do u need the remote wire hooked up to your cd player for your amp to turn on

Posted on Nov 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwoood kac-7202 redlight/no output


you blew the output Ic's (amps one or more ) you can fix this by replacing the output IC's

Jan 29, 2014 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

My kenwood amp wont turn on all the way i just hooked it up to my truck. the blue lights and the fan come on but the red light wont come on to power my subs


REMOVE THE RCA INPUTS AND DISCONNECT THE SPEAKERS, THEN POWER THE AMPLIFIER UP WITH THIS NO INPUT, NO SPEAKER LOAD CONDITION. IF IT STILL DOES NOT POWER UP, VERIFY THAT THE POSITIVE AND ESPECIALLY THE GROUND CONNECTIONS, ALONG WITH THE REMOTE CONNECTIONS ARE 100%, THEN TRY AGAIN. IF STILL NOT POWERED UP, MEASURE THE REMOTE WIRE VOLTAGE TO INSURE THAT IT IS NOT LOWER THAN 11 VOLTS. IF YOU CANNOT MEASURE IT, THEN DISCONNECT THE REMOTE LEAD FROM THE AMPLIFIER AND TEMPORARILY INSTALL A JUMPER WIRE FROM THE POSITIVE POWER TERMINAL TO THE AMPS REMOTE TERMINAL WHICH WILL FORCE IT TO TURN ON. IF IS STILL DOES NOT POWER UP, THEN IT WILL HAVE TO BE SERVICED. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Nov 20, 2009 | Kenwood KAC-7203 Car Amp

1 Answer

Amp will not come on ,no light


Yes!!!!!!!!!! Your remote wire is what tells your amplifier to turn on and off it won't work without it. Assuming your stereo headunit is an after market unit it has the correct wire for this. what you have to do is pull out you headunit, and in the back of the headunit where all the wires plug into your unit there is blue wire with a white stripe. this is the remote turn on wire. connect a wire to that blue n white wire and run it back to your amp, insert it into to the spot marked remote. turn your head unit on and your amp will power up... if you have all the rca cables hooked up your amp should be ready to go.... btw good choice on the amp, kenwood is the way to go!

Aug 31, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood kac-x1r flashes code e-03


HI DUDE EVERY REMOTE WIRE THEY HAVE FUSE NEAR THE BACK OF PLAYER TRY TO CHANGE IT .... R...TRY UNPLUG UR AMP .. AND ..FIX IT BACK

Apr 16, 2009 | Kenwood KAC-X1R Car Audio Amplifier

1 Answer

Kac-ps201t problem


I had a similar problem with a KAC-X812D Kenwood amplifier.
My problem turned out to be that the RCA inputs were so sensitive, they picked up interference from my head unit through the RCAs.
I replaced the head unit with a newer model, and had no problems after.

This may not be your case, but hope it helps.

Dec 15, 2008 | Kenwood KAC-9152D Car Audio Amplifier

3 Answers

Kenwood KAC-7202 wont turn on


I have found the problem to my Kenwood KAC-7202. The amps fan was the only thing that would come on thats it. So I started checkin zener diodes cause all transistors checked out fine. So I remember readinf about a guy that had same problem and took it to a shop and they said it was some diodes. Well, thats what I was thinkin or the transformer. It turned out that 1 zener diode was no good, diode D9 1ss133. I took a zener out of an old vcr I use for parts and put it in and the fan came on as usual then the red light. Then I hooked my mp3 player to the rca input and hooked up some speakers and it works great. Hope this helps you other guys with the same problem. Check your zener diodes with a digital volt meter, if you get any measurement other than the reverse impedance which will read between 600 and 1200 ohms some lower or higher and then reverse the leads on your meter and if you get any reading it's no good and the reading will be 0-50 cause mine read 047 ohms.

Feb 09, 2008 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

My kenwood kac7201 amp wont turn on but it has power to it


Recheck the voltage precisely like this:

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jan 22, 2008 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Kenwood KAC-PS201T


The first thing you must do is to confirm that you have voltage at the amp. Just because the fuses look good, that doesn't mean you're getting power to the amp.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jan 21, 2008 | Kenwood KAC-X201T Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...