Question about AudioBahn A2300HCT Car Audio Amplifier

1 Answer

HELP please! Ive been trying to hook up an amp and two 12s to a ford factory radio. the power comes on the amp. i just have no sound. ive bought an Speaker to RCA Adapter, spliced it into one of the speakers on the back deck, then run the RCA to the amp. but still no sound..ive done everything i know to do. Ive switched all wires and everything to make sure they are connected correctly, but i didnt ground the Adapter, the man said no need. Any help would make me very very very happy!

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: HELP please!

Ok on the factory radio there is an adapter kit you can get that plugs into the back of the headunit and will push the sound to the subs i had one in my car till i got a new headunit and it worked fine. id recommend that you go to your local sound shop like a detail shop or some place that installs them for a fee and ask them what you think

Posted on Aug 22, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Aftermarket amp

The Chrysler Dodge radio sends full volume to the Infinity amplifier using other cables it sends voltage with data to the amplifier and tells the amplifier lower or increase the volume, there is no way to tap or get the signal that is way pac build this interface for your radio CAN buss adapter hi low

Jun 01, 2013 | Car Amplifiers

2 Answers


From the specs this amp can only handle 4ohms when bridged but can handle 2ohms when it's not bridged

  • Continuous Power (20Hz-20kHz, 0.04% THD)
    • 2 ch: (4 Ohm) 100Wx2
    • 2 ch: (2 Ohm) 200Wx2
    • 1 ch: (4 Ohm) 400Wx1
  • Maximum Power (EIAJ)
    • 2 ch: (4 Ohm) 250Wx2
    • 1 ch: (4 Ohm) 750Wx1
  • Frequency Response: 10Hz - 50kHz (0,-1dB)
  • Total Harmonic Distortion: <0.01% (1kHz, 4 Ohm)
  • Signal-to-Noise Ratio: >105dB (IHF-A Weighted, at 1kHz)
  • Dimensions: 10-3/8" x 2-1/2" x 13-5/8"
Hope that helps.

Nov 08, 2010 | Pioneer PRS-X720 Car Audio Amplifier

1 Answer

Protection light is on

un plug rca
and disconnect all spk from amp and turn on if light dont come start with one rca at a time and one spk and connect and you will find the problem

Apr 11, 2009 | Car Amplifiers

1 Answer

Just bass through speakers attatched to amp

there is probably a switch that says lpf-full-hpf those are your low pass filter(only low tones) full which is all ranges of sound and high pass filter which when you want to hook up a set of mids or highs I hope that this helps u out

Apr 01, 2009 | Car Amplifiers

1 Answer

Something Wrong With my Fosgate 500-a2 Amp

Is the amp being fed directly from the head unit's RCA preamp outputs or is it being fed by another amp's preamp outputs? Try temporarily wiring up a speaker you know is good in place of the sub and see if anything changes.

Apr 01, 2008 | Rockford Fosgate Punch 500a2 Car Audio...

2 Answers

No power to my legacy 600 watt car amp

Hmm...ive had this problem before and its always been either the remote wire, the rca cables or the ground. i would try hooking up the remote wire strait to the battery, if that doesnt work try to find a better place for the ground. maybe where your trunk latches. if that still doesnt work then i would try new rca cables.

Feb 13, 2008 | Car Amplifiers

2 Answers

Lanzar Vibe 1200D protection light

You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

1 Answer

Orion XTR PRO 2400 power on... no sound

it could be that it burned the stereo inputs or outputs

Sep 24, 2007 | Orion 1200D Car Audio Amplifier

3 Answers

Phase Linear UPA424...No sound

I had the same problem with mine but i had the 224 version first worked nice just for a small system but i just got this one today and i hooked it up to a small sub box how i had the one before and it just dosent work the other one quit beforhand and i thought it just went bad so i figgerd id buy this one but after about and hr n 1/2 of work to show nothing kinda was a depressing moment, ive gone through my wireing about 4-5 times now and drawn it out 2 times on eveything ive done im just lost, ive even tryed diffrent rca and also tryed a diffrent radio and still nothjing tryed messing aorund with settings still nothing its kinda a bummer

Sep 10, 2006 | Phase Linear UPA424CS Car Audio Amplifier

Not finding what you are looking for?
AudioBahn A2300HCT Car Audio Amplifier Logo

62 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21840 Answers

Are you an AudioBahn Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides