Question about Hitachi CP-X327 Multimedia Projector

5 Answers

Lamp When turning on my projector(which I have two of that do the same thing) the power light flashes green for approximately 60 sec. then the Lamp light turns red, and the power light flashes red. Nothing is projected. I have contacted Hitachi, and was told to replace the lamp, and did so, but this did not fix the problem. Do you have any suggestions?

Posted by on

  • 1 more comment 
  • Don Ide Dec 21, 2007

    After turning on the projector, the POWER light flashes green, then the LAMP light turns red and the POWER light flashes red. No light from LAMP.
    I replaced the lamp twice, but this did not fix the problem.

    There is good air flow.

  • Keijo Feb 20, 2008

    I have the same problem
    -Tuomo-

  • nilfehj Mar 04, 2008

    After turning on the projector, the POWER light flashes green, then the LAMP light turns red and the POWER light flashes red. No light from LAMP.
    I replaced the lamp twice, but this did not fix the problem.
    There is good air flow.



    I talked to someone at Hitachi and they said I got a bad bulb so I replaced it AGAIN Still have the problem!!!!

×

Ad

5 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 41 Answers

I have the CP-X275W that did the same thing. The ballast was bad and I fixed it with a $5 switching regulator. The CP-X327 has the identical ballast.

Details:

The High Intensity Discharge Metal Halide lamp suddenly failed to light up. A new lamp was installed and would not light up either. The fan ran and the lamp LED flashed after a few minutes. Voltage to the ballast module was 368VDC. The ballast did not pulse.

Ballast# PS-226-LS-210 was bad. Hitachi Part# HA01101 has been discontinued and the new part number is HA01102. It was $210USD at Vance Baldwin or $221USD at Part Solver.

The FET series (TR1,5,6,7,8,) seemed good: (drain-source resistance=5Kohm). Bought an identical projector on Ebay to do comparative multimeter measurements. Found resistance differences in IC01 (STRG6153). Swapped good part to bad projector, and it worked. This is a 5-pin Sanken brand switching regulator, US$5 at www.electronix.com. They have the STRTG6153, which is compatible, and may be better. The bad one removed from the circuit measures 15Kohm on pin 3 to pin 5 and the same 15Kohm when the probes are reversed. The good one measures 18Mohm and infinite when the probes are reversed.

If you would like me to fix it for you and clean all your optics, I can do it for $150USD plus $25 return shipping. Contact Chris at chris_goulet@yahoo.ca.

If you have a new lamp for sale I would buy one for $100USD.

Good luck.

Posted on Feb 05, 2009

  • 4 more comments 
  • Chris Goulet Mar 31, 2009

    Another tech reported that it was the main board, not the ballast, that was bad. The board was sensing a false lamp overheat condition. They were able to locate and replace an electronic component, then the projector worked.

  • Chris Goulet Jul 12, 2009

    Hi Chris,
     
    Got the parts and replaced them, TR01 (2sk2642) was not faulty but I replaced it anyway because I broke one of the pins when I de-soldered it from the pcb.
     
    When I turned on the projector, the lamp would not start. It tried to start up repeatedly resulting in short dim flashes of the lamp, and after a few sessions the protection mode turned on with the flashing "lamp" indicator led.
     
    After that I replaced c04 c05 (both 47uf 25v) and c06 c07 (both 10uf 50v) tried again and WHAM! It works!!!! :)
     
    The parts I replaced to get the projector working again:
     
    IC01= STRG6153
    R06= 6R8
    R07= 6R8 
    R11= 4,7 ohms
    C04= 47UF 25V
    C05= 47UF 25V
    C06= 10UF 50V
    C07= 10UF 50V
     
    Many thanks for your help and the posting on the fixya site, without that thread I would never have come this far!
     
    Daniel

  • cedric cabrera Nov 28, 2013

    R06 and R07 this is 1/10w or 1/4w or 1/8w

  • Chris Goulet Nov 28, 2013

    Cedric, the watt rating of surface mount resistors can be determined by measuring its size. See

  • Chris Goulet Nov 28, 2013

    See:http://en.wikipedia.org/wiki/Surface-mou...

  • Chris Goulet Nov 28, 2013

    Cedric, see my profile for my email address. Email me, then I can send you the service manual.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same problem (power light blinks red, lamp light stays red), but I bought my projector from a surplus auction.
Is there a way to see whether there is a problem with the ballast or the lamp before dropping $200 on either one?

Posted on Jan 21, 2010

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

These projectors suffer from premature ageing of the ballast psu, I carry spares for these and can repair

Posted on Mar 09, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

No, but just come across the same problem

Posted on Jun 16, 2008

I have the same problem? Anyone fixed it yet?

Posted on Feb 05, 2008

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: Lamp

lamp duration

Posted on Jun 12, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I can't figure out what is wrong with my Hitachi CP-X605 projector.


The ballast (which provides power for the lamp) might have gone bad. Check the voltage its outputting with a digital multimeter.

Aug 23, 2015 | Hitachi Office Equipment & Supplies

2 Answers

The projector turns on but won't project any light through the lens.


If this is a NEC VT series projector, Change the lamp. When if it continues to blink amber and not project and image after installing a new lamp check the lamp cover to see if the micro switch tab on the lamp cover broke off. Some models have a built in lens cover. If the cover is not slid over to open completely the light may not turn on.

May 19, 2014 | NEC VT800 LCD Projector

1 Answer

Projector not turning on


seems that the lamp is defective, pls test it

Have a good day! any question ,contact me,Please
We supply original projector parts: lamp, bulb, Lcd panel, Lens, DMD chip, color wheel,
motherboard, powersupply ... with high quality and competitive price.
Jerry Lampdeng Limited
Mobile: 0086-13178867858
Wechat ID: 008613178867858
Whatapp ID: 008613178867858
Skype: lampdeng@hotmail.com
http://www.lampdeng.com

Feb 25, 2014 | Optoma EP739 Multimedia Projector

2 Answers

Benq w1000 project not turning on


Look at the manual page 34, for the indicator messages. I suspect it's the same problem I have (which I haven't had formally diagnosed yet!), which I believe is a defective fan. My projector had been making a really loud noise on startup, which varied in length and volume. Recently the projector has taken to turning itself off after being on for about a minute, and the power light flashes green, with the temp and lamp lights flashing red.

Jan 27, 2012 | BenQ W10000 Projector

1 Answer

Green Power light blinks for about 60 secs, then


YES New lamp needed the model number will be on old one does not take long to change if still got hand book shows how change

Nov 07, 2009 | Sony Grand WEGA KDF-50WE655 50" Rear...

2 Answers

SONY 60" KDF-60XS955 power goes off and on every 30 sec


..got the lamp changed too..back to be where it was before, working perfectly good...saved a lot of mone from having it serviced at home...thank you all for the info....

Dec 08, 2007 | Sony Grand WEGA KDF-60XS955 60" Rear...

2 Answers

PLV-Z1 no longer powering up - Ready light is green and the Lamp light is red


I have a Sanyo XU35. Mine was starting up and showed a picture for about 15 - 30 seconds then shutting down. My lamp warning light was not coming on. When I put it in for repairs it turned out to be the lamp that needed replacing. The technician said it is not uncomman for the lamp to be gone and the lamp warning light not to come on. I got my lamp on e-bay from ping_ngo for a great price.

Aug 11, 2007 | Sanyo PLV Z1 Multimedia Projector

Not finding what you are looking for?
Hitachi CP-X327 Multimedia Projector Logo

1,938 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Office Equipment & Supplies Experts

jasbo
jasbo

Level 3 Expert

2237 Answers

The Knight
The Knight

Level 3 Expert

75169 Answers

Chris Goulet

Level 2 Expert

41 Answers

Are you a Hitachi Office Equipment and Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...