Question about Aprilaire 600 Humidifier

2 Answers

Aprilaire 600 Humidifier

I have 2 issues.
1. My humidifier will only dispense water when in test mode. It does this when the furnace fan turns on (which I believe is the correct time), but not on any of the number settings.

2. Do the expensive allergen furnace air filters render the humidifier less effective than the cheap fiberglass filters? Even when my test mode is dispensing water, I don't notice any humidity. The damper is in the winter position.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

J-

I had this problem several years ago. In order for the water to flow, the outside temperature sending unit must indicate to the controller that it is less than 60F. If not, the unit will not operate outside of test mode. Check the temp outside where your sending unit is (could the sun be heating that side of the house?) and ensure that the circuit to the sending unit is working. I had a bad wire splice inside a wire nut stopping the circuit. Took me a long while to figure it out.

If the outside temp and your sending unit circuit is ok, I wish you luck on your troubleshooting.

adx_98

Posted on Nov 19, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have a similar (test mode only) problem and discovered a "workaround" this morning. My humidifier doesn't work when the fan setting on the furnace thermostat is set to AUTO. If the thermostat fan control is set to ON the humidifier works porperly. I'll be calling my service rep first thing tomorrow.

Posted on Nov 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

We noticed the humidity went down to 30% and I adjusted the rate to increase Now our Aprilaire 400 says to change the filter. I did that, and it still says to change the filter. The furnace runs fine....


If your humidifier is equipped with a Digital Humidifier Control with Water

Panel change indicator, after replacing the Water Panel, turn the control

knob to the "Test/Reset" position until the "Humidifier On" light blinks to

reset its timer. (Blower must be operating and HVAC calling for heat.) Be sure

to turn the control knob back to it's original setting. If the "Humidifier On"

light continues to blink, your humidifier is in Test mode. DO NOT LEAVE THE
CONTROL IN TEST MODE OR HUMIDIFIER WILL NOT OPERATE.

Jan 27, 2011 | Aprilaire 400 Humidifier

1 Answer

We just bought a house with an existing Aprilaire 600 humidifier. It is now heating season and we ae running the furnace. I turned on the humidifier and no water is getting to the pad.The water line is ok...


Hello,Make sure the heating blower/fan is running when you turn the dial as the humidifier might not have power if there is no heating blower operation.

Nov 06, 2010 | Aprilaire 600 Humidifier

1 Answer

I replaced the water panel on our aprilaire 600 humidifier. I adjusted the thermostat to call for heat to test it. When the dial (non-digital control panel for the humidifier) is turned to test/reset,...


Thank you for contacting us with regards to your model 600 Humidifier. The Change Water Panel indicator should flash when the control knob is set to the Test/Reset mode. The flashing indicates that the timer has been successfully reset. However, the humidifier should operate for the first 60 seconds of Test mode as long as your furnace is running. If your humidifier does not turn on, contact your installer. The humidifier may require service.
We appreciate the opportunity to be of assistance.
Sincerely,


Brett Phillips
Technical Support
Research Products Corporation

Nov 01, 2010 | Aprilaire 600 Humidifier

1 Answer

Our aprilaire humidifier is only 4 years old and it does not seem to be working. We have static in the house and when I did test mode it never drained water like it was supposed to. Any ideas what I can do...


Hope this helps, check and see if humidistat is set to 35% humidity and that bypass damper on humidifier is in the open position or winter position.(humidistat is usually located on cold air return duct near furnace). Next, replace humidifier media pad, remember to replace media pad (filter) annually, you also may want to clean any lime deposit out of humidifier housing with a solution of warm water and white vinegar before installing your new media filter.Remember to turn power off at side of furnace when cleaning humidifier and replacing media. Before installing new media turn power back on to furnace, set humidistat to the on position, turn furnace thermostat above room temp., and inspect humidifier to see if water is running from top,(you may want to have a bucket under humidifier when checking for water), if you see water running, turn power back off to furnace, properly install new media filter, reconnect humidifier cover & set humidistat to 35%. If you do not see water present, check water supply valve to humidifier and make sure its turned on. If water supply valve is open, then check water supply tubing for blockage.And the last things to check is to make sure all registers through out your home are open and not blocked by any objects, also make sure furnace filter is cleaned, if none of this works refer to installation manual to see if humidifier was sized and installed properly, Good luck.

Mar 03, 2010 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600 humidier: water continuously runs


sounds like you may have it wired to a continuous power source vs one that shuts off with the furnace. The most common wiring is red to C & white to W

Jan 08, 2010 | Aprilaire 600 Humidifier

1 Answer

Testing a Aprilaire Humidifier 600 Controller


if it works in the test mode then it should be okay but you can get a humidity gauge from radio shack and set in the house to see how high or low its is. the humidifier is only going to give a max of 45% humidity

Nov 27, 2009 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600: water only runs in "Emergency" Heat mode


When your unit is on normal the outside unit works and the inside only the fan runs. your heat pump does not remove any humidity when it operates so the installation cotractor did not wire it to operate then. you can change the wiring on the humidifier to operate all the time by wiring it to the fan (g) terminal then it should work just turn it all the way to the lowest humidity when you are in cooling mode.

Jan 07, 2009 | Aprilaire 600 Humidifier

1 Answer

Humidifier won't turn on with furnace fan set to Auto.


There is a devise called a current sensing relay (a little black box that hangs on a blower motor wire that senses current from that wire) If you have such a devise it should hang from the white (common) wire. Loop the wire through twice.

Nov 23, 2008 | Aprilaire 600 Humidifier

1 Answer

Aprilaire 600 bypass water flow rate


The water is only dispensing over the evaporator pad while the furnace is in the heating mode. When the furnace finishes cycling the humidifier will also stop.

Mar 04, 2008 | Aprilaire 600 Humidifier

1 Answer

Humidifier control .


if humidifier was wired into thermostat circuit for power instead of seperate transformer , this can happen. you need to see if you voltage going to the solenoid valve. if you do , and it isn't opening, the valve is bad . this is assuming that it is using a # 50 relay to come on only when the fan runs . . make sure the water valve is open

Dec 24, 2007 | Aprilaire 700 Humidifier

Not finding what you are looking for?
Aprilaire 600 Humidifier Logo

391 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilaire Humidifiers Experts

paulcarew

Level 3 Expert

1863 Answers

Ken Thomas

Level 2 Expert

118 Answers

Mack Baxter

Level 3 Expert

379 Answers

Are you an Aprilaire Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...