Question about Rockford Fosgate Punch 301M Car Audio Amplifier

1 Answer

Amp not turning on

I put the amp in my car and hooked it up but it will not turn on. I have 1000 wat wiring kit and it still wont work. The light wont even turn on and when i move the ground cable around to different areas on my car it makes a scratchy noise so i dont know if its getting power or not.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If neither is too low, the power supply in the amp is probably blown.


Posted on Nov 11, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I took my 1000 watt amp and kit out of my old truck and put it in in my new ride. It worked just fine at first then the subs started going out for hours even days but amp was still powered on then i hooked...


You may need to run a larger wire to the amp or upgrade your alternater to get enough voltage to the amp. double check all of you wire connections going to the battery and from the alternator also. Clean all terminals and maybe even beef up the wires from the alternator to your battery. Your smaller amp works due to it needing less current to work, your big amp can't even power up with the lack of available current.

Apr 01, 2013 | Car Audio & Video

1 Answer

I am tring to put a cd player on my 2004 pontiac but it wont work the sterio wont turn on so i ran a wire from the fuse box on the side of the dore and it turn on but it has no sound wat am i doung wrong


hook up all your wires to the harness and the cd player EXCEPT the ground take and run both wires to the firewall or something metal instead of hooking them up together

Aug 30, 2011 | 2004 Pontiac Grand Am

1 Answer

I have 2 pioneer tsw33c 10 inch subs and a pioneer


get amp kit if u wat high performenc get most exspensive kit as for the sub u could bridge them as for the stereo and speaker just make sure the posi

Mar 15, 2010 | Car Audio & Video

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Help asap


hook blue wire to ur radio to amp remote

Feb 12, 2009 | Sony Car Audio & Video

2 Answers

Car audio


on the back of he cd player is the wire harnest there should be a SOLID blue wire on there take the remote wire connect it to that and run it to your amp and put it where the amp says remote. there is an easier way you can hook up your power to the amp then take the remote wire and just run it directly to the power wire on the amp you should only need a couple inches of wire and it will work fine

Jul 10, 2008 | Kenwood KDC-MP335 CD Player

1 Answer

Thunder 5604


okay u will have to troubleshoo the amp.....dose the amp light up?...when u have the radio on? also check your sub wires.going to the amp....make sure the rca'sare hooked up to the radio rear out puts are the radio sub out puts...and then test your amp gain adjustment...let me know if that work's

Jun 23, 2008 | MTX Thunder5601 300W x 1 Car Amp Mono...

3 Answers

Jl audio


If the amp was hot, it probably has a serious problem. You should have it checked out by a qualified tech. Don't continue to use it. More serious damage could occur.

May 29, 2008 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Punch 301M Car Audio Amplifier Logo

Related Topics:

219 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

seankane89

Level 1 Expert

53 Answers

hoyzee1

Level 2 Expert

150 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...