Question about Sherwood RD-6500 Receiver

Open Question

Problems with one channel

I have an issue that seems rather odd with this receiver. The rear right channel refuses to work. The same wires and speakers work on any other channel, but none of them work on this channel. Can only one channel blow on a receiver? Sadly i suspected this wouldn't work for long.

Posted by on

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

2 Answers

Yamaha rx 530 center channel cuts out

Thanks for all the suggestions guys.

I've tried using the balance for left and right speakers, and when the receiver is acting up with the right speaker having a low volume, I tried moving the balance all the way over to the right speaker. The right speaker volume will not increase in volume but the left speaker will decrease in volume.

Just to clarify, the center and the rear speakers are balanced. The issue only happens sometimes when I first power on the receiver I will have no center channel. If I leave everything alone for a few mins, the center channel will come on.

So it seems to me that something one the receiver is going. The question is, can anyone suggest a physical repair for the receiver for these symptoms?


Jul 20, 2012 | Yamaha RX-V530 Receiver

1 Answer

I have a Yamaha RX - V665 and the right rear surround works only part of the time.

Start by using an old test speaker and connect it directly to the right surround output with a short wire and monitor it.

If it sems to work with no issues, you either have a bad connection at receiver or speaker, or a break in the speaker wire somewhere.

If you have the same problem with the test speaker, you have a rgt. rear output issue in the receiver and it needs repair.

Hope this helps

Apr 17, 2010 | Yamaha RX-V663 Receiver

1 Answer

Sony STR DE845: rear speakers not working, three fronts are OK.

The rear amp is malfunctioning (duh). Take it to a tech for a real diagnosis.

Sep 05, 2009 | Sony STR-DE845 Receiver

1 Answer

Receiver is shutting down.....

First, I have to compliment you on a thorough and comprehensive problem description and an apparent sense of how to troubleshoot. We're halfway there already.

Your Blu-Ray / PS 3 statement is intriguing but with the E-1 code that absolves it as the problem.

You have two opposing symptoms: the live failure says you have a short while the test mode implies an open circuit. We have to isolate everything and see if it moves to another channel.

Let's run with the "E-1: NO FRONT SP" error. I think it's trying to tell us we have an intermittent sensation of an open wire in one of the Front speaker channels. * Unfortunately, the manual doesn't break out Left and Right (but I'm sure the receiver knows) to help us isolate. You say it doesn't get past the Left test. I need you to decide by listening to the Left Front Speaker setup routine if it's really working or not, and if it seems to be working, maybe the receiver is really failing at the point it advances to the Right Speaker, assuming Right follows left in the sequence.

Verify for me: You swapped the two front speakers Left to Right and replaced both speaker wires with NEW wires and had no improvement.

I'm wary of a failcode that doesn't identify which of a pair is failing, so I 'd like to see ALL NEW speaker hardware and connections in place to avoid the pitfall of swapping the L & R with each other and having one of them be the problem without changing the symptom.

We can accomplish this easily: Try temporarily running the rear speakers as the Fronts just to see if the test can pass. If so, test the Fronts as if they're the Rears speakers. You should be able to just swing the receiver-ends of the cables among the speaker posts.

Something should change or else the problem is internal to the receiver. Good luck.

Apr 28, 2009 | Yamaha RX-V663 Receiver

1 Answer

I am having problems with my left side speakers. They are extremly faint(Front and Rear. I have sitched the wires in the back for the left speakers onto the right side and they work fine and then the right...

If switching the wires solves your problem, then the problem is in the wires. Buy some new speaker wire or use some insulated scrap wire to replace the malfunctioning wires.

Apr 16, 2009 | Yamaha RX-V496 Receiver

1 Answer

Rear Surround speakers

Best thing to do is to put the unit in 5 channel or 7 channel mode. That will send left ch information to the front left and rear left speakers ( both will get the same information). Ditto with the right channel. The center channel will get centre channel information.

If all the speakers work, go out and rent TOP GUN. ( yes its old), BUT there are a few extreme scenes , one of which is the elevator scene, where the camera changes perspective and suddenly you hear the elevator doors close BEHIND you through only the surround speakers ( have the unit in surround mode....NOT 5 or 7 ch mode ). If this works ok, then you have no problems.

Remember, surround sound only produces information in the rear channels when the information is there. To check out the digital and DTS decoders, get an action flick. If you can, get a remote too, because that will unlock many features about the receiver that you cant get to with the front panel controls. Also go to yamaha and download the owners manual ( its free !!).....that should get you going.....

best of luck...

Jun 08, 2008 | JVC RX-880V

1 Answer

Surround sound distortion

Receivers like this will incorrectly decode rear channel audio and pass it on to the rear channels as distorted audio. Make sure the source being used really has rear channel information encoded into it. It could have other issues but check this first.

Dec 16, 2007 | Sony STR-DE625

1 Answer

RX-V596 center and rear channels do not have any sound

Nevermind... My center channel output was set to "NONE" I've had this receiver for a few years now, probably set it that way back when I got it. Oh well, Helps to re-read the user manual...

The info is in the "SET MENU" section of the manual, Pages 35-38. Should solve the issue for "almccrum" above as well.

If you don't have your manual it can be downloaded here:

Oct 06, 2007 | Yamaha RX-V596 Receiver

1 Answer

NAD T762 - no sound

Try reseating the prologic/output board. Second one from the right (from the front of the reciever), that fixed my no sound problems on many channels. You will have to take out a few screws to remove and reseat it, and while you are at it clean the connections.

Sep 08, 2007 | NAD T762 Receiver

1 Answer

Right surround channel not working in some modes

I had the same problem with the right channel.    It turned out to be a broken wire inside the receiver; it can be found connecting from the main PCB to the card for the 5.1 board.    After repairing the broken wire, it has worked fine.   


The harness connects the 5.1 low level signals to the board which are then redistributed to the amplifier section.     It is a bundle of wires in gray casing and with red, black and white wires (with shielding).


Find the offending wire, repair or replace and it should be fixed.


Hope this helps

Jul 31, 2007 | NAD T751 Receiver

Not finding what you are looking for?
Sherwood RD-6500 Receiver Logo

Related Topics:

25 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sherwood Audio & Video Receivers Experts


Level 3 Expert

4502 Answers

Josh Whitehead
Josh Whitehead

Level 3 Expert

1142 Answers

The Knight
The Knight

Level 3 Expert

66330 Answers

Are you a Sherwood Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides