Question about Rockford Fosgate 800.2 Car Audio Amplifier

2 Answers

800.2 well i ran it for a year like that and never had a problem till i blew the sub, i think when it blew the sub it frigged or blew something in the amp but i'll run the idea by one of my friends and see what he says. man i Appreciate your time man.

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Well when you blow a sub it can definantely short your output fets in the amp.

Posted on Nov 02, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Does the amp power up?

Posted on Nov 11, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok so I have a profile clarus 800 amp its all hooked up properly nd all of the wires r new the fuses are not blown are anything the problem is that when I hook up the subs( 2 10" infinity kappa's)...


i could be that you blew one of the RCA outputs on the back of the head unit. if you have front/rear/subs rca outputs, try connecting to a different set to check if you can get sound to the subs.

Jul 23, 2011 | Profile CL800 Car Audio Amplifier

2 Answers

My kenwood KAC-7204--- the wiring is hooked up right, I just got a 2000 watt max sub 1000 watt rms, i was running the amp in bridge mode and it ran for 1 day than it turned off. I checked it and the fuse...


when i was running my sub off bridge mode this kept happening to me. I ended up just running two subs and for some reason the fuse stopped blowing. i think there is something wrong with these amps.

Jun 04, 2011 | Kenwood KAC-7204 Car Audio Amplifier

1 Answer

Power pyramid subs smoking i think the jl 1000/1 is tuned wrong..


If the sub is new, they need to be broken in.

All sub woofers need a break in period of about 5 to 6 hours at medium volume.
The reason is because the glue needs to be cured. This is done by the heat from working.

If you are giving it too much volume too soon, you are burning the glue.

Back off the subs and only play them at medium volume for about a week.

Nov 22, 2009 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

How to connect HIFONICS BXI 2607 D watt at 1 ohm....


That's dependent on your subwoofers. You will need 2 dual 4 ohm subs wired in Parallel, a single dual 2 ohm subwoofer wired in parallel, a single dual .5 ohm wired in series. Or something similar.

http://www.bcae1.com/spkrmlti.htm

Nov 20, 2009 | Hifonics BXi 2006D Mono Block Amplifier...

1 Answer

My system just stopped working one random day. the sub will hit very softly every 5- 10 seconds. i think it is the amp. what could it be?


Hello

Well my first thought is that you blew your sub. Does your amp have a power light on ? Is it green or red ?

If you have an extra sub or amp, or a friend does. Try switching one or the other out (sub would be easiest) and rule out which one is really at fault. But im still leaning towards a blown sub.

Post back if you have any further question's or comments. Thank you for choosing Fixya!

Oct 04, 2009 | Dual Car Amplifiers

2 Answers

Amp or something cutting out.


Power caps store power from the battery and they feed constant power to the amp so you dont get no drainage! this could be one reason..

have you bridged both subs and wat gauge wire are you using.

these amps can only handle one bridged sub at 4ohms and this amp is recommended that u use 8gauge or higher. if your running to subs i normally reccomend using 4 gauge power wire as you get more rms power feed to the amp

you can get a power cap or anyother accersory cheap online at my suppliers.. caraudiosecurity << click to enter >> hope this helps and please rate me :)

Apr 22, 2009 | Rockford Fosgate Punch 401S Car Audio...

1 Answer

THUNDER 5601 WHEN VEHICLE TURNED ON, SUBS BOOM, THEN WORKS OK. ALSO WHEN RADIO TURNED OFF


If the amp produces no boom with no signal input cables connected, I'd suggest using an LOC.

Let me know if you have any other questions.

Sep 30, 2008 | MTX Thunder 3401 Car Audio Amplifier

1 Answer

I think my ex blew my amp


model number? im thinking 401s? if so that should be the only light on

Aug 07, 2008 | Rockford Fosgate Punch P5002 Car Audio...

1 Answer

Amp turns on then starts making subs go erratic with almost sounds like line nosie


hi i had the same problem people suggest checking ground thats where you start at then if it aint ground for sure, the make sure you have good rca cables. If there good this is what happen to me i had a cheap ole pioneer 70 doller cd player the actual rc jacks from that cd player was making and horrible sound travel through my speakers im talking humming whinning everything im positive that this will solve your problem email me at maggotman927@hotmail.com and let me no something if i helped or if ya need more help

Apr 04, 2007 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate 800.2 Car Audio Amplifier Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Amplifiers Experts

Pablo Gonzalez

Level 3 Expert

733 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...