Question about Kicker KX120.2 Car Audio Amplifier

1 Answer

Protection light I got my amp hooked up, and when i went to turn it on the protection light came on for about 3 seconds, went off followed by the green power light coming on, but still no sound. what do i do to fix it?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 132 Answers

Double check the blue stereo input wire to amp is this a new amp if not speaker channels in amp might be blown

Posted on Nov 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I had these 12in pioneer subs so I went and bought the new Rockford Fosgate they came out like a week ago my problem is every time i hook them up to the amp the protection red light turns on can you...


if the amps impedance is higher than the speaker, it will trigger the protection circuits, because the amp sees it as an overload, example the amp has 8 ohm impedance specified, and your speaker has 4 ohm specification, that is a clear overload. Bring the subs back to the amp's dealer and have the amp replaced; the one that matches your subs. Hope this helps... ;-)

Feb 03, 2011 | Car Audio & Video

1 Answer

Got a problem with my car amp.Everything was working fine until 2day.Amp goes in to protection mode.Jumps from power to protection indicator every i would say 3 seconds and each time it goes in to...


Ok check the remote wire running from the headunit to the amp should be giving v12 feed whiles headunit is on.

check or change grounding position.

take cover off the amp as the circuit may be over heating.

Sep 22, 2010 | Car Audio & Video

1 Answer

Protection light keeps flashing on and off


try hooking up only the power ground and remote see what happens if protection light is on then u have a problem with amp if it goes off then hook up rca if still off then hook up speaker wire if it turns on then u have a prob with speakers

Feb 02, 2010 | Kicker ZX10001 Car Audio Amplifier

1 Answer

Protection light comes on went the amp is turn on and it stays on for four seconds and then the amp turn on


Disconnect any speaker from the amp then re-power. If it still goes into protection, your amp needs serviced. Shorted output transistors most likely. And check your Sub for shorts as well. If the voicecoil on the sub is burnt, it will short any amp. If you can use a meter, check the resistance on the sub. Hope this helps

Jun 02, 2009 | Kicker KX Series 04KX1200.1 1200w RMS...

1 Answer

Protection Light Comes on


Sounds like you have an ohm problem, Tryy hooking the positive from one speaker to the negative on the other speaker. Then hook the negative from the first speaker to the negative on your amp and the positive from the second to the positive on the amp this will drop your ohm load and the amp should stop going into protection.

Mar 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Protection light lights up for a second and turns off and the amp seems like it is not working. It is connected and wired correctly.


disconnect the speakers from the amplifer, and turn the system on again. if the protection light still is active even without the speakers hooked to it, then it is most likely that you have a blown transistor in either the power supply section, or the output section.

Either way, your amplifier will need to be serviced.

Dec 07, 2008 | Kicker Car Audio & Video

2 Answers

Protection light grief


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Vibe is mediocre. Time to invest in an old school Lanzar Opti Drive amp. .A thumbs up would be greatly appreciated if this answer is helpful to you. protection-light-grief-shonxoarcym4awy4zl1imx4o-2-0.jpg

Jun 11, 2008 | Lanzar VIBE266 Car Audio Amplifier

2 Answers

Lanzar Vibe 1200D protection light


You will need to show it to a service technician as it seems the output section has blown so it remains in protect mode. One reason (could be) that the input to the amp was high and may have been clipping for some time before the amp decided it could take it no more

Jan 14, 2008 | Lanzar Vibe 1200D Car Audio Amplifier

2 Answers

My amp wont put out sound


it's blown....probably, check your connections and make sure your presenting it an ohm load it can handle....so check the sub with a dmm.

Feb 28, 2006 | Jensen A600HLX Car Audio Amplifier

Not finding what you are looking for?
Kicker KX120.2 Car Audio Amplifier Logo

Related Topics:

141 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

70347 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...