Question about Sunbeam Ultrasonic 81696 Humidifier

2 Answers

Sunbeam ultrasonic humidifier runs but produces no mist

Unit turns on & fan is running but produces no mist.
reservoir & sensor are clean

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 5,568 Answers

It sounds very much like the transducer has failed. This is likely a crystal transducer and since they produce the agitation that should cause a mist, they are running continuously; not a good thing for something that is trying to shake iteslf apart all the time. These require input from a circuit that produces the fairly high level of power needed to drive the crystal so it could also be the source of the problem.
This isn't something an owner is able to diagnose unless they have some technical training.     

Posted on Nov 08, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had a similar problem and found the fuse (1a / 125v w/pigtails) on the pcb was bad. Unit works fine now.

Posted on Dec 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Humidifier will produce mist for a min then stop If you look you can see it producing mist within but it will not come out of the top Walgreens cool mist ultrasonic humidifier


I have had times where my Crane humidifier won't produce mist if I haven't turned it on for several days (4+) or more. The water that sits in the reservoir may develop a film on the ultrasonic element which inhibits the creation of the mist to come out the top of your humidifier. I would lift off the tank and empty the reservoir. Then VERY GENTLY with a piece of paper towel, wipe the ultrasonic element (looks like a disk the size of a quarter at the bottom of the reservoir) to clean off any film. Then replace the tank and let the reservoir fill up the tank and try it again.

If your humidifier runs properly for a minute and then makes a whirring noise and goes silent (like the motor stopping), then it's a motor problem. The humidifier motor may have gone out of alignment due to bumping or rough handling of the humidifier when cleaning or emptying it. If that is the case, you will have to empty the humidifier reservoir, unscrew the base, and find the screws holding down the motor and check for misalignment. Loosen them a little and put it back together and try again.

Best of luck
thebqe

Feb 13, 2014 | Humidifiers

2 Answers

My unit is not producing mist. I followed all the instructions and tried all of the troubleshooting instructions but have had no results. I am getting no mist


If the instructions didn't mention how to clean the unit of scale and mineral deposits, that's more than likely the problem.

If that's the case, here's what you need to do: Empty the tank of any more that's still in it and mix a 50/50 solution of White Vinegar and Bottled Distilled Water. Fill the tank with the solution and allow it to set 8 hours or over night. Then tunr the unit on and place your hand in front of the mist nozzle, to see if it's producing mist. If it is, let it run for at least 45 minutes and turn the unit OFF. Empty the remaining solution and refill the tank with Bottled Distilled Water. Run the unit until the tank is 1/2 empty and refill with more of the Bottled Distilled Water. Now, you're set to go. In the future, I'd recommend that you always use Bottled Distilled Water rather than tap water. As it's mineral and scale free.

Hope this helps to solve the problem. Please let me know. Thanks.

May 06, 2011 | Sunpentown SU-3750 1 Gallon Humidifier

2 Answers

I have a Cool Mist V3500 humidifier. The fan


TRY POURING IN SOME WHITE DISTILLED VINEGAR AND RUNNING IT. THE VINEGAR LOOSEN UP ANY SCALE AND JUNK. AFTER RUNNING UNIT FOR AWHILE, DRAIN OUT ANY REMAINING LIQUID AND ADD DISTILLED WATER OR FILTERED WATER. RUN UNIT AGAIN. THEN DRAIN OUT ANY LIQUID. NOW THE UNIT SHOULD WORK AS NORMAL. IN THE FUTURE, TRY USING DISTILLED WATER OR FILTERED WATER.

Dec 13, 2009 | Vicks Cool Mist V3500 Humidifier

2 Answers

WHY DON'T MIST COME OUT OF MY HUMIDIFIER


with cool mist humidifiers your not suppose to see any mist. if it's a warm mist there should be. but by your model number i'm finding that it's a cool mist. that's why your not seeing any mist.

Aug 15, 2009 | Vicks Cool Mist V3500 Humidifier

2 Answers

We have a Sunbeam Cool Mist Ultrasonic Humidifier that we bought just over 2 months ago. Up until a couple of days ago, it was producing mist and running just fine. I cleaned it with the brush and got the...


I have this same problem. And cool mist humidifiers DO produce mist. I have had my humidifier for a while now (6 years) and have never had any problems. But after the most recent cleaning, it worked at first, but now seems to not be working anymore... Am also wondering if there is anything I can do to remedy the situation?

Mar 17, 2009 | Sunbeam 701 Humidifier

1 Answer

No mist, but i can see a water droplet fountain on the surface


if it's a cool mist unit it will not produce any mist. now if it's a warm mist unit it should. that's normal. it is possible to replace the transducer if it is damage but you are going to have some leakage from it. but the only way to get the transducer mainly is from the manufacturer

Mar 12, 2009 | Sunbeam Ultrasonic Humidifier

6 Answers

Air-o-swiss 7135 humidifier not misting


Ours has done the same thing after only 2 weeks. From article research, it appears that this occurs to everyone after cleaning it with the EZ Cal that is recommended. From looking at our unit and figuring out how it works, it appears as though the Ultrasonic Vibration membrane has stopped working. This particular piece is responsible for vibrating the water and making water mist particles which are blown out with the air. We will be calling the manufacturer on Monday to register a complaint and request a replacement unit.

Nov 23, 2008 | Air-O-Swiss 7133 Humidifier

2 Answers

Humidifier makes a huge noise and no mist


According to the Crane's Troubleshooting section:
The power light is green but there is no mist being emitted:
- Check that there is water in the tank.
- Check for possible lime deposits on the water level sensor or the nebulizer.
- Make sure that nothing blocks the vapor output slots.
- Check that the fan vent on bottom of humidifier is not blocked.
- Empty the humidifier and rinse the water basin with cool tap water and allow to dry for 15 to 30 min.

This next part may or may not be relevant.
Humidifier power light is staying red and not turning green. Or, Humidifier is working then stops:
- Ensure that water level sensor is assembled properly.
- Clean water float.
- Call service center and request replacement water float.

Barring that, here is the service center contact info:
Dart Warehouse Corporation
Tel: 1-888-599-0952 (Business hours Mon-Fri 9:00 am - 4:00 pm Ct)
Website: http://www.crane-usa.com
1835 Ferry Road
Naperville, Illinois 60563

Jan 28, 2008 | Crane Cow Humidifier

2 Answers

Fan runs but no moisture


According to the manual, there may be a problem with your water level sensor. According to the manual:
- Ensure that water level sensor is assembled properly.
- Clean water float.
- Call service center and request replacement water float.

I scanned in the page from the manual that shows how to dismantle, clean, and reassemble the water level sensor here.

If that doesn't work, you can try contacting the manufacturer:
Dart Warehouse Corporation
Tel: 1-888-599-0992 (Mon-Fri 9:00 AM - 4:00 PM Central)
Website: http://www.crane-usa.com
1835 Ferry Road
Naperville, Illinois 60563

Dec 09, 2007 | Crane Frog EE-3191 1 Gallon Humidifier

Not finding what you are looking for?
Sunbeam Ultrasonic 81696 Humidifier Logo

Related Topics:

3,041 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sunbeam Humidifiers Experts

yadayada
yadayada

Level 3 Expert

77186 Answers

Oloyede Monsuru

Level 3 Expert

1417 Answers

Paul Sikkema
Paul Sikkema

Level 2 Expert

171 Answers

Are you a Sunbeam Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...