Question about Sceptre 17" LCD Monitor

1 Answer

No picture sceptre 7x 17" monitor

Just stsrted. Turn on computer and get no video on monitor. power light flashes red then blue.

Posted by on

  • Anonymous Nov 21, 2008

    same issue, turned on the monitor...video flashed on screen then immediately dissapeared.

  • blood_king08 Jan 11, 2009

    where can i get some replacement ones

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Check for a bulged capacitor. They should be flat on top, look for one, possibly two with a "bulge" on the top :)

Posted on Nov 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Sceptre X7G-Naga VI 17 inch LCD Monitor When I turn the monitor on and boot the computer I get the red light for a sec then the blue light comes on I will also see windows booting up but the...


try with restarting computer & press F8 at the same time. u will see a menu where choose "safe mode" & start the computer. in safe mode see the display properties, set the refresh rate & resolution according to monitors specifications, apply & restart again. if that does not work, replace the main board of lcd monitor.

Aug 25, 2011 | Sceptre 17" LCD Monitor

1 Answer

I have a Sceptre X7G-Naga VI 17 inch LCD Monitor When I turn the monitor on and boot the computer I get the red light for a sec then the blue light comes on I will also see windows booting up but the...


try with restarting computer & press F8 at the same time. u will see a menu where choose "safe mode" & start the computer. in safe mode see the display properties, set the refresh rate & resolution according to monitors specifications, apply & restart again. if that does not work, replace the main board of lcd monitor.

Aug 25, 2011 | Sceptre X20G-Naga II 20.1" Flat Panel LCD...

2 Answers

Why isnt it turning on. only the blue light turns on and then i try to turn it off and the rede light comes on. when the red light comes on it makes a hogh pitch sound?


More likely to be unstable DC voltages in the power supply due to bad DC filter caps, unplug it so it will not do more damages to the circuits.
See the 17" version here with bad caps:
http://s807.photobucket.com/albums/yy352/budm/SCEPTRE/Sceptre%20X7G/

Capacitors kit: http://lcdalternatives.auctivacommerce.com/ he can make you a set of caps for you.
Or www.digikey.com just make sure to use caps with low ESR, 105c, high ripple current, long life rating such as PANASONIC FM or FC series.

Basic LCD monitor and TV troubleshooting guide:
http://www.fixya.com/support/r6150077-basic_lcd_monitors_troubleshooting
http://www.fixya.com/support/r5093881-lcd_flat_panel_tv_troubleshooting_guide
http://www.fixya.com/support/r7406380-tv_training_manuals
Failed TV and Monitors pictures: http://s807.photobucket.com/albums/yy352/budm/
Learn about bad caps: http://en.wikipedia.org/wiki/Capacitor_plague

Aug 02, 2011 | Sceptre X9G Komodo IV 19" Flat Panel LCD...

1 Answer

17 inch flat screen monitor has trouble turning on


Make sure that the PC video output is set at 60 Hz. The LCD often will accept up to 75Hz but will not work correctly.

May 04, 2008 | Sceptre X20G-Naga II 20.1" Flat Panel LCD...

1 Answer

SCEPTRE DCLCD 20" MONITOR


plug it out and take for repair from technician or if you are a technician . there is problem in the main board where power comes in.

Apr 18, 2008 | Sceptre DCL 7A 17" Flat Panel LCD Monitor

1 Answer

Sceptre monitor x7g-nagaVI


Problem is 2 Capacitors on the power inverter board, at 1000 uf 16 volt. This one was on the model xg7-naga V 17 inch monitor.

Jan 14, 2008 | Sceptre 17" LCD Monitor

1 Answer

32" Sceptre LCD No POwer


0939a31.jpg This is the same problem I am having with my Speptre X20WG Naga Monitor.
The power LEDS are usually red in standby and blue in opp; but now they just go purple and nothing happens..no sound no picture. I called tech support and no dice they just wanted my money, but I think all we might have to do is change a fuse on the main pcb! As you can see the white arrow isnt really pointing to anything specific! I think the fuse is the lt blue component, but am not sure. This is all I can offer! If you gat any good tips or if anyone else finds a fix please email me pbj0327@yahoo.com.
Thanks! and good luck m007!

Nov 28, 2007 | Sceptre X20g-Naga III 20.1" LCD Monitor

5 Answers

Sceptre X7g Monitor Flashing Red & Blue Lights. Blank Screen


i fixed this problem by unplugging the monitor, unplugging the video cables. Then hold down the power button while plugging it back in. Release power button and then press power button for on. It worked then. I got the icon for no signal, i plugged back in my monitors. Sceptre X9W

Sep 11, 2007 | Sceptre X7GNAGAV 17" LCD Monitor

Not finding what you are looking for?
Sceptre 17" LCD Monitor Logo

233 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sceptre Computer Monitors Experts

Robert Veldman
Robert Veldman

Level 3 Expert

373 Answers

Mike McWhinney

Level 3 Expert

537 Answers

Cindy Wells

Level 3 Expert

4759 Answers

Are you a Sceptre Computer Monitor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...