Question about AutoFlo S2000 Humidifier

Open Question

How to repair the fault circuit board (S2000)

My Autoflo S2000 could not fill up water. After I changed the circuit board with a new board, the system now works fine. I want to repair the fault circuit board. My question is that where is problem in the circuit board and how to check it. Thanks.

Posted by on

1 Suggested Answer

  • 1 Answer

SOURCE: My AutoFlo S2000 blows the breaker fuse after

Current for heating is 11.4Amps. Blower motor add 5-7 Amps which extends normal fuse rate (15A). After "maintenance" auto-drain, heating is longer than usually, maybe 15-20 minutes, which cause overcurrent (more than 15A in 10-15 minutes) and fuse blown. Change your furnace circuit for 20Amps or plug the humidifier onto another circuit.

  • Andre

Posted on Nov 22, 2010

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

1 Answer

Water leaking / running from top of humidifier

humidifiers have a drain and if there is water going in it will be coming out the drain. check drain to see if it is clear, check hoses going into top of humidifier for cracks, check filter in humidifier.

Feb 05, 2014 | AutoFlo 250 Humidifier

1 Answer


Hello, i have a link for a unit that will be close to what you are looking for

Nov 28, 2011 | AutoFlo 400BP Humidifier

1 Answer

My furnace is leaking when the air is on and the motor in the autoflo 800 humidifier is bad. Could this be the problem?

Hello, the motor itself wont cause the unit to leak water, the float valve on the unit is what adjusts how much water is coming into the humidifier. If the float valve is not adjusted properly or broken it will cause to much water to enter the humidifierand therefrore overflow. Replace the motor and chexk the float valve to enure it is adjusted properly and if it is stuck or broken replace.

Jun 15, 2011 | AutoFlo 800BP Humidifier

1 Answer

The AutoFlo 2000P unit ( 12 years old ) on my furnace is leakng water from the drain spout, which it had never done before. It also is emitting sounds like a low clicking or grinding sound. Where is the...

Tim, they're are generally not hard wired. At least, by today's standards. They're usually plugged into a receptacle. If that's not the case with yours. Open the lid and lift the float valve and tie it some way that can't lower. That will stop water from entering the humidifier tank and it should stop working. Also, look for the water line shutoff valve and turn it OFF. That way, you can be double sure it will stop running.

Hope this helped you to turn it off.

Apr 30, 2011 | AutoFlo 200P Humidifier

1 Answer

Is set to 60 end is no water coming

First, is the saddle 'T' valve open on the water supply line? If it's not turn it ON no water can fill the tank. If after that, it doesn't work, there may be a problem with one of the solenoids.

I have included a link to your Owners Manual, which may be of assistance, since it has a Trouble Shooting Guide.

Hope this helps you.


Feb 07, 2011 | AutoFlo 250 Humidifier

1 Answer

I just installed a new AutoFlo 200P. I have 24V to the 200P motor, but the motor won't spin. I can't even get it to move if I put pliers on the output shaft (I'm not forcing it, though). Any thoughts?

Like to help, but I have a similar? problem. My brand new motor turns, but gets hung up and clicks. That's why I bought a new one in the first place. Now it's hot. Tried to jiggle, make sure there is enough room for the wheel to rotate. Seems to be sufficient space. Why won't the wheel turn?
It's almost like the water weighs too much and holds it the wheel in place and the gears aren't strong enough to turn it.

Jan 03, 2011 | AutoFlo 200P Humidifier

1 Answer

On the auto 97 the float does not cut the water off could i rebuild it

If the float has no water in it.Try to flip around the small rubber stopper that pinches off the fill nozzle.

Mar 17, 2010 | AutoFlo Humidifiers

1 Answer

There is no water going into humidifier. I have water going up to the solenoid assembly but nothing going into the humidifier.

Turn the humidistat all the way up and listen for a click at the solenoid valve. If it clicks, then the solenoid valve is probably plugged, scaled up or stuck. They can be disassembled and cleaned depending on the type, but it would be easier to replace it.

If no click, check for a power problem in the circuit.

Dec 12, 2009 | AutoFlo 250 Humidifier

1 Answer

Just moved into home with a250 mumidifier. water not getting to unit. It's turned on.

Is the water supply on? If you have a voltmeter, check for voltage across the solenoid valve leads when the furnace is heating. If you have voltage, but don't hear a click when the furnace turns on, suspect faulty solenoid.

Dec 09, 2009 | AutoFlo 250 Humidifier

Not finding what you are looking for?
Humidifiers Logo

Related Topics:

35 people viewed this question

Ask a Question

Usually answered in minutes!

Top AutoFlo Humidifiers Experts


Level 3 Expert

1033 Answers


Level 3 Expert

1751 Answers

Barrett Palumbo
Barrett Palumbo

Level 2 Expert

1772 Answers

Are you an AutoFlo Humidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides