Question about Hamilton Beach Water Cooler with Storage Cabinet

Open Question

Hot water rear switch causes GFI to trip

The cold switch can turn on and off, however when the hot is switched on the GFI will trip off. Could this be caused by a build up off minerals on the heating element? If so are parts able to be purchased?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 1 Answer

SOURCE: No Cold Water

My Hamilton beach water cooler is not cooling

Posted on Jun 07, 2008

  • 400 Answers

SOURCE: hamilton beach tabletop water dispenser for hot

The water selector valve is fautly and needs to either be stripped and cleaned or replaced.

Posted on Mar 09, 2009

mgprice
  • 744 Answers

SOURCE: My hot water on model #87330 cooler has stopped

Unfortunatly this is going to be a bad heating element or high limit thermostat, It's going to be cheaper to buy a new one or just make do with cold water. Sorry I can't be more helpfull but i worked on these things for a while and the company i worked for would rather buy new then put time effort and parts into a $100 water dispencer.

if I can be of any more assitance please feel free to comment again.

Posted on Jun 23, 2009

  • 1 Answer

SOURCE: Hamilton Beach 87330 hot water problem.

I have a HB model 2002 type wd01 water dispenser. It has the same "No Heating" problem. I can't find a service manual, electrical schematic or exploded view anywhere to help me diagnose the problem. Even if I did, and I suspect it's the thermostat as n6ec suggests, where would I get repair parts?

Thanks TEK57

Posted on Mar 26, 2010

  • 10 Answers

SOURCE: My water cooler won't cool

Is this model 87307? I am looking to buy this dispenser 87307. Pls e-mail me at vmd011@hotmail.com Thanks

Posted on Nov 16, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hotpont aqurius wml 560 has a problem once you have loaded the machine closed the door set your cycle press start the door locks and the led illuminate but nothing happens it normally starts to pump in...


g'day, sounds like the solenoids in the back aren't letting water in. The solenoids are what the hoses are hocked onto. They are like an electrical tap. These are not pumps, water is only pumped out of a washing machine. Some reasons why water is not coming in: - Taps are not turned on (Keep it simple), turn taps on. -Hot, or cold solenoids are not working. (Lets hope chances are only one has broken). Swap cycle options, try just hot, or just cold options. If one works and not the other, a solenoid is not working. just put either hot or cold on the solenoid that is working. Note, some new machines only have one hose at the back, this is because they heat the water internally - like dishwashers. If this is the case, a new solenoid can be purchased and installed. -Another reason might be that solenoids aren't getting power. This cold be because the trip switch in the door. A common problem. Think of the trip switch just like the light in the fridge. When door is opened, switch is opened. If u can test machine on spin cycle ie, the machine spins, then this is not the cause. Some appliances even have switches on soap draws so check that out aswell. hope this helps


Aug 07, 2011 | Washing Machines

2 Answers

My Kenmore Elite HE3 keeps flashing F H


F/H error is normally a malfunctioning flow meter. A good indicator is substantially higher water levels than normal, provided the flow switch has tripped its first set of contacts.

Condition
No water detected entering machine or Pressure switch trip not detected.

If after 30 seconds the control does not detect water entering machine and then valves will be turned off and the error code will be displayed.

Or

If the control has turned the water valves on and after 8 minutes the flow meter has detected 10.5 gallons of water passing through it, but has not detected the pressure switch trip, the valves will be turned off and the error code will flash.


Check/Repair:

Press PAUSE/CANCEL twice to clear the display.

If there is no water in the unit:
1. Make sure that both valves at the water source(s) are turned on all the way.
2. Check for plugged or kinked inlet hoses or plugged screens in the inlet valves
3. Verify inlet valve operation


If there is water in the unit:
1. Verify Drain pump operation
2. Pressure Switch Hose is in good condition and properly connected to Tub and Pressure switch
Verify there is not a siphon problem
Verify wire harness connections to:Inlet Valves, Pressure Switch, Drain Pump, Flow Meter, and Central Control Unit (CCU)
Check all hoses for possible leaks
Verify pressure switch operation
Verify flow meter operation
Verify CCU operation

If this is intermittent, it would be very hard to determine the cause.
I myself have rarely run into this issue, and when I did, it was mainly caused by low water pressure into the water from the customers water supply, or clogged inlet water valve screens.

Make sure you don't have any duct tape or something around your drain pipe, it needs that air gap to prevent siphoning.

Hope helps (remember to rate and comment this answer).

Jun 24, 2011 | Kenmore Washing Machines

1 Answer

I have a GE two speed motor/pump for a hot tub that I have adapted for a type of therapy called underwater pressure massage (all of the hot tub jets are channeled through a single hose for the high...


Disconnect both hot leads from the breaker at the box. Using an ohmmeter measure the resistance to ground or the neutral bar in your box. If the resistance is LESS than about 50 K you have excessive leakage current. It is unlikely the motor is the problem. I would check the wiring and switching for the leakage. Now to the second problem: If you switch between speeds while the unit is running, the GFI will LIKELY trip. This is normal as you create a massive transient that the GFI PROBABLY can't handle. There are a couple things to try: One is using a two pole control switch and turn off the pump before "switching gears" ... as an electrical engineer I can't explain this unless you can understand electrical transients AND capacitive coupling between the windings and the case of the motor. I realize you may have a combination speed and on off switch so you MIGHT have to add a switch. Ideally I would want a relay for on/off near the breaker that momentarily disconnected before shifting gears. The next fix possibility involves a trick we use to control transients in electronics. This involves noise control by using a toroid around the pair of hot wires. This MIGHT take several turns through a good sized ferrite toroid with both the hots in the same direction, side by side. This forms what we call a "Bi-Filar" choke. Look that up on Google to understand the principle... it essentially helps balance the currents in the hots and isolates them from ground for transients.

May 08, 2011 | Bryant 50 Amp 2 Pole Br250 Type Br Ni...

1 Answer

Our machine is about 4 years old now and has recently begun tripping the GFI sporadically. In most cases it does this when the steam pump is on, either for steam or heating for hot water. Sometimes, it...


Hi
Your seals in the steam boiler are gone and it is leaking water to the switch below. The steam boiler is located just above the switch on the lower left side. You just have to replace the seals (O-rings)

Dec 31, 2010 | Saeco Magic Comfort Plus Espresso Machine

1 Answer

Hello we have Bradford hot water tank model #MI65R6DS13. Our problem, I keep having to press the tanks reset switch for us to get hot water. At the same time after I press the reset switch we have hot...


No the top thermostat is the first place I would start to replace. They run about 14.00 more than likely it isn't controling right. Turn power supply to water heater off and replace thermostat.

If you was getting scalding hot and then turning cold without tripping the thermostat it would be the top element working and the bottom one bad.
Bottom element good it will give you luke warm water for a while then gradually turn cold because it's heating the bottom of the tank.

Hope this will help you out.

Oct 09, 2010 | Fasco Bradford White Hot Water Heater...

1 Answer

My 2001 venture van rear air is blowing hot air


often on the vans with rear air the air dor acuator goed bad and can no longer switch from hot to cold. also the swich itself will often go bad. this can be caused by sticky fingers damaging the inside of the switch. sometimes a good cleaning in warm water will fix a sticky switch

Apr 23, 2010 | 2001 Chevrolet Venture

1 Answer

I have a HB Water cooler Model 2312C, Type WD01,


Problem: Water is not hot


Possible Causes: Dispenser is unplugged


Solution: Push plug completely into outlet


Possible Causes: Heating switch not on


Solution: Check to be sure heating switch is turned to ON


Possible Causes: The fuse is blown/circuit


Solution: 1. Replace house fuse or reset breaker is tripped circuit breaker.

2. If too many items are plugged into a single circuit, move some items to a different circuit


Possible Causes: Temperature limiter tripped


Solution: 1. Set the hot and cold power switches to OFF

position.

2. Wait five minutes, then set switches to ON position.

3. Wait 30 minutes for water to heat or cool



Link for owners manual: http://useandcares.hamiltonbeach.com/files/840178800.pdf.

Feb 18, 2010 | Hamilton Beach Water Cooler with Storage...

1 Answer

Fridge keeps tripping electricity


I assume by "earth leakage" you mean it is on a GFI circuit? Some older GFI outlets are sensitive to and do not work well with motors or other inductive loads like your refridgerator compressor. As for the compressor feeling hot, this is usually normal.

If this is a GFI outlet, try replacing it with new unit. If it is a GFI breaker, try replacing that.

Dec 27, 2008 | Kenmore Elite 22.4 cu. ft. Bottom Freezer...

1 Answer

Water intake


sounds like a problem with your selector switch , or you ve hooked up your hoses backwards(pretty common issue).new accutemp water temps will indeed turn hot water on even though yuove sselected cold/cold wash. Energy guidelines state that there is an optimimum "cold" temp and if your water is too cold it will turn on the hot water to stablize a warmer "cold".

Oct 27, 2008 | Whirlpool Washing Machines

1 Answer

Water fill temp.


check to make sure that your hot water isn't connected to the cold side this is the number one cause for your problem all washers rinse in cold so if you switch to and its hot cold then your hose is on the wrong valve just switch the fill hoses see if that don't fix it

Mar 27, 2008 | GE WBSE3120B Top Load Washer

Not finding what you are looking for?
Hamilton Beach Water Cooler with Storage Cabinet Logo

Related Topics:

51 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hamilton Beach Water Filters & Coolers Experts

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Brad Brown

Level 3 Expert

15308 Answers

John Tripp
John Tripp

Level 3 Expert

4654 Answers

Are you a Hamilton Beach Water Filter and Cooler Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...