Question about Audio Players & Recorders

Open Question

Kef coda s subwoofer

Currently my subwoofer isn't working anymore. I checked the fuse, and it's still good. still no power....any clues? thanks!!

Posted by on

  • blondebabii1 Nov 23, 2008

    the switch is turned on and its plugged in but i get no power i havent had it very long! i dont know what is wrong. any one have any idea?

×

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

brainyass
  • 242 Answers

SOURCE: Replacement KEF Coda III TWEETER Type SP1087

Go here and find a nice substitute. Many to choose from and it may be better to purchase a pair of them rather than have mis-matched ones. They should be inexpensive enough for you, as low as $2 up to $480. You just need the size of the mounting hole to find a replacement though.

http://www.parts-express.com/speakers.cfm

Posted on Nov 21, 2008

  • 75 Answers

SOURCE: kef subwoofer kht 2005:2

check for the connection og the main wire is cut.. or check the supply..

Posted on Dec 08, 2008

  • 1 Answer

SOURCE: KEF Subwoofer AV1 and KEF Activator. Need specifications

Unit is now 12 years old min. and no longer state of the art.... i offer $400

Posted on Jan 28, 2009

  • 222 Answers

SOURCE: I just would like to change one of broken speakers

try their website

Posted on Jun 08, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rpm gauge


Just take the vehicle to a repair shop &
have the issues resolved & then ask all the questions
at the shop

Jun 21, 2013 | Toyota Celica Cars & Trucks

1 Answer

Changed battery cables now subwoofer isn't working in my 1997 ford expedition


Check the fuse for the power wire for the amp. Up somewhere by the battery in line of a red cable leading to the battery post.

Apr 10, 2013 | Cars & Trucks

1 Answer

Why isn't my Logitech Z-5300 speaker system no longer turning on at all?


I have a suggestion that you can try. If the unit is no longer turning on and you're sure the electrical outlet is good (by plugging in another device) and the hand-held control panel is on, as well as the switch at the base of the subwoofer, then try replacing the fuse. The subwoofer on this model has a fuse near where the power cord enters the subwoofer. There is a slotted screwdriver slot on the fuse cover. Using a flat-head screwdriver (or your thumbnail), turn the cover about a 1/4 to a 1/2 a turn and the fuse should pop out. Keep the cover. Replace the fuse with a 4 amp, 125V (or higher) fuse that is a slow-blow fuse. There are fast blow (or fast acting) and slow blow (or slow acting) fuses. You can't replace one for the other. You should be able to find a fuse at Radio Shack. If a new fuse doesn't get your system working again, then something else is broken. Good luck.

Sep 25, 2012 | Logitech Z-5300 Computer Speakers

1 Answer

Aiwa tw60 subwoofer have power but no woof sound


Aiwa isn´t a good subwoofer. The best are Rel, Sonus Faber, etc.
Here is the characteristics:

.1 20 watts, Min. RMS at 4 ohms, from 40 Hz to 160 Hz, with no more than 1% Total Harmonic Distortion


The subfrequencies are below 25 Hz, but TS-W60 work over 40 Hz!.

Bass frequencies (woof) are from 25 to 50 Hz.

Bad, very bad.

Sell it and buy a good subwoofer.


JMG

Jul 18, 2011 | Aiwa TS-W60 Subwoofer

1 Answer

2004 Chevy trailblazer. Power windows & locks dont work on driver side front controls. Have all ready removed and replaced control cluster on arm rest. All other wondows work at the respective door,...


Sounds like a fuse. Are you getting power to the driver door module (control cluster as you say). Below are 3 pictures for you. The first one is the location where the fuse box is located for that fuse (under drivers seat in the rear). The second picture is a diagram or the latout of the fuses. The fuse you want to check is the fuse marked "LT DOORS" or the one marked 02. It should be a 25 amp fuse. The 3rd picture is a wiring diagram for the circuit. If the fuse isn't blown check the power wire from the fuse box to the driver door control module. Sounds like a power issue. Anymore questions or diagrams that you need, feel free to email me at csautomotivecars@att.net and I should have and will send if you need anything else. I hope this helps and good luck.


clifford224_912.gif

clifford224_913.gif

clifford224_914.gif

Jun 27, 2011 | 2004 Chevrolet TrailBlazer

1 Answer

So after getting my car back for the garage my subwoofer isn't working I checked to make sure all of the connections are correct and the settings are there why won't it work


Check to see if your amp is on. You may have blown a fuse somewhere maybe on your amp. Check for proper voltages and make sure the sub isn't blown by pushing on it. If you feel unequal resistance, you probably blew it. Also check the ohms on the woofer.

Jun 06, 2011 | Car Audio & Video

1 Answer

How to open the subwoofer housing to change the fuse


on the back unscrew all the screws (there should be 8 in the plastic square around the jacks... and then undo the four that are in the wooden back) then pull out the plastic square, it will take a decent amount of force, try prying with a flat head screw driver. Once you have that out, you should be able to access what you need inside.

May 30, 2010 | Altec Lansing VS4121 Speaker

1 Answer

My subwoofer isn t working with my MarantzSR3001.


If the sub is good, then check the cable to the sub, check the level in receiver settings and check your surround modes. sounds like your problem is in setup menu if the sub is ok. Hope this helps

Jun 06, 2009 | Marantz SR3001

1 Answer

Jensen JS1000-A sub stopped working, why?


Is is possible that the receiver's subwoofer configuration turned off? double check your speakers setup in the receiver...Just an idea.

Jun 30, 2007 | Jensen JS1000-A Subwoofer

1 Answer

Power problem


have the power supply check out you have an open connection on your regulayor.that clicking sound comes from the relay.good luck

Jun 04, 2007 | Velodyne DLS-3750 Subwoofer

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

389 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

4990 Answers

The Knight
The Knight

Level 3 Expert

73460 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...