Question about Onkyo HT-S770 System

Open Question

No Sound coming from speakers

I'm not getting any sound from the speakers. It was working fine. i've checked all the connections and reseted receiver to factory default. When i assign V1 an optical input, i have no options for listening modes. it displays "Not Available". Has never happened. so i tried the FM Tuner, which doesn't require an outside source. Nothing. Speakers work, tried them on another receiver. i only get any kind of option for the mode after toggling the speaker "A" channel off and on. then i get a choice of DTS or STEREO. Neither speaker channels, A or B, work. I am completly stumped. Any options, tests or suggestions welcome.

Posted by on

2 Suggested Answers

  • 788 Answers


Your symptom sounds as though you may have to turn off any surround sound settings that you have selected in the other modes.

Most amplifiers use the surround portion of the amplifier to power the B channel speakers.

Since you have sound when using the radio portion, I would try turning off the surround mode. For example try turning the amplifier to just stereo and see if that gets the B channel speakers to work

I hope this information allows you to resolve this issue.
If I have helped you, please help me, and rate this suggestion the highest FixYa rating. (Two Thumbs Up) If you cant rate this post with the highest rating, then please comment to this post and I will try to help you further.

Posted on Jun 22, 2009

  • 22 Answers

SOURCE: I am not getting the full surround sound options.

On the remote try scrolling through the settings from the DTS button and also make sure you have the correct audio source selected. I switched to the optical cable but, then found that the better sound for my room came from the RCA set-up.
Good Luck and I hope this helps.

Posted on Oct 04, 2009

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


1 Points

Related Questions:

1 Answer

5.1 Surround Sound Cutting Out

Yes you are right man, this problem occurs only with the cable problem, i can explain you, if there is a receiver problem means you won't get the sound its dam sure,
only if there is a cable problem you will get some noise or sound cut off with the speakers, so you please check the cables properly it will be alright.

Mar 26, 2009 | GE GTD120 System

1 Answer

Can I still use my prologic receiver for my LCD TV ?

optical connection in tv is only input optical connection in receiver is only input will not work.need to connect rca jacks to tv's audio out jacks behind tv to any available input in receiver

Jan 04, 2009 | Samsung HTP-1200 System

2 Answers

Wireless speakers

You should have two pieces for your wireless rear speakers setup. A. a wireless card inserted behind the all in one receiver. B. the receiving box that will connect to the 2 rear speakers.Also,you should not have any obstacles to block off the line of site for the rear speaker receiving box to the wireless card.
Best way to test it is too simply leave the rear speakers connected to the rear speakers receiving box on the floor near the a/v receiver with dvd player built in.Play a dvd and see if you have sound coming out from the rear.

Nov 01, 2008 | Panasonic Home Theater System System

1 Answer

No audio is coming through my speakers

If the receiver is actually powering up but you are getting no sound, there are few basic things to check.

Check the audio connections on the back (speakers AND inputs) to make sure they are tight at both ends and undamaged. Go into the setup screen for the DVD player and make sure the audio settings are set for PCM output and that you are using a digital or optical audio cable. Then make sure you have the correct function selected on the receiver to match the inputs. If the receiver has a speaker test function, use it to see if there is any output from the speakers. Finally, make sure the volume is turned up and the mute button is off.

Otherwise, the amplifier may be faulty

Sep 07, 2008 | Philips HTS-3555 System

2 Answers

Power, but no sound coming from my speakers, checked fuses.

i have power but no sound it worked fine for a little while yesterday but it stopped whats wrong wit it

Mar 04, 2008 | Onkyo HT-SR700 System

7 Answers

Surround sound not working through ordinary tv

Try connecting the red and white audio cords to your system from your cable box/satellite receiver instead of your tv. Worked for me.

Oct 01, 2007 | Home Theater Systems

2 Answers

Can't get all speakers to turn on in AV-1 function

can't seem to get the sound to come on. i knowe i have sound but will not turn on

Feb 09, 2007 | Amphion Mediaworks T-365 System

Not finding what you are looking for?

Open Questions:

Onkyo HT-S770 System Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Home Theater Systems Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

341 Answers

The Knight
The Knight

Level 3 Expert

66537 Answers

Are you an Onkyo Home Theater System Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides