Question about Jl Audio Car Audio & Video

1 Answer

I am not sure where to plug in my rca cables. they usually go in an input plugin but there doesn't seem to be one on my jl audio 500/1 amp

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 97 Answers

Is there a high input and a low input

Posted on Nov 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where i find the high lever input conector?


It is a plug located to the left of the RCA inputs on the opposite end of the amp where the power and speaker outputs are. You will need a plug with pigtails (most likely available from JL Audio
Checkout this link for a picture.:
http://www.sonicelectronix.com/pictures_new.php?id=2789&picture_id=111453

Jan 20, 2013 | Jl Audio E1200 Car Audio Amplifier

1 Answer

I have a jl 500.1 and a 8w7. The sub is playing but not really it will play sometimes but most of the time i am getting almost nothing. Am i using the wrong settings or a bad connection or blown sub?


Sounds like a bad rca connection. You need both rca jacks to be plugged in from your head unit, both left and right or you will not have full power you'll have half power to your sub/subs. Check your sub with a volt meter and see what it reads. Make sure if your head unit has a sub volume make sure it's turned up. Alot of people don't realize they have a seperate subwoofer volume on there deck and it's set to low, so check that. You could have bad rca cables. If all that is ruled out(best way by trying a different amp) the amp itself might be having problems. Don't think it would be in protect mode either.
Let me know if you have'nt allready.

Nov 14, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Have a JL audio slash 500 that isnt putting out any audio... i know the sub is fine. but i noticed the RCA inputs are loose and dont hold the cables very tight.. is this my problem and what can i do to...


Yes it possible that the inputs have been damaged on the circuit board of the amp. If the amp has hi level inputs you could try running a speaker wire input to it and see if it works. You might try another pair of rca cables to.

Aug 20, 2010 | Jl Audio Slash v2 500/1v2 Car Audio...

1 Answer

So my jl 500/1 v2 has power and no audio... i get 3 ohm when i use the voltmeter on the amp the sub but no voltage? is this a fuse problem or am i an *** who has no idea how to troubleshoot


Okay lets go step by step. First check and sure you have battery voltage and twelve volt turn on on the remote term. of your amp. Be sure u have a ground also. Next take your speaker leads disconnect them and pop them with a battery, and make sure it pops. I(f that all passes you need to make sure your amp is getting an input signal because you could have a bad rca cable.

Aug 20, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My amp only powers on it gives no power to my subwoofers


1st check to see if the RCA's are plugged in if they are make sure the speakers are plugged in. Check at the amp and at the sub Alson check the input voltage switch. JL Audio Slash series amps have a high/low switch for your input voltage. And the last thing I can think of is if your using a remote wire to turn the amp in make sure the signal sensing switch is off. If your not using a remote wire turn it on....Hope this helps

Mar 29, 2010 | Jl Audio 250/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

Jl audio amp 1000/1 fix


IVE HAD 2 JL 1000/1S DO THIS TO ME EACH TIME ITS TURNED OUT TO BE A SHORT IN THE RCA IMPUT BUT ALSO CHECK YOUR RCA CABLES AND THE SUB INPUT ON YOUR HEADUNIT

Dec 22, 2008 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

JL audio 500/1 produces barely any sound


have you checked the input sensor on the amp?

Oct 28, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Rca Connection


You need to check the shield ground on the head unit. The following link will guide you through the test procedure.

Shield Ground Testing

Jun 07, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL 500/1 power problem.


There should be a small switch someware on the amp marked VOX or normal. I bet its on vox. if there is no switch then theres a jumper inside the unit to put it into a vox state. Vox Is when audio is at the input the amp goes on and when theres no voltage at the input the amp switches off.

Sep 22, 2006 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

matthew walsh

Level 1 Expert

69 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...