Question about Hoover U6630-900 WindTunnel Bagless Upright Vacuum

1 Answer

Hoover Windtunnel My Hoover Windtunnel is 3 years old. It worked great until yesterday when it lost all suction. I have followed the manual to trouble shoot any possible clogs and could find none. Then I noticed that when I remove the dirt collection cup and held my hand over the vent the suction is fine and strong. So... I replaced the hepa filter thinking that might be the problem. That didnt' work. The motor runs fine. The suction without the dirt cup inserted is strong. As soon as you insert the dirt collection cup both the hose and the floor unit loose suction. Help!!! I really like this vaccuum and cannot figure out what's wrong.

Posted by on

  • 1 more comment 
  • fredzsis29 Mar 16, 2008

    I have the same problem with my vac too. Is just replacing the belt going to help?

  • Anonymous Mar 17, 2014

    hoover windtunnel not picking up dirt

  • Anonymous Mar 24, 2014

    The dirt doesn't spin when the sweeper is on

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Posted on Mar 18, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My widepath bagless windtunnel Hoover vacuum cleaner has lost its suction.


Could be a clog somewhere or you need new filters. Change the belt if it's over a year old.

Mar 24, 2018 | Hoover Vacuums

1 Answer

I have a hoover windtunnel that has worked great till yesterday now it doesn't have any suction an all 3 filters all new. Please advise


Check the ducting that leads from the pick-up brush to the container. Fluff and larger bits are inclined to get jammed in elbows and bends in the pipes.

Feb 02, 2011 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

The vacuum will not power up. What kind of troubleshooting can I try. Also, I purchased the item from Boscov's in September 2009 and I can't find the receipt, is it possible for the 1 year warranty to be...


There's a trouble-shooting guide on page 18 of the manual, which can be found at this link: http://www.hoover.com/pdfs/manuals/U8341900.pdf However, it's not a very extensive trouble-shooting list.
On the other hand, the Hoover warranty is for one year (see page 19 of the manual). But they do require a proof of purchase. If you don't have the receipt, they will probably honor a credit card statement. There is a number to call on the warranty page.
If you found this helpful, please vote.

Feb 24, 2010 | Hoover U8341-900 WindTunnel 2 Bagless...

1 Answer

Lost suction, gasket problem


This is a great basic steam cleaner. I have not heard of repeated problems of this type. The gasket is called a standpipe gasket. I would try to use a non-permanent sealant such as RTV silicone to adhear the gasket, eventually if this needed service you will want the gasket to be able to be removed.

Feb 02, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Hoover Windtunnel spits dirt back out the back


Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Jan 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover only two years old an stopped working!


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40540&thid=564949
Hoover only two years old and it stopped working!
Posted by baby_nurse on May 02, 2008
My Hoover self propelled wind tunnel was working great until a couple of days ago when it started shutting on and off while vacuuming. I thought it was the outlet but when I plugged it into two different outlets it did the same thing. Then finally yesterday it just stopped working it won't even turn on when plugged in. I thought it was the switch but it is not. Is it the motor? Has the motor burned out? Do I need to buy a new one? Help!!

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U6616-900 Windtunnel Bagless Upright
I think you are right, if it is not the switch then it would be the motor. Does it smell bad like a burning smell? If so it is definitely the motor and then @ that point you may want to get an estimate for motor replacement, and keep in mind of what you spent on the vacuum versus what the cost of repair might be. My own rule of thumb is if it cost more than ½ of the price I paid for it then you have to decide – do I want to pay the repaired cost for the vacuum or do I want to purchase a new one. Just a suggestion... You may want to check with your local vac dealer. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.

May 02, 2008 | Hoover U6616-900 WindTunnel Bagless...

1 Answer

Hoover wind tunnel self propelled U6617-960


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40485&thid=557365
Hoover Windtunnel self propelled U6617-960
Posted by srkelly on Apr 29, 2008
The vacuum has no suction at the floor. I have checked the hose, and no blockage. When I try to use the attachments, still no suction. What could be the problem.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U6437-900 / U6439-900 Windtunnel upright Vacuum
You definitely have a clod between the tube by the brushroll area and the attachment hose and the best way is to take a wire hanger and make a little hook on the end to see if there is a clog, the clog is closer to the fan area and anything big would clog up the area sideways and
-- you may have to remove the top cover to see if there is a clog and to better get @ it from the top. Another suggestion is to do a belt change whether you have one or 2 belts on the vacuum and to change the belts @ the same time every 4 to 6 months. Also, check you owner’s manual under trouble shooting to see if there is something else, other wise that is what I think is the problem. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.

Apr 29, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Getting no suction


Check the hose for a clog, when suction is low, you will usually find a clog in the hose or in the dirt inlet by the brush roll. If this is less then a year old, then it is still in warranty, if you can't figure it out, then take it and proof of purchase to a warranty repair shop.

Mar 21, 2008 | Hoover 5416-900 WindTunnel Bagged Upright...

1 Answer

Hoover Windtunnel


Either the hose has a clog, or the inlet down by the belt is clogged. Is there suction at the end of the hose, if not then it is clogged. If there is suction, then it has to be clogged down below by the brush roll, check that inlet. There also is a filter at the bottom where the dirt cup (and bag) is, check it also.

Dec 28, 2007 | Vacuums

Not finding what you are looking for?
Hoover U6630-900 WindTunnel Bagless Upright Vacuum Logo

1,842 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...