Question about Car Audio & Video

1 Answer

I really need ur hlp badley

Every time i hook up my rockwood PA2080 amplifier to my vehicle the red power light comes and stays on and then the green protection light is BUT nothing is coming out its not the radio i dont think i have checked that and yeah

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the protection light is lit, the amplifier probably has shorted output transistors. To eliminate other possible causes, read through the following page. Let me know if you have any other questions.

Amp in Protect mode - Troubleshooting

Posted on Nov 05, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why my jl audio 1400d amplifier stays in protective mode?


Check for a speaker wire that come come of , Or a loose grond wire on the amp or where ever you have the ground wire connected two,

Oct 31, 2012 | Jl Audio Car Audio & Video

1 Answer

Xplod XM-554ZR Car Audio Amplifier: powr/protect light comes on red not green...


Hi, disconnect all speakers from unit and try again - if red light still shows then your amp has died.
If the light goes green, then start testing for shorted speaker/wiring. This includes speaker wiring to vehicle shorts - there should be an o/c reading on your meter

May 05, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Havin problem with a1200 class a/b amp it ligts green and red at same time after hooking in remote how doi fixdo i need diagram to fix


Make sure you don't have any shorts on your speaker wires or rca cables. Unplug one at a time, the turn on power until it stays green with no protect light, then you know what input is causing the short. If you remove all speaker wires and rca wires and all you have connected is the ground, power(12volts) and remote and it still lights up red/green(in protect mode) then your problem is the amp.

Mar 09, 2010 | Car Audio & Video

1 Answer

Green light (protection mode) on, NO red light (ready)


double check your wires aren't shorting out or power or remote wires aren't grounding. check if speakers are blown with nine volt battery

Sep 05, 2009 | Kenwood Car Audio & Video

1 Answer

Pyle dryver amp light protection stays on not green light stays red i have tried to disconnect everything and plug it back up but light stays red


check your subs disconnect them the try to power the amp up if it powers up the the subs have died and it could be a problem with that amp i suggest you get a better amp

Jul 09, 2009 | Pyle Dryver PLAD213 Car Audio Amplifier

1 Answer

Protection Light Comes on


your amp isnt getting enough power to it you may need to install a compacitor unit

Mar 23, 2009 | Sony NTX-2136 DHD 2Channel Car Amplifier...

1 Answer

Protection Light Comes on


Sounds like you have an ohm problem, Tryy hooking the positive from one speaker to the negative on the other speaker. Then hook the negative from the first speaker to the negative on your amp and the positive from the second to the positive on the amp this will drop your ohm load and the amp should stop going into protection.

Mar 08, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

RED Port light on AMP?


are you sure its not PROT?
the amplifier is protecting itself from fire because of something.
Disconnect the subs. and turn on.
if it comes on normally, the subs are at fault and will need attention. If the light still stays on, you hafe probably blown an output on the amplifier and it will need repair.

Dec 24, 2008 | Sony XM-2200GTX Car Audio Amplifier

4 Answers

Red light


something is shorted in the circuit, or your subs. unhook the subs first and try it again, if it is still in protect then it is most likely the output transistors.

Feb 22, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Rockford Fosgate P3002 Amp


what are the color of the lights that stay on.red= protect/ green=on.if the amp has little sound it probably still working,check deck output volume(rca)

Aug 22, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

350 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4885 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77169 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...