Question about Kenwood KAC-9152D Car Audio Amplifier

2 Answers

Kenwood kac-9152d i had a kenwood 380 watts amp before and my sub was conected in 2OMS but now i got a kenwood 1200 wat amp but when i conect my sub it dosent work it jumps how can i fix it

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have Amplifier Jensen A300HLX I dont feel the amplifier to weak . How I test how much power is pumping ?

Posted on Jun 10, 2007

Ad
  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 18 Answers

By jump do you mean all it does is thump and no sound besides thumping noise? if so put a better ground on your amp, double grounds work the best. please reply

Posted on Oct 06, 2006

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

kingkc1987
  • 4 Answers

SOURCE: amp goes dirctly into protect

ok well it could be two thing wrong your amp dont have a good ground or your amp is a smar amp and your subs must have to be hooked up so the power from the amp cn go to the subs so the amp can see that you do have subs hooked up to take it out of protect o and look at your fuses to to smal or to big will send it to protect to

Posted on May 19, 2009

  • 77 Answers

SOURCE: kac - 929 kenwood 1000 watt amp

Does it do it when car is not moving? If it does'nt then it is a bad connection in the amp itself or outside the amp. Check all your external connection well, it is easy to pass a bad connection up without knowing it. I recomend checking every connection, redoing the connections. Then you can rule that out and may find the problem. If connections don't fix problem let me know i'll be glad to help. I have my own amp repair business and people send me there amps from all over the U.S. Just send me a message and
I'll take you thru some steps to diagnose the amp if problem persists after connection checks. Good luck, hope to hear from you!

Posted on Aug 02, 2009

SPL Freak
  • 63 Answers

SOURCE: my amp is a kenwood kac-9152d it goes in to

In protection mode do you mean the light comes on and it plays music and stuff? If that's the case, that's what the amp is supposed to do. Protect itself from a power surge

Posted on Mar 06, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a kenwood kac-9152d amplifer and it works just fine for about 10 minutes then just shuts off and subs dont work, about 30 seconds later my amp turns back on with the subs.


make sure it's well ventilated. If there's no air flow, then there is no way of cooling down and to protect itself it will shut off. Make sure the speakers are wired correctly as per amp specs. too many subs or subs connected improperly can draw too much current and shut the amp off, but you will notice this when you turn up the volume to a certain point and the amp shuts down.

Aug 30, 2011 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I have a ts-w307d4 pioneer sub woofer and its a 4 ohm sub that has 4 terminals on it 2 red and 2 black how do i wire this sub to my amp i have a sony 1200 watts stereo amp and my sub is a dual voice coil...


conect one of the positive terminal from the sub directli to one chanel of the amp, and do the same with the negative,and do the same with the others terminals from the sub conect to the other chanel

Aug 12, 2010 | Pioneer TS-W307D4 Car Subwoofer

1 Answer

Car audio amplifer blowing fuses


why are you in stereo for subs? mono all the way.

Feb 21, 2010 | Kenwood KAC-7252 Car Audio Amplifier

1 Answer

How well will a 1000 watt kenwood amp pump with 2 1200 watt suns


2 will push more air but be careful how they are wired so you dont go to low on the ohms your amp sees.That amp should be 2 ohm stable so read up on how to wire in series or parallel.

Sep 06, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Power amp wont power up


Check the fuses-should be a pair of 30 amps on the side. use a paper clip and jump power from the power+ to the remote+ and see if that lights it up-if it does than your remote lead isnt giving it juice-

Apr 06, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Kenwood KAC-8401 light goes from blue to red when turned on


Either the amp is ad or the sub got shorted? You can check itby disconnecting the Sub and seeing if the amp comes on blue then. If yes, then the sub is shorted. If no, then the amp is shorted. Also chck the voltage AT THE AMP. Make sure that it is above 12 Volts.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Dec 29, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Sub power comes on consistently for about a second and thuds


u might have bridged the amp below is ohm load, if that the case run the speakers in series instead of parraell !

Dec 25, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I need help


Most of the time if the red light is on the amp is no blown but some times it does this cause the subs are hooked up in the wrong way. If the amp is only 2ohm stable and you hook the subs up to it at 1 ohm than the amp will not work so I would check this frist.

Oct 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My kenwood amp


you need to check your wiring and check your rca wires to see if they are giving your amp a signal to put out

Mar 11, 2008 | Kenwood KAC-9152D Car Audio Amplifier

2 Answers

Power on amp switch off when base is turned up


A: make sure that speakers size and watts.B: Type of speakers is used for base. C: Make sure the current (Amps)of the battery and your amplifier. D: Check audio from source and decrease the level of base. Thanks.

Feb 09, 2007 | Kenwood KAC-9152D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

199 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4915 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

78257 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...