Question about Macplay Baldur's Gate II: Shadows Of Amn for Mac

1 Answer

BG II for Mac crashing

Ugh, the game doesn't seem to work. I have a fairly new MacBook (2.4 GHz Intel Core 2 Duo). I install the version for Mac OS X, then my computer restarts. I open up the BGII folder, click on the thing I installed, it starts up for about 15 seconds... and then it says it quit. Nothing even shows up from the game really. It just says it quit. Anyone got any idea what it could be and how to fix it?

Posted by on

  • curtelverd Nov 25, 2008

    I recently installed Baldurs Gate 2: Shadows of Amn & it's expansion Throne of Bhaal.  I downloaded the patch, which replaced 2 things in the folder.  When I double click the icon to play Baldur's Gate 2, I get this message:


    An Assertion failed in ChDimm.cpp at line number 666
    Programer says: Unable to Open BIF:data:MISSound.bif


    How can this problem be fixed?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 32 Answers

It is not compatible

Posted on Dec 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Are there updates for other processors for blazing angels 2


if you mean upgrading to a cheap processor that is supported for your game. Intel core 2 duo or core 2 quad is right for you or Athlon X2 4000+ for AMD chipsets. Check out the link that I added so you can review the system requirements of the game Blazing Angels 2 Secret Missions of WWII system requirements System...

Oct 16, 2014 | Ubi Soft Blazing Angels 2 Secret Missions...

1 Answer

Joint Strike Fighter crash


sorry to say bt i think that your operating system is not able to open taht game

Jul 29, 2013 | Eidos Interactive Jsf Joint Strike Fighter

1 Answer

Will Macplay's Baldur's Gate 2 run on this computer?


Baldur's Gate is roughly ten years old so it was made to run on hardware that would be a fraction of what you have. If it doesn't play it certainly wouldn't be because of your hardware.

I also found this site with users running it on much older Macs:
http://www.versiontracker.com/dyn/moreinfo/macosx/12466
(see the comments toward the bottom)

Jun 09, 2010 | Macplay Baldur's Gate II: Shadows Of Amn...

1 Answer

How to install prototype game on my pc vista is my os, i have installed but i can not run or play it


This is your game's Minimum System Requirements:
OS: Windows XP SP3/Vista SP2
Processor: Intel Core 2 DUO E4700 (2.6 GHz) / AMD Athlon 64 X2 3800+
Memory: 1 Gb
Hard Drive: 8 Gb free
Video Memory: 256 Mb
Video Card: nVidia GeForce 7800 / ATI Radeon X1800
Sound Card: DirectX Compatible
DirectX: 9.0c
Keyboard
Mouse
DVD Rom Drive

May 12, 2010 | Activision Prototype for Windows

1 Answer

After I installed Baldur's Gate II on my MacBook, when I tried to start up the game, I got the error "An Assertion failed in ChDimm.cpp at line number 645 Programmer says: Unable to Open...


I love that game dude, but it's old and sadly depending on the OS you have, it doesn't run. You're probably using Mac OS X, or even Mac OS X Snow Leopard and BG2SoA doesn't run on Mac unless you have bootcamp.

Mar 20, 2010 | Macplay Baldur's Gate II: Shadows Of Amn...

1 Answer

Can older games be used on newer iMac?


I know for mac's it is a bit different.. on PC you can play an older game no problem but for some reason on mac you cannot?

I have a Macbook, and i tried to play Diablo 2... Yes very old game .. but since i was on mac OS 10.5 + ... the CD would not read.... if it was a pretty popular game there might be a newer download or patch you can install so that it will work but other then that i dont think you can.

Jun 02, 2009 | Scholastic I Spy Parents Guide for...

2 Answers

Can i play Civ II on my brand new mac?? or do i need an older mac


Civ II is a fairly old game. It seems that your PC runs Windows XP or earlier. It is likely that the site you read was correct, and your computer is too new to run it. However, you may be able to get another newer version of Civ for Mac, but check the system req's for any game you try to install. I don't know for sure if this is the case, but I hope this helps you somewhat.

Jun 01, 2009 | Macsoft Civilization 2 Gold for Mac

3 Answers

COMPUTER GAMES


hi,
There will be no difference in performance or graphics between the pirated version and the legal version.
They both works just the same way.
And about your issue, try installing more recent driver update for your graphic card.

Sep 19, 2008 | Rockstar Games Grand Theft Auto: San...

Not finding what you are looking for?
Macplay Baldur's Gate II: Shadows Of Amn for Mac Logo

Related Topics:

644 people viewed this question

Ask a Question

Usually answered in minutes!

Top Macplay Video Game Consoles & Games Experts

Josh Whitehead
Josh Whitehead

Level 3 Expert

1146 Answers

yadayada
yadayada

Level 3 Expert

63801 Answers

Brad Brown

Level 3 Expert

13793 Answers

Are you a Macplay Video Game Console and Game Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...