Question about Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum

1 Answer

Kenmore Progessive Lead wire "A" brackets broke on swivel

When using powerhead I lost motor power so I took the swivel apart and found 2 small pieces broken off of the swivel part which held the lead wire "A" in place. Without those pieces the power connector has too much free play and loses contact. Is there a particular adhesive I could use on those broken pieces to hold the lead wire in place so the connector will stay in place or any other suggestions?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 125 Answers

You could try GOOP adhesive

Posted on Dec 30, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I take apart an electrolux model el12a powerhead in order to replace the swivel?


Remove the screws on the bottom of the power head, you will then be able to remove the top cover to gain access to the swivel.

Dec 24, 2014 | Electrolux Vacuums

1 Answer

Need wiring schematic for ametek 119550


I had the same problem after not paying attention to the connections when replacing my motor. I spent days searching for information and only found several non-answers with small photos that no one can read.I contacted Oreck for wiring information. They explicitly stated that they can't provide any wiring information for safety and liability reasons.

I found the Ametek schematic which shows the LINE and TAP locations on the motor.

Note: I have a 2600HH XL with 2 headlights.

Connect as follows:

3A, LINE: White lead w/piggy back terminal from light harness #1 & white lead from the power harness to the piggy back terminal
2A, TAP: Black lead from light harness #1
3B, LINE: White lead w/piggy back terminal from light harness #2 & black lead from the power harness
2B, TAP: Black lead from light harness #2

9f6a42fa-778c-4d92-87ed-8fafaf1adc57.png

Dec 13, 2012 | Vacuums

1 Answer

The powerhead on my Hoover Duros will not keep running. If I push the on/off switch it will come back on sometimes, other times when I push it it turns the whole thing off as its supposed to do.


I just had the same problem with my hoover duros, the vacuum was running fine but the powerhead kept going off. I would make a sweep with it and powerhead would be running and then next sweep powerhead would shut off. I had tried checking connection and belt, etc. I thought it was the powerhead. But then I found the problem. On the duros there are 2 pieces of wands that hook powerhead to hose on canister. They both connected and clicked in fine but I decided to check them separately. I hooked just one piece to hose and powerhead and then turned it on and then I did the other piece. ta-dah! that's what it was...it was only one section of the wand. When I hooked them up separately, one piece the powerhead worked totally fine and vacuumed like normal. When I removed that piece of wand and tried the second piece (actually the bottom section when both are hooked together) the powerhead did not work at all. So I just need to get a new section of wand. Hope this helps!

Nov 17, 2011 | Maytag Hoover Duros S3590 Vacuum...

6 Answers

Royal 3050 power head does not run


The sounds like powerhead motor either burned up, or the belt broke and got tangled in the turning motor shaft. Pull the bottom off the power head and look for a curled up rubber band. If you find one, it's the belt.

If it's the motor, you won't hear it running when you turn the powerhead on.

Jan 23, 2009 | Royal Procision 3050 Bagged Canister...

2 Answers

Belt broke, can't get bottom off


if it's the one in the picture then pop off the light cover by gently pushing in and prying on both sides . Remove the bulb by pushing and twisting , OK?, now see the 2 screws? take them out. now flip over the powerhead and gently pry at both sides toward the rear wheels.
Ta Daa!

Oct 01, 2008 | Kenmore 23313 Whispertone Bagged Canister...

2 Answers

Kenmore canister switch issue


It most likely is the hose pcb. It has the switch on it, and part of it is either just dirty or bad.

May 17, 2008 | Kenmore 25512/ 25513 Progressive Canister...

2 Answers

Miele Vacuum cannister


Most times you have to replace the neck on the powerhead. Sometimes the switch in the handle of the hose will have a bad solder connection. But S300 is not a good model number, also the powerhead has its own number on the bottom, so couldn't look up parts for you.

Feb 21, 2008 | Miele S300 Bagged Canister Vacuum

2 Answers

Electrolux Epic 6500 Powerhead Motor


Call an Aerus Electrolux dealer in your area.

Jan 29, 2008 | Electrolux Epic 6500 Vacuum

2 Answers

Vacums


check belt not broken - could have happened when you caught tassle in head

Apr 18, 2007 | Kenmore 23313 Whispertone Bagged Canister...

Not finding what you are looking for?
Kenmore 25614 / 25615 Progressive Bagged Canister Vacuum Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60960 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...