Question about Computers & Internet

2 Answers

I just bought a Loigitech Premium 4-port hub but it does not work on my computer. I have a Dell Inspiron 510m laptop of about 2002/03 vintage. when I first plugged it in I got the message (something like) 'New hardware found', then 'Generic Hub' and then 'Hardware Installed'. But when I plugged stuff into the hub it did not come up on My Computer. The hub did not show. When I disconnected the hub my USB ports would not work and I had to restart to get them working again. When I connected again I did not get any messages but neither would the hub show up and the ports were disabled. I tried the hub on a different computer (a desktop) and it seemed to work OK. Any suggestions about how to fix it?

Posted by on

  • taswalker Nov 04, 2008

    I plugged it in again and it is working OK. I plug devices into it and they work. Thanks. I don't know what was happening before.

  • taswalker Nov 04, 2008

    Thank you Master JC. If I have another problem with it I'll try updating the driver.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Contributor
  • 35 Answers

Update / reinstall the Chipset Driver of the laptop :
(Click on the link or copy link to you browser)

Insipiron 510m Chipset Drivers

---or---

http://support.dell.com/support/downloads/download.aspx?c=us&l=en&s=gen&releaseid=R114079&SystemID=INS_PNT_PM_510M&servicetag=&os=WW1&osl=en&deviceid=1134&devlib=0&typecnt=0&vercnt=2&catid=-1&impid=-1&formatcnt=1&libid=27&fileid=149851


Posted on Nov 04, 2008

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 32 Answers

First go ahead and plug the hub back in and see if the ports are working. If they are not. I would try to go into control panel and then goto system and then hardware and then Device Manager. Scoll down to the USB Connection Field. See if they are any explanation points in yellow over any of the devices in the usb connection fields. If there are, Then its a driver issue. I would right click on them and click uninstall... Once doing so you can right click on any field and then click on scan for hardware changes. This will make the computer re scan for the USB Device Hub that you just purchased.

Note: Currently there doesnt seem to be any drivers availible for this device for Windows Vista.

Hope this helps
Joe < Data Miner >

Posted on Nov 04, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

Tip

Dell 510 not working


I have dell inspiron 510m laptop it is showing massage
''your computer is 5DGY81J-595B is protected by a password
authentication system''
i am not able to enter in setup even
pls tell me what to do

on Mar 09, 2008 | Dell Inspiron 710m Notebook

3 Answers

My computer tells me that if my wireless adaptor was plugged into a different USB root hub it would work faster. How is this done?


Try plugging the wireless adapter into one of the usb slots on the back of the computer. If it still shows that message, I wouldn't worry. The difference in speed is negligible at best. hope this helps

Mar 06, 2011 | Dell Inspiron 531 Athlon 64 X2 4400+...

1 Answer

MY LAPTOP (DELL INSPIRON 1545 ) KEYBOARD NOT WORKING. I AM PURCHASING FROM QATAR. BUT NOW I AM IN KERALA. 8 MONTHS BEFORE I PURCHASED THIS ONE. CAN I GET THE SOLVE THE PROBLEM MY LAPTOP? i dont know i...


We ran a typical Dell Inspiron 1525 battery of tests, including games, applications, and a couple other areas.
Time constraints limited the amount of testing we could get done before the NDA lift (and Dell Inspiron 510m Battery Dell Latitude D630 Battery
it's already a few hours late), but we will be providing a follow-up article with further
testing and information. That said, if there are any specific areas that you'd like to see
tested, feel free to e-mail me or leave a comment.

Aug 17, 2010 | Dell Inspiron 1545 Notebook

1 Answer

USB port on laptop is not working


make sure the driver is installed

Jan 03, 2010 | Dell Inspiron 8600 Notebook

1 Answer

How to reset the system clock on a dell 510m tried it in tne bios they light up but wont alter,, if the battery is low how and where is it locted i had to pick a diffrent laptop to send this post as my...


Peter, your system clock can be reset on your Windows screen, either in the lower right if you have the time function displayed (double-click to time and make any adjustments) or by going to Control Panel/Date and Time icon to do the same thing.

Nov 19, 2009 | Dell Inspiron 1525 Notebook

1 Answer

I am looking fro lan card driver and sound card


Here is the link that goes through support.dell.com and should take you directly to the Dell Inspiron 510m drivers and downloads page:
http://support.dell.com/support/downloads/driverslist.aspx?c=us&l=en&s=gen&ServiceTag=&SystemID=INS_PNT_PM_510M&os=WW1&osl=en&catid=&impid=

If for some reason this link does not work you can do the following:
1. Goto support.dell.com
2. Select drivers and downloads from the middle of the screen
3. From this point you can either select to enter your service tag number (should be on your pc) or you can do like I did and select Laptop, then Inspiron, then scroll down to 510m (you will actually have to scroll down to the 5000s because it is not listed from smallest to largest)
4. Once you have selected the 510m model it will bring you to the same page as I have linked above.
---
Finding your drivers -

I only saw one file listed under Audio so you could start there. Just expand the selection titled audio and it will give you options to download the file and install it just like any other installation.

Sound drivers usually require a reboot so anticipate this.

For the network driver I think I only saw one actual Lan card driver listed and it was towards the bottom under the selection titled Network.
It was the 10th one down and it is titled Intel Driver - (R) PRO/100 VE Network Connection.

Download and install that and hopefully that gets you going.

Good Luck,

Taco~

Apr 17, 2009 | Dell Computers & Internet

1 Answer

IRQL_NOT_LESS_OR_EQUAL


1. purchase a 2.5" usb enclosure.
2. remove your hard drive and install in the enclosure.
3. plug the enclosure into a working computer and copy or move your important files onto working computer.
4a. reinstall the laptop hard drive and try a repair installation by booting from the XP cd. (if you are running xp)
4b. reinstall the laptop hard drive and try booting to Last Known Good Configuration. Press either the F5 or F8 key while rebooting to get to the menu.
4c. purchase a new hard drive and reinstall the OS using the reinstallation cd's

Dec 09, 2008 | Dell Inspiron 1501 Notebook

2 Answers

Overheating


We had a GE 7 port usb port and it overheated and melted----thank goodness I got up when I did or the house would have caught on fire. The only thing we had connected to the usb port was a APC battery backup unit. Any reason why the usb port overheated?
It was pugged into the battery backup unit and I am hesitant to rehook the computer up to the battery backup unit and also will not by another GE usb hub again and whatever hub we do use, I will not plug it into an outlet!
the computer was downstairs and I noticed the odor of electrical burning smell upstairs---the unit was bought nov 25, 2007 and we returned it to BJ'S for a refund today-----I do not reccomend this product to anyone.

Oct 29, 2007 | GE JASCO (HO97878) 4-Port USB Hub

Not finding what you are looking for?
Computers & Internet Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Computers & Internet Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

kakima

Level 3 Expert

101554 Answers

David Payne
David Payne

Level 3 Expert

14160 Answers

Are you a Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...