Question about Sta Rite STA-RITE IMPELLER 2HP FULLRATE & 2-1/2HP UPRATE, C105-238PEB

1 Answer

2 hp vertical sta-rite well pump

Runs fine but does not draw water (or very little.) everything in the well has been check out (ok) some water leakage from upper portion of punp. (seal?) would appreciate any advice. Dee

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 17 Answers

Did you prime the pump? To prime: Before turning pump on, unscrew plug cap from top of pump (usually on pump impeller housing,) and with a pitcher or garden hose, fill pump full of water, and replace plug. Then turn pump on and see if problem is solved. If leaking: Are all fittings tight, O-rings and seals new, and is there any pipe thread tape on all threads w/o seals?

Posted on Mar 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sta rite dyna glas 1 hp pool pump low water pressure


There are a few questions you need to address first. One is the pump sucking are 2/ is the skimmer box at the pool full of leaf matter 3/ I have the pump impeller got leaf of rubbish in it. Check these items first.

Jul 05, 2014 | Sta Rite Sta - Rite Dyna - Glas Pool Pump...

1 Answer

I have a 1 hp Sta-Rite Centrifugal Pump, MPRA6#-147L. When on, water is coming it but the area with with filter is not filling up. I get no pressure on the filter and very little water is going to the...


CRACKED LID BAD LID O-RING,SUCTION LEAK, OR CLOGGED IMPELLER, LOOK AT YOUR BASKET IF IT HAS CRACKS, CHANCES ARE THE IMPELLER IS GOT **** IN IT. SPLIT THE PUMP AND CLEAN OUT THE IMPELLER , GET A NEW BASKET ASAP.. REMEMBER TO (PRIME THAT PUMP) AFTER ANY REPAIR !!!!
JAY THE POOL PUMP MOTOR REPAIR GUY IN LONGWOOD FLORIDA

Jul 23, 2011 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

Can get the pump to prime but not get to full suction water circulates but doesn't develop any head pressure


make sure intake union tight or leak on intake if ok check impeller for debris or pump top seal

Jun 18, 2011 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

Pump appears to be running properly but is not moving the water


Make sure there is an o-ring on the lid. Fill pump with water and then appy a little petroleum jelly on the o-ring and tighten hand tight. Start pump.

Apr 26, 2011 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

1 Answer

Sta-Rite Dyna Glas Pool Pump


debris may have gotten into pump or pump is air bound need to check pump first try to bleed pump if water comes out and not pumping hard possible burnt up impeller or seal

Apr 03, 2010 | Sta Rite Sta - Rite Dyna - Glas Pool Pump...

1 Answer

Spa Motor Hums


if it is a used pump, these have a tendency to have a little rust. just get some pump pliers and rock the shaft gently back and forth. then plug it back in.
David

May 17, 2009 | Sta Rite Sta - Rite Dyna - Glas Pool Pump...

1 Answer

Pump runs continuously with not water


replace the pressure guage.
prime the pump by pouring in water in the impeller basket area and replace lid-try running pump again

Mar 22, 2009 | Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out,...

Not finding what you are looking for?
Sta Rite STA-RITE IMPELLER 2HP FULLRATE & 2-1/2HP UPRATE, C105-238PEB Logo

287 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sta Rite Pool & Spa Pumps Experts

Jay Finke
Jay Finke

Level 3 Expert

1222 Answers

Rich Florenzen

Level 2 Expert

333 Answers

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

1869 Answers

Are you a Sta Rite Pool and Spa Pump Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...