Question about Audio Players & Recorders

3 Answers

Due to moving I had not used my McIntosh audio equipment for several months. Was working fine before. Now hooked up as before but no sound out of speakers. PreAmp C-32. Gets power, can hear with headphone plug in. Speaker Control Relay SCR 2. Hear a single clicking sound (as before) when power turned off or on. Amplifier MC 2205. Both blue light panels come on when powered up. No needle movement or sound from speakers when music source turned on. I do hear the music when headphones plugged into preamp headphone plug. No sound when headphhone plugged into amp headphone plug. Have triple checked all connections. Any ideas as to problem in relay switch or amplifier? Easiest way to check would be most appreciated.

Posted by on

  • gtbasinger Nov 01, 2008

    Yep, found a loose wire. thanks, jer

×

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 899 Answers

If there is no headphone sound on the amp then there may not be no sound input to the preamp inside the amp , first make sure the the switch that changes the speaker set up , like A set , B set , and make sure thats not the problem , then if thats not it you will have to make sure the preamp output is good ( hook it up to another input and or another source )
if that is good then the problem lays in the power amp , try , unhooking inputs , turn off amp , unplug it from the wall for a min. then plug it in and turn it on wait for the click then plug in the inputs ( if the output of the preamp is good
if this all fails to work it will need to be tested and components checked to determine what the problem is exactly

electech

Posted on Oct 31, 2008

  • jason Oct 31, 2008

    and it might be this preamp transistor on the preamp or the amp

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 3,614 Answers

Well if you find problem on your amp. it is better to re check again the audio input / output connections could be a loose connections or you got a wrong connection. or try testing iton the other speakers and check it alone.

Posted on Oct 31, 2008

  • micromaster
    micromaster Nov 01, 2008

    kindly rate my solution as fixya, once the info fix the problem.

    thanks


×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,550 Answers

The problem lies in amplifier .

Posted on Oct 31, 2008

  • SAM ANDERSON Oct 31, 2008

    If you have any spare speakers (which is working ) connect to amplifier to check whether it is working properly .

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have a McIntosh MC602 used to drive two 4 ohm subwoofers. Worked perfectly until a close lightening strike took out several theater components. Even though it was turned off during the storm it was plugged...


it seems that the right channel is blown. the unit has no fuses inside, most likelly output transistors are gone. not easy fixable, you need to bring it to a repair shop. if you are in nj you may brong to ebcelectronics

Sep 12, 2011 | Mcintosh MC602 2-Channel Amplifier

1 Answer

McIntosh C-39 preamplifier will not power on. Over the last several months this problem has gotten progressively worse, from taking several tries with either the remote or physically pressing the power...


Hi there,
Is it plugged in directly to the wall or are you using a Uninterrupted Power Supply or Auto Voltage Regulator?
Check for any signs of overheating on the Capacitors and the IC's usually this intermittent shutdown can be caused by a faulty capacitor which cannot hold the electricity and thus causing the unit to shutdown.
Hope this helps!

Aug 14, 2011 | Audio Players & Recorders

1 Answer

I have a cable box connected to reciever and was working fine for months, now i get no picture on tv only sound. I use hdmi cable out to tv that also uses my ps3 to tv which is working fine. What...


I don't know what kind of TV you have and what kind of output capabilities you have but, while your receiver will transfer your video signal, it is not the ideal way to hook it up. The port you are using may have to be reset somehow or, may have gone bad. Ideally you want to hook all video componenets directly to TV then, use, digital optical is best, audio out from TV to receiver. If you have more than 1 input in to TV, you can run your PS3 and cable box directly to TV, using the TV's menu to select which you are using, then, run your audio out to receiver.

May 23, 2011 | Denon AVR-887

1 Answer

The right speaker produces almost no sound


This can happen due to several reasons.

You just check whether th wire got bend . It can happen due to that.


-rate if it helped you.

Apr 08, 2010 | Bose Companion 2 Series II Multimedia...

1 Answer

Equipment not turning on!???


Have you tried checking the remote wire yet? Because it could very possibly be that. Without a remote wire hooked up, you cannot get any power. Try that and see if it works.

Apr 29, 2009 | Alpine MRP-M500 Car Audio Amplifier

2 Answers

GE profile performance tfx30ppz ice dispenser not working


Had the same problem. The water line from the valve to the ice maker was cracked due to heat from the compressor.

Jan 09, 2008 | GE Profile 26.6 cu. ft. Side-by-Side...

1 Answer

No sound but plays the dvd fine


I think this is due to wrong Audio settings.
Try to change audio setting as Stereo/Right or Left/5.1 from the Audio setup of the Menu

Dec 14, 2007 | Emerson SpongeBob SquarePants 3D Sculpted...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

80 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

4943 Answers

The Knight
The Knight

Level 3 Expert

73086 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...