Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Restet amp well my red light only comes on when i plug the rca cables.... but when they r both plugged no lights turn on

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

You might have abad set of outputs in you radio check to see if they have voltage coming through them with a mutimeter

Posted on Nov 02, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I have a kicker 500.2 red protection light is on and red light on top of amp flashes every couple seconds. Have checked all connections and other amp in truck works good. I bought two of these amps and...


Disconnect all the wires except the three main power wires, ground, 12v battery and remote. Now, turn on your radio, if the protect light is still on then there's an internal short in the amp. If the light turns green, then there's a short in either the auxiliary cables or the speaker outs. If it turns green, then troubleshoot the other wires that plug into the amp by connecting them one at a time until the protect light comes on, which will tell you that there's a problem with that speaker/aux wire.

Jul 25, 2011 | Kicker KX500.2 Car Audio Amplifier

2 Answers

I have an internal problem with a rockford fosgate 900 watt mono amplifier. when its all hooked up the power,light comes on but it wont bump...what could be wrong with it? Please help. Thanks


check the remote wire that its on. check the know on it that its on low cross over whith decibal gain. also make sure your rca plugs comming from the cd player are in the input on the the amp , good ground and that you didnt plug in the wires wrong for each sub. its very possible you may also have a loose ground connection or a blown fluse. either on the amp or under the hood. but most likely on the amp.

Mar 17, 2011 | Rockford Fosgate Car Audio & Video

1 Answer

WHAT DO IT MEAN FOR MY AMP TO READ DIAGNOSTIC


The diagnostic light, for this particular model, means that there is either a short circuit on the loudspeaker leads or there is an internal amplifier fault that is causing a DC offset. In order to determine which, disconnect all RCA and speaker leads while keeping the +12 volt, power ground and remote leads connected. Now turn the amplifier back on, and if the diagnostic LED lights up, the amp has an internal fault. If not, plug the RCA cables back in and reset the amp. If it goes into diagnostic now, the problem is with the input (either bad cables or a faulty head unit). If the amp is fine with the RCA cables plugged in, repeat the process with the speaker cables (one at a time). When you plug in the faulty speaker wire it will put the amp into diagnostic mode.

Mar 06, 2011 | Hifonics XX-Hercules Car Audio Amplifier

1 Answer

What could be wrong if the red light is on it comes on once i plug my rca wires in


If the red light goes off (out of protection mode) when you unplug RCA cables, You may have a break in your RCA cables or they are trapped somewhere or completely nackered. For a quick solution, Take your RCA cable fully out of your car, Then wire it to the back of your head unit through the centre of your car straight to the amp, If still red light, you need new RCA cables

Mar 03, 2011 | Car Audio & Video

1 Answer

I have a 1400 watt cruch amp & i hooked it up myself. when i turn the radio on the power wire on the amp comes on, bt if the audio cords are hooked up, the protection light comes on. if i dnt hook the...


Should the amplifier go into protect mode, simply disconnect all RCA and speaker leads, while keeping +12 volt, power ground and remote leads connected.

1. Now turn the amplifier back on, and if the diagnostic LED lights, the amplifier has an internal fault.

2. If not, plug the RCA cables back, and reset the amplifier. If it goes into diagnostic now, the fault lies in the input, either with bad cables or source unit.

3. If the amplifier seems fine with RCA cables plugged in, connect the speakers, one at a time, and if one of the speakers or its wiring is faulty, it will activate the diagnostic
system.

Dec 08, 2010 | Mobile Authority A-500 Car Audio Amplifier

3 Answers

The saftey red light keeps coming on


It means that the subwoofer is blown. The red light is called the Protect light. Disconnect the speaker wire from the amp and then turn the amp on and see if the red light goes away. But if as soon as you hook the speaker wires back to the amp and the red light turns on that DEFINATELY means the sub is blown.

Apr 04, 2010 | Cadence TXA 1000D High Power Mono...

1 Answer

The portection light on my alpine mrv-1507 wont let me get any sound


remove the rca wires and the speaker output wires and just leave the 12volt power/ remote/ and ground connected. turn on the radio and see if the light goes off. if it does then one of your speaker or rca wires are shorted, plug in one at a time and see which one gets you the red protect light, then find the short for that speaker/rca wire. if the red light turns on with only the 12volts/remote/ground, then the short is in the amp.

Feb 26, 2010 | Ohm Crystal Mobile Sound CADT 600.2...

1 Answer

Amp on "protect" mode


Hi, what you need to do is unplug all the connections to the amp. The amp goes into protection when the circuitry over heats.\
First decrease all your gains to minimal volume.
Connect your 12+V, remote, and ground.
See if the protection light comes on then.
Next plug in your RCA cables.
Check protection light.
Then plug in your subwoofer cables.
See if you are still in protect mode.
Hopefully everything works alright again.
Just slowly increase the gain to see what the cut-off is. Make sure you aren't dropping the ohmage too low on the amplifier. Check manual for correct wiring and such.

Feb 08, 2009 | Phoenix Digital PD-394 Car Amp

1 Answer

Protection Light Is Coming On


You say the protection mode only occurs when you plug the RCA's in. Does it have to be both RCAs or just one?

The other end of the RCA cable is plugged into the HU?

It possible the RCAs have too much DC voltage on them, causing the amp to go into protection.

Is there a short in the RCA cable?

I would definitely check out the RCA connection at the back of the HU, as it sounds like there could be other issues there. Make sure the RCA connectors aren't touching any other metal (especially +12V).

Mar 14, 2008 | Car Audio & Video

1 Answer

Amp won't put out sound


Hello, if you leave me your email I can send you the user manual for this amp. Best regards, Arpi

Apr 10, 2007 | Sony XM-SD22X Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4724 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...