Question about Power Acoustik Car Speakers & Subwoofers

1 Answer

Power ligth (red) is on but dont work - Power Acoustik Car Speakers & Subwoofers

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 185 Answers

Ok so it when on protect check the fuse's or the amp might be bad

Posted on Oct 31, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 12inch speakers work in my house but when I hook them back up to my truck they dont work . My amp used to have a red light on it but now it doesnt work i bought a new amp and speakers and still nothing...


Could be a number of things. Check all the fuses (the power wire, the amp). Make sure your ground wire hasn't worked loose. Make sure your remote wire hasn't worked loose either (sometimes vibration causes loose crimped wires to come out behind the head unit). Happy Hunting

Aug 20, 2011 | Car Speakers & Subwoofers

1 Answer

AFTER HAVING MY BATTERY DISCONECTED 4 2 HOURS IN MY 2003 FORD F150 I CAN'T GET THE UNIT TO TURN ON,ONLY A RED LIGTH ON THE VOLUME CONTROL.


If the power is coming to the set without any fuse blown , the switched and unswitched +12, then it is possible that the code is reset , if this is the original set in the Ford.
If so contact dealer for code to be entered to set this to work.

Sep 30, 2010 | Dual Car Speakers & Subwoofers

1 Answer

Ive got the red power wire hook up and the yellow 12v hot all the time but dont now what color the ground wire is or the speekers are


Your ground wire is going to be black. Your normal wire colors are violet and violet/black, green and green/black, white and white/black, last but not least you have grey and grey/black. Those are your speaker wires. Solid blue is usually to power your antenna, and blue/white is for your amp turn on lead. Those two wires are approximately .5mV of power, and you can actually use either one to turn an amp on. Speakers: normally your solid color is positive, while the black stripe is your negative. As for which one goes to which speaker, left front is white, right front is gray, left rear is green, and right rear is violet. Hope this helps.

May 17, 2010 | Car Speakers & Subwoofers

1 Answer

I need the diagram for 1993 honda accord for radio i am installing a jvc cd player and i dont have the right adapter so i cut the origanal plug and now need to know the color codes for the wiring


this the wiring for that car--
constant power-white/green
ignition--white with red
ground-black
dimmer-red/black
left front spk-blue with green-+
left front spk-ghray/black -
right front spk-red/gree-+
'' spk-brown/black-
right rear spk-red/yellow-+
'''''''''''''''''''' spk-brown/white-
left rear spk-blue /yellow-+
'' spk-gray/white -

antenna you done need you antenna is in your window


Jun 25, 2009 | Car Speakers & Subwoofers

2 Answers

I have taken out my standerd sterero in ford fiesta 1996 and cut off the block dont know what wires are what and now clock dont work ant think i have blown the stereo can any one tell me what wires are...


you may have blown the one of the fuses in your car look in the fuse box and check the fuse for the clock ps if you find out what wires are what please let me know as ive got the same problem in my fiesta. cheers kez

Apr 13, 2009 | Car Speakers & Subwoofers

1 Answer

LEDs don't light


??????????????? only on fixya would we get a complaint that speakers that are supposed to make sound work great but some lights on them dont work.... ugh.. ok with most of the spealers that have l.e.d.s typically have a seperate connection for the lights. The red wire goes to a switched 12 volt power source, the black goes to chassis ground... if they have power and ground but dont light up then they are junk...

Sep 08, 2007 | Blitz BZX462 Coaxial Car Speaker

8 Answers

SUBWOOFER NOT WORKING?


if you have real old wires from the amp to the sub try getting new wires on it. check the little wires that go to the cone itself on the sub. sometimes they can manage to get pulled out of their terminals and make sure that thier touching the terminals on the correct spot

Sep 29, 2006 | JBL GT150 Car Subwoofer

Not finding what you are looking for?
Car Speakers & Subwoofers Logo

Related Topics:

77 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Speakers & Subwoofers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Brandon Berry
Brandon Berry

Level 2 Expert

407 Answers

Iron
Iron

Level 3 Expert

3018 Answers

Are you a Power Acoustik Car Speaker and Subwoofer Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...