Question about Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Vaccum doesn't have power.

When pluged in the change bag,change brush sensor lights up and the power won't come on.

Posted by on

  • rose miller Apr 17, 2009

    the sensor s12 quit working so we put a new electric cord and it worked fine. When we went back to work to use it it wouldn't turn on and still will not. We have checked the eletrical cord on another sensor s12 and there isn't any thing wrong with the cord. When you turn it on there is a faint flicker on the check brush and bag full light but it won't start up. Please advise. thank you BOB

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 108 Answers

I had one of these come in for service, a new mainboard was the solution. They're getting power if the lights come on. The board just isn't letting it go.

Best of Luck!

Posted on Jun 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix sensor s12. red light for bag stays on even when vacuum bag is not full and the vacuum is clear


You most likely will need to change the Yoke assembly. There is a sensor built in that gets clogged with fine debris over time. This will take care of the problem.

Feb 09, 2015 | Windsor SR12 Sensor Bagged Upright Vacuum

4 Answers

I have a Windsor Sensor s12 and power shuts off after 5 min. of vacuuming. I'm wondering if it's overheating of if there is some other sensor that causes it to shut off.


Your Sensor most likely has an internal heat sensor that is shutting off the motor. Some vacuums install an external heat sensor with a reset button that you must push to re-start the vacuum. If your model does not have an external reset button it is most likely a sensor inside the motor. If it is defective the motor must be replaced to solve the problem. But first make sure the overheating is not being caused by a blockage somewhere or the bag is too full. Air must pass completely through a vacuum starting at the floor where it picks up the dirt through all the canisters, filters, bags, etc. and then is exhausted from the vacuum. Any restrictions or blockage can cause the motor to over heat.
That Vac Guy

Jan 04, 2013 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Power light on but motor won't run. where do i


the motor carbon brushes need replacing which is a most difficult job to get the cleaner disassembled. Brushes are easy to fit if You have replaced carbon brushes in other appliances etc..
Getting to the brushes in the Kirby is very difficult...
Lee in Australia

Jul 28, 2011 | Kirby Generation 3 Bagged Upright Vacuum

1 Answer

No suction at all on my Kirby just cleaned the brush, etc... had a hard time getting the belt back on... really hate this vacuum cleaner


I have a kirby Diamond series and the 'green light' on the upper right side (while standing behind the vaccum) does not come on and when it doesn't come on I noticed that it does not sound as though it is picking up at all. I have changed the belt, placed a new bag in it and made sure that there is no clogs. What else could it be?

Apr 03, 2010 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

I have windsor s12 vaccum this one have brush up light on


The windsor Sensor brush indicator light will come on when:

  • Something stuck in the brushroller
  • Brushroller is worn and needs replacement
  • height is wrong (indicates a problem with height adjustment)
  • a bad circut board/sensor
more than likely your brushroller just needs to be replaced, very common.

Jun 03, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

2 Answers

Vacum not sucking the dirt and the light is not turning on


loss of vaccum brush head not spinning check belt turn over remove bottem plate check belt assmble. remove any string or hair build up sear is the best bet for the belt

Mar 31, 2009 | Kenmore 34923 / 34925 Progressive Bagged...

1 Answer

Just powered itself off


It will shut off if your bag is full. If you are cleaning up fine dust, it will give a false bag full indication. Take the bag out and carefully, shake it down to get the dust out of the filter layers inside. This will let more air flow through the sensor.

Nov 20, 2008 | Electrolux UltraLux 2000 Bagged Canister...

2 Answers

Rotating brushes will not turn


If belts are ok then possibly needs new front brush motor replaced.

Nov 05, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

1 Answer

Changing bell on a hoover turbo power 6200


Most Hoovers if you turn the vac over, remove the plate covering the brush roll, then you can get to the belt and brushroll.

Dec 31, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Windsor SR12 Sensor Bagged Upright Vacuum Logo

Related Topics:

439 people viewed this question

Ask a Question

Usually answered in minutes!

Top Windsor Vacuums Experts

Ryan S
Ryan S

Level 2 Expert

328 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike

Level 3 Expert

4331 Answers

Are you a Windsor Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...