Question about Jl Audio 500/1 Car Audio Amplifier

2 Answers

JL audio 500/1 produces barely any sound

I just got a jl 500/1 amp and all the connections are good but it barely plays anything even with the volume and gains all the way up. can you please help me?

Posted by on

  • abergel Nov 08, 2008

    no thats definitely not it. im almost positive its one of my rcas

  • Jake Pereira
    Jake Pereira Aug 03, 2012

    i have a similar issue. when i unplug one if my rcas the sub works fine-ish but when both are plugged in the sound is faint but will kick in randomly and sound great :/

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

Ohm load is way off check it and let me know... If you send the wrong ohm load to amp will restrict the output so it sounds low or muzzled

Posted on Nov 06, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Have you checked the input sensor on the amp?

Posted on Oct 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a jl 500/1 amp hooked up in my car and the power light comes on for about 5 seconds then turns off. no sound out of the subs. it is hooked up to a factory deck through a high to low level converter....


hook up the remote wire ( or make sure its hooked up good) check your ground! ground wire not big enough awg wire and put on bare metal not more than 1 foot away from amp. bad ground will cause this.

Sep 12, 2011 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a jl audio 500/1. I had the amp professionally installed. The amp played for 2 days and no it has no sound but the power will come on. what could be the problem. I have new rca jacks, 4 guage power...


Go back to where you got it installed and ask them to fix it.

If you don't want to do that I would recommend going to another good car audio shop and getting them to check it out.

You can test it yourself by hooking up an iPod to it using a Headphone to RCA cable.. test at low volume first.

Dec 31, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My jl 500.1 amp dosent play anything.


you have your sub wired incorrectly. your amp shouldn't get hot unless you're settings are too high or your'e sending too small of an ohm load to the amp. this would cause it to heat up and will fry your amp.

May 30, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Amp isn't powering subs and speakers


silly as it sounds, you may want to check your EQ settings on your headunit. Things like sub volume, SLA, loudness and balance. When they replaced your battery, those old settings were lost.

Mar 26, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Bass freezes at a certain volumn and no longer gets higher


JUST CHECK THE CROSSOVER SWITCH, AND MAKE SURE THE SWITCHES ARE IN THE CORRECT POSITIONS

May 22, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Audio 500/1 Amp, The green power light is on but no sound!


Check to be sure you are on the correct outputs on the head unit, and be sure the outputs do not have a separate volume control.

Mar 06, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl 500/1 amplifier will not turn on


you may have burned the channel you were using..try taking the cover off the amp and checkin for burned spots or any wires that may be loose or touching within the amp.

Feb 24, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I HAVE A JL AUDIO MONOBLOCK AMP 250


It indicating that the power output is too loud and possibility of speakers may get damaged if played at this volume for long periods. When the loudest sound is played the led light mightshow its loosing its brightness and dims in time with the sound level.......................sodeep

Jan 17, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Clarification for jl amp problem


sounds very much like resistance was an issue and no they dont have an internal fuse sorry

Oct 12, 2008 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Jl Audio 500/1 Car Audio


There are no fuses inside the amp.

Are any of the lights lighting up on the amp?

If so, which ones?

Jun 09, 2008 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

174 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Amplifiers Experts

matthew walsh

Level 1 Expert

69 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Are you a Jl Audio Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...