Question about Car Audio & Video

Open Question

How to wire a mutant amp mtpk300-a - Car Audio & Video

Posted by Anonymous on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
emissionwiz
  • 76846 Answers

SOURCE: mutant amp protection off

this is caused by a shorted output transistor(s) in the main amp.

Posted on Jun 12, 2009

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

WHAT AMP DO I NEED TO RUN MY MUTANT 120 SR AMP MANUAL


60-100 amp fuse should be plenty i run my ssl 850 monoblock of 60amp no problem

Feb 27, 2013 | Mutant Car Audio & Video

1 Answer

Where can i get the wiring diagram for the mutant nw280sp car amp thanks


Here is a direct link to the wiring diagram for this amp.
http://www.crutchfield.com/S-liATTbX39zU/learn/learningcenter/car/amplifiers_wiring.html
Hope it helps you? please comment for more information and thank you foe using fixya.

Jan 27, 2011 | Car Audio & Video

1 Answer

Mutant amp protection off


this is caused by a shorted output transistor(s) in the main amp.

Jun 12, 2009 | Car Audio & Video

1 Answer

Mutant headunit instruction manual mt-cdm501ucr


http://www.mutant.uk.com/downloads/manuals/MT-CDM501UCR.pdf
hope it helpss

Apr 24, 2009 | Car Audio & Video

1 Answer

Car Speakers


YOUR POWER WIRE IS NOT STRONG ENOUGH TO HANDLE THE POWER. GET A BIGGER POWER WIRE AND SEE IF THAT HELPS

Jun 30, 2008 | Car Audio & Video

1 Answer

Brand new sub deied 5 minutes after fitting


maybe u had ur crossover set to full on the amp. Check it bcause, if you have to many high frequencies sent to any subs at a high level u can seize them in minits.

Oct 26, 2007 | Eclipse SW8102.4 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

149 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...