Question about EliteGroup ECS G900 Notebook

Open Question

Turns on but no video or display - EliteGroup ECS G900 Notebook

Posted by on

  • Jeffrey McDaniel Feb 23, 2012

    Does its post? Any beep codes? Any additional information would be great.

×

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Denon AVR-1312 turns on displays for a second switches off and the red light starts to flash


you most likely have a shortedchannel in the amp that would need to be repaired

Jul 31, 2014 | Denon AVR1312 51 Channels Receiver

1 Answer

E machine model T3626 turns on display doesnt work and doesnt power off???


Sounds like either the Monitor is bad or the Video Card is bad. Try plugging another monitor on the computer and if it can't show a display then more than likely the Video Card is bad. If it shows on the monitor you just plugged in, then the original monitor is bad.

May 01, 2012 | Computers & Internet

1 Answer

Television turns on, but no video or sound


If you do not also get the On Screen Display/Menu you have a bad board somewhere==

Double check your connections and let me know as much as you can about the problem

I am here to help

Mar 15, 2012 | Toshiba 37CV510U 37 in. LCD HDTV

1 Answer

Screen turns black when tring to play video games


update the display adapter and check with the requirements for the game
if required upgrade the video card

Mar 13, 2010 | Gateway FPD1975W 19" LCD Monitor

2 Answers

IBM ThinkPad A20M Turns on but there is no video?


My initial diagnoses for your PC is due to a defective
video card. But there could be other causes such as
Processor contact defect. So, to get a precise and
guaranteed works, have your PC serviced by a qualified
PC technician in your area.

Dec 08, 2009 | IBM (08K3261) for ThinkPad A20P, A20M,...

1 Answer

1621 radar will not show target


Could be the video wires in the radar cable

Jan 04, 2009 | Boating

1 Answer

Emachine monitor lose color.


HI Bernard,

This sounds to me like the video lead is loose. Could you please try the video lead each end and tighten the locking screws if possible.

Regards

Nick

Oct 29, 2008 | E-Machines eMachines Monitor E15T4

1 Answer

Display 'video 1' stays on all the time


There is a "Display" button on your Sony remote that turns the display ( Video 1,2,3 etc) off and on , you probably hit it by accident like I did.

Nov 14, 2006 | Sony KP-53V90 53" Rear Projection...

Not finding what you are looking for?
EliteGroup ECS G900 Notebook Logo

Related Topics:

57 people viewed this question

Ask a Question

Usually answered in minutes!

Top EliteGroup Computers & Internet Experts

David
David

Level 3 Expert

778 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Jerry Umali

Level 3 Expert

979 Answers

Are you an EliteGroup Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...