Question about Electrolux Vacuums

Open Question

My N106K Renaissance vacuum powerhead keeps going on and I have to restart it. the reset button is NOT tripped.

Power head # is N106K. Possibly mid-90's version.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: kenmore whispertone model 11620412003

I am getting suction to the power mate, but the mate doesn't
work. The belt seem fine, but the light and beater doesen.t
go on. Tried the reset - no result. Thanks

Posted on Jan 04, 2008

Ad
  • 3 Answers

SOURCE: Dyson DC 17 Asthma allergy Vacuum

I had a similar issue. I called Dyson. Hey why not, the number is right on the from of the machine. SO IS the beater bar on/off button, right next to the big red on/off switch. It does have a safety off when something jams the bar from rotating so the motor doesn't burn out. I also removed my sock and on restarting the thing, the beater bar would motor was not turning on. I thought the reset would be inside but no, it is right outside in plain view, which I didn't see either. It is a grey button opposite the big red on/off switch. Boy did I feel dumb after that phone call!

Posted on Sep 07, 2008

  • 1214 Answers

SOURCE: Royal 3050 power head does not run

The sounds like powerhead motor either burned up, or the belt broke and got tangled in the turning motor shaft. Pull the bottom off the power head and look for a curled up rubber band. If you find one, it's the belt.

If it's the motor, you won't hear it running when you turn the powerhead on.

Posted on Jan 23, 2009

  • 1 Answer

SOURCE: Powerhead woes

I've had my Hoover S3755 for about 2 years and loved it, at least until the last couple of months when the "belt slipping off" problem started. I changed the belt and the vacuum would work for a little while then the belt would come off again. I put on a new belt again and within minutes the belt had slipped off. I took it to my local vacuum repair about 4:00 in the afternoon. By 4:45 I got a call from the repairman that he'd fixed my vacuum! What did he do? He put a different belt on it. He put a Rainbow belt on my Hoover that's thicker and doesn't have as much "give" as the Hoover belt. It's also a little bit wider than the Hoover belt. Now when the brush slows or stops at a carpet edge the belt doesn't slide off.

Posted on Jan 31, 2009

  • 3 Answers

SOURCE: Need to know if a replacement part can be purchased and where

IT CAN BE FIXED BUT YOU NEED TO KNOW THE ROPES
I HAVE THE KNOWHOW AND THE PARTS
PRICE IS 40$ + YOU PAY ONE WAY SHIPPING
RETURN IN 1 WEEK
EMAIL LESGUEST@VERIZON.NET

Posted on Mar 05, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The power brush on my dyson 24 is not turning


On the motor side of the powerhead there is a red reset button. This trips to protect the brush motor when the roller gets jambed.
Hope this helps.

Apr 12, 2014 | Dyson Ball DC24 Bagless Upright Vacuum

1 Answer

Electrolux Vacuum Renaissance Power head brush won't turn


if it is making a humming sound but not turning you belt is broken, if it is not check the reset switch (little res button) if that doesnt work check the connections between the cord of the powerhead and the wand, the wand and the hose, and the hose and the vacuum
give the hose itself a good look over sometimes the wires up by the grip break in the casing

Mar 12, 2014 | Electrolux Vacuums

1 Answer

Wertheim 6035, lost manual, where is button to restart carpet head?


There is a hole at the back of the powerhead near the height adjustment lever. Just put something slender in the hole like a screw driver to reset.

Jul 08, 2012 | Vacuums

1 Answer

The powerhead on my Hoover Duros will not keep running. If I push the on/off switch it will come back on sometimes, other times when I push it it turns the whole thing off as its supposed to do.


I just had the same problem with my hoover duros, the vacuum was running fine but the powerhead kept going off. I would make a sweep with it and powerhead would be running and then next sweep powerhead would shut off. I had tried checking connection and belt, etc. I thought it was the powerhead. But then I found the problem. On the duros there are 2 pieces of wands that hook powerhead to hose on canister. They both connected and clicked in fine but I decided to check them separately. I hooked just one piece to hose and powerhead and then turned it on and then I did the other piece. ta-dah! that's what it was...it was only one section of the wand. When I hooked them up separately, one piece the powerhead worked totally fine and vacuumed like normal. When I removed that piece of wand and tried the second piece (actually the bottom section when both are hooked together) the powerhead did not work at all. So I just need to get a new section of wand. Hope this helps!

Nov 17, 2011 | Maytag Hoover Duros S3590 Vacuum...

1 Answer

The sweeper attachement went "dead." What could be


more than likely the overload or reset button has been tripped within the powerhead.

Press the red button or the square button on the left side top of the unit, more than likely it is the red one, and it should start up for you again.

Good luck,
Mark

Nov 09, 2010 | Kenmore Whispertone 23312 Bagged Canister...

1 Answer

The powerhead brush died. The vacuum works just fine, but the brush doesn't.


there could be 2 reasons for this problem.

one) the powerhead is dead legit as in there is no power coming to it or the motor is actually dead.

2) something jammed in the brush and popped the reset button. The reset button is a red button located as your looking at the back of the powerhead on the right side. Usually a red square. Push it and it SHOULD start up again.

That being said, if you have done the reset button and it still does not work, that unit I beleive has either a 2 or 5 year warranty (cannot remember dont have the documentation in front of me) and if it is still covered under warranty for you, take it to your closest Vacuum repair shop. Do take the hose and powerhead with the cannister unit.

good luck

Nov 06, 2010 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

Powerhead Keeps Shutting Off


Open up the power head and check the toothed corners where the power head sits - it sounds like thread has caught up at the sides which can only be removed by opening up the powerhead to clean it.

Nov 14, 2008 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

Restart button


Usually there is a red reset button to push on top of the power head, but some are on the back edge of the powerhead.

May 28, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Kenmore whispertone model 11620412003


I am getting suction to the power mate, but the mate doesn't
work. The belt seem fine, but the light and beater doesen.t
go on. Tried the reset - no result. Thanks

Dec 29, 2007 | Vacuums

2 Answers

Vacums


check belt not broken - could have happened when you caught tassle in head

Apr 18, 2007 | Kenmore 23313 Whispertone Bagged Canister...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...