Question about Alpine MRV-1507 Car Audio Amplifier

1 Answer

ALPine mrv-1507 Need helppp!! powere light flashes red

I have my alpine mrv-1507 and for some reason my power light flashes red... even when my speakers aren't connected.. anyone know whats wrong with it? can anyone please help?

Posted by on

  • NEMOOO Oct 27, 2008

    lol but i have two batteriesss u think its internall ?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

According to the owner's manual, it means that the battery voltage is low. Page 13:

http://vault.alpine-usa.com/products/documents/OM_MRV-1507.PDF

Posted on Oct 27, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have the same proble,mine 1507 power light go red everytinme i hook it up to my CAP,and no sound comes of it..please help me..thanks


hi djdannid19!
guess your car battery is too weak, replace or get a second one build in (btw use of cap not necessary if you have big batteries). also might be that the cap is gone dry.
regards

Feb 26, 2011 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

Amp


I honestly don't have a solid answer for you. I can say check your fuses. Check your battery to amp wire. And also check your ground. Make sure the fuse on your amp is also not blown

Feb 26, 2010 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

How do i run it 2 ohm stable


This is how 2 type r's are wired to one amp at 2ohms hope this helps dont forget to rate me thanks

Upfront Audio :)

1a81949.jpg

Apr 06, 2009 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

V12 MRV-1507 or Xplod? Amplifier - XM-ZR1252 good quality sound


Alpine is just a better brand in general. I have the older MRV-1507, sounds GREAT, i have had friends who has had the Explode line, but it was always a temporary system until they got something better, like the alpine or kenwood.

Aug 14, 2008 | Car Audio & Video

1 Answer

Alpine MRV-1507 "low Voltage"


If it indicates that you have an open shield ground, read through the following page. It will show you how to test the shield ground connection of your head unit..

Temporary RCA Shield Repair


Aug 14, 2008 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

MRV - 1507 Question ...


The MRV-1507 is a two channel amplifier, below I've pasted important info from the manual:

Battery Lead (Sold Separately)
Be sure to add a 80 amp fuse as close as possible
to the battery’s positive (+) terminal. This fuse will
protect your vehicle’s electrical system in case of a
short circuit. If you need to extend this lead, the wire
gauge should be AWG8 or larger.
MRV-1507 ... 80A amp fuse

Power Output: RMS Continuous Power (at 12.0V, 20 Hz to 20
kHz)
MRV-1507
Per channel into 4 ohms ......................... 150W, 0.08% THD
Per channel into 2 ohms .......................... 300W, 0.3% THD
Bridged into 4 ohms ................................ 600W, 0.3% THD

You can find a manual for this amp here:
http://www.alpine-usa.com/US-en/support/support_search.php?modelname=mrv-1507

Jul 07, 2008 | Alpine MRV-1507 Car Audio Amplifier

2 Answers

Mrv1507 power light blinks red..


Your speakers probably are made for 6 or 8 ohms. to check, take out any of the speakers and read the back for the ohm rating, if it is more ohms, you need a more powerful amp.

Jun 18, 2008 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

Alpine mrv-1507


Your amp. got damaged the audio amplifiers IC's thats why it's going on protect mode.

Jun 05, 2008 | Alpine MRV-1507 Car Audio Amplifier

1 Answer

Blinking protection light on mrv-t757 amp


Could be the power supply or output stage electrolytic capacitors.
Possibly breaking down/drying out inside.

Mar 17, 2008 | Alpine MRV-T757 Car Audio Amplifier

2 Answers

Alpine 1507


I would either try a bigger fuse, if possible, or turn the power output dial on the back of your amp down. This can be done with jus a simple flathead screwdriver. I suggestion would be to go out and buy a power monitoring cap. Wal-mart, or Tweeter usually distributes them. It'll have a LED reading on the top, with two wire hook-ups either on the bottom or the top for positive and negative, place this in between your amp and your subs in the wiring set-up.

Feb 25, 2008 | Alpine MRV-1507 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

543 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jaime Hernandez

Level 3 Expert

2296 Answers

Are you an Alpine Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...