Question about Kenwood SW36HT Subwoofer

1 Answer

Sw-32ht kenwood subwoofer

The power doesn't even come on when you plug it in and turn the switch on it is totally dead. Someone told me that it might be a fuse but I can't find a fuse anywhere on it. What wuld be the cause of this problem? it has not worked for about a 1and a half I have been trying to figure out why.

Posted by on

  • 1 more comment 
  • Anonymous Jan 02, 2009

    fuse type and size

  • Anonymous Mar 08, 2009

    same

  • admichaus Apr 13, 2009

    Same problem, on the sw32ht led lights, but no sound comes out. However I opened the back cover and discovered there is a relay (little blue box that clicks) on the circuit board. I moved it with my fingers and voilĂ  it works now!!, intermitent though, but better than before. My guess is that after 9 years of boom boom vibration, the relay became somehow loose and it needs to be either re-soldered or replaced, I will need the service manual to do it, anyone has it?



    Please if you do send it to admichaus@hotmail.com







    Regards

    Andres

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Open the case and check the fuses and the speaker to see if it actualy still working and not blown.

Posted on Feb 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have Kenwood SW 900 . need to know its out put. Kept for long period


Do you mean the Kenwood SW-200 subwoofer or the SW-200 power meter? The subwoofer can use 50W RMS at 4 Ohms. It's rated at 60W. The power meter reads in two ranges: 20W and 200W.

Kenwood has the manual for the subwoofer on their support site. The direct link to the manual is http://kenwoodusa.com/UserFiles/File/UnitedStates/Home/Manuals/sw200.pdf .

I hope this helps. If you are looking at a different Kenwood product, please clarify which product you have. I can't find a SW 200 receiver from Kenwood.

Cindy Wells

Mar 08, 2016 | Kenwood Car Audio & Video

1 Answer

Have a kenwood sw-32ht green light comes on but have no sound, please help on what it could be


Check the signal or rca's. Make sure the sub is turned on from the headunit. Sounds like you have power but no signal. Also, make sure your power wire has 12 volts. I've seen where the light turns on because remote wire has power, but no power from the battery wire.

Oct 17, 2014 | Car Audio & Video

1 Answer

Kenwood sw-35ht Replace with a kicker sub


I suppose you could, but you are talking about a driver (speaker) that was not designed for that cabinet size and amplifier used in the Kenwood, There are differences in speaker design besides power rating and impedance.

Jun 10, 2014 | Kenwood SW-38HT Subwoofer

1 Answer

Kenwood powered subwoofer no power


There may be a blown fuse internally

Nov 16, 2012 | Kenwood SW-38HT Subwoofer

2 Answers

I am unable to start my HP pavilion dz6700 laptop..it turns on and in a sec it switches off. Battery of laptop is dead and even though i connect to externa power source it doesn't start


Hi,

Unfortunately there's a problem with the motherboard of the laptop, you need to replace it. One of the circuits is grounded or is totally dead to accept and release power for the unit to turn on.

Hope this helps.

Jun 13, 2011 | HP Computers & Internet

2 Answers

Woofer will not turn on. fuse was bad but i replaced it and still no power.


Had the same problem, no power from the sub, no light. Opened the box, fuse was bad, replaced the fuse...pop...blew again. Found out that on the bigger middle board next to the power plug there are two capacitors on either side, the inner one burned and crumbled to pieces. I called Kenwood, they said that I would have to bring it to a Electronic Service Specialist that they will give you a number to in your area...or...Ship it yourself to their East Coast Center in Virginia. I already asked if Kenwood is going to send an RMA or Shipping Label and they will not. You will be responsible for the shipping there, but they will pay for the shipping back. Kenwood's East Coast Center in Virginia's number: 757-340-1702 - Good luck

Dec 14, 2008 | Kenwood SW-38HT Subwoofer

1 Answer

I have a Kenwood Subwoofer, SW-305, S/N 00901468, that when the power is one and hooked up there is a loud buzzing sound. No audio comes out of the subwoofer. I have checked and rechecked my conections and...


please try to replace your RCA plug that connects from your input player to your Kenwood Subwoofer..coz it not have open ground or has no continuety in it

Dec 05, 2008 | Audio Players & Recorders

2 Answers

Kenwood KSC-WA801


if you don't mind a large car battery (and battery charger) in your living room, it will work. Another option is to get a 12 VDC power supply, capable of sourcing 100 or more amps, but that would be too costly.

Jun 15, 2007 | Kenwood SW-38HT Subwoofer

Not finding what you are looking for?
Kenwood SW36HT Subwoofer Logo

Related Topics:

2,176 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4861 Answers

Eddie Dalton
Eddie Dalton

Level 1 Expert

41 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a Kenwood Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...