Question about Creative Labs Gigaworks S750 Computer Speakers

Open Question

S750 run without control pod

Can i run creative s750 withou control pod ??

Posted by Anonymous on

Ad

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 99 Answers

SOURCE: Gigaworks S750

If you check the Creative forums there is a thread there where a few people have started to fix problems like this permanently and they have helped quite a few people fix their problems. I would only suggest checking it out if you have any electronics experience (soldering, and basic troubleshooting minimum). Otherwise I would send it back but keep in mind that this is one of a few common problems with the S750's and you are likely to have other problems in the future unless you take measures to fix the problem that creative has not.

I would also like to point out that your problem would be a short on one of the amp boards after the power regulators, very likely one of the STA575 amplifier ICs. Those are not easy to find but it is possible to find replacements.

Posted on Dec 16, 2007

Ad
Open SKy
  • 620 Answers

SOURCE: Creative Gigaworks S750 9 pin color code

Cliff
First things first:

This is not a special and critical eq. from creative, you can take it to the reapair shop and they sometimes have the schematics, other than this, sorry you have to RMS to CREATIVE.
Carl

Posted on Feb 01, 2008

Ezrahite
  • 2632 Answers

SOURCE: re: creativer gigaworks S750

Hi,

Welcome to Fixya. According to creative labs they do not sell any replacement parts for the speaker systems. You can see about getting a new control pod from ebay or craigslist but the problem is more likely inside the subwoofer. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is not much information there about control pod problems but at least the people on the thread will help as much as they can. If you are not familiar with electronics then some of the people on the forum thread can help if you are willing to ship the subwoofer box to them.

Creative s750 Repair

Thanks

Posted on Jun 04, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My gigaworks s750 powers up and lights, but no sound


Hi, have you find any solution? I got the same problem. Can you please email me. mtlmw@hotmail.com. Thank you

Feb 26, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

Power light blinks, control pod wont power on and no audio


It seems that this problem has occured many times and I have hunted down an answer:

The glue within the amp turns brown when in contact with high temperatures. This brown substance is actually conductive, therefore you get currents all over the place and eventually blows your amp.

The fuse will also blow, requiring you to replace that.

To fix this, you either install fans (costly?) or use it in a cool/cold room. Either should work, but do not go buying the worlds biggest fans, as it may not be the case for all of you unhappy customers out there.


Hope this helps,

Tiger720

Sep 16, 2009 | Creative Labs Gigaworks S750 Computer...

2 Answers

All I need is the control pod for the Gigaworks S750


I had an extra one but I sold it. According to creative labs they do not sell any replacement parts for the speaker systems. The best suggestion that I can give is to check craigslist and ebay for the control pods.

Dec 13, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Audio control pod seems dead


You can see about getting a new control pod from ebay or craigslist but the problem is more likely inside the subwoofer. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is not much information there about control pod problems but at least the people on the thread will help as much as they can. If you are not familiar with electronics then some of the people on the forum thread can help if you are willing to ship the subwoofer box to them.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Nov 09, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creative S750,all speakers distorted


Your problem sounds like it is the high voltage power supply not working. I would start by checking the IRF740 MOSFETs on the power supply board. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is a lot of information there about the problem you are experiencing as well as complete diagrams of the power supply and good pictures.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Oct 25, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Sub has died overnight


Change the fuse - located at the 220V input. Use a knife ti release it. Then the system will work again.

Oct 08, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Creative Gigaworks S750 9 pin color code


Cliff
First things first:

This is not a special and critical eq. from creative, you can take it to the reapair shop and they sometimes have the schematics, other than this, sorry you have to RMS to CREATIVE.
Carl

Jan 28, 2008 | Creative Labs Gigaworks S750 Computer...

1 Answer

Control pod


Double check the connections, if the connection for the control pod is good then something is wrong inside. I would say most likely thing would be a problem on the power supply inside the subwoofer box.

Nov 29, 2007 | Creative Labs Gigaworks S750 Computer...

1 Answer

A mess!


pls check your audio cable conection. bye

Sep 11, 2007 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs Gigaworks S750 Computer Speakers Logo

Related Topics:

160 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

620 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

77186 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...