Question about AudioBahn Car Audio & Video

1 Answer

I have a audiobahn amp model number is a435hcx four channel. It gave the red light I turn it off for a while then I turn it back on and it work a few seconds then it went to a red light again I want to know it could b wrong with it

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 341 Answers

It might be that you have wired it in such a way that the impedance is too low and this is tripping the amp into a fault mode. What kind of speakers do you have attached to it and how are they attached?

Posted on Feb 17, 2012

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 7 Answers

SOURCE: audiobahn 12' subs and audiobahn amp

First thing is first. What subs do you have? Audiobahn makes several kinds of 12" subs. What model sub do you have?
Without knowing this, it would be hard to recomend an amp without knowing how much power your sub can handle. Audiobahn makes from very power amps that can put out up to 5000W RMS, but if your sub can not handle that power, then you will blow your sub.

Posted on Dec 21, 2007

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Audiobahn a1502dp amp only one channel is working. I need both to bridge it and get its full 1ohm potential. Where can I get this fixed? Preferably near kc


Audiobahn A1502DP True Digital Series 2-Channel Amplifier

www.sonicelectronix.com > ... > Car Amplifiers > Class-D Amplifiers

Rating: 4.5 - ‎4 reviews
Audiobahn A1502DP • True Digital Series 2-Channel Amplifier 1 ohm stereo stable 2 ohms bridged • True Digital Circuitry • Dual Cooling Fans • HP/LP ...

new amp, only one channel working?? help! [Archive ...

www.caraudioforum.com > ... > Car Audio: Installation Help

Apr 24, 2006 - 16 posts - ‎5 authors
the next step would be to try reversing the rca cables on the amp. ... unplug one wire, the one sub that is working, gets quieter, although it is still working. as ... It'saudiobahn, of course this could happen straight from the factory.Missing: a1502dp

[PDF]True Digital Full-Range Series - Audiobahn

audiobahn.com/.../Amplifiers/A752DP-A1502DP-A2502DP-A1004DP-...
A752DP/A1502DP/A2502DP ... Audiobahn was established in 1997 with one long-term goal in mind, ... Great products and proper installation are only a small piece of the puzzle when it ... from the smallest terminal, to power wires up to 0 gauge, and 4channel RCA cables. .... exceed the total value of fuses in the amp. 1 1 .

one channel not working [Solved] - Speakers - Audio


Jan 15, 2016 | AudioBahn Car Audio & Video

1 Answer

I have a 12 inch auduobahn 400 watt that is a special edition d jones. what is the best and most efficient way to install it with a jensen 400 watt 2 or4 channel mosfit power amp.


Is it a 2 or 4 channel amp???? Does it have a lpf (low pass filter)??? If its a four channel it prolly wont sound too great. If its a 2 channel you need to bridge sub to amp. Usually its the 2 outside terminals on the amp. Might have a diagram on the bottom of amp

Feb 27, 2012 | AudioBahn Car Audio & Video

1 Answer

My audiobahn amp 2000w serial number A1500HCT is not currently working when I plug it in turn on the car the blue light that usually indicates that it is working turns to red. it was working fine before...


Check all your connections and wires. You probably have an issue with a bad ground or your remote wire Make sure you have no bare spots on your wires. Also make sure there are no pinch points on the wires running to amp.

Nov 18, 2010 | Car Audio & Video

3 Answers

Audiobahn amp help...


You have a Direct Short in the System Between the Head Unit and the Amp. Check the Ground on the Amp and then Check all the Wires behind the Stereo and the Common Ground There. You could even have a Spot in the New RCA Cables that is Touching Metal Somewhere. Please Rate My Response! Thanks!

Feb 09, 2009 | AudioBahn A2002T Car Audio Amplifier

2 Answers

Audiobahn A4601T, only 1 audio channel works


Is it the same channel in both amps that produces output?

Have you tried all combinations of setting for the switches and pots on both amps?

Oct 25, 2008 | AudioBahn A4601T Car Audio Amplifier

4 Answers

I have a dub 4001 amp


Take it step wise.

Unplug the inputs and outputs from the amp (be sure to mark the wires so you can hook them back up), leaving only the ground, +12, and remote wire hooked up. Now, turn it on. If the amp light goes red, the amp is broken. If it goes green, turn if off, plug in the speakers, then turn it on. if it's red, its a speaker problem, if green, do the same with the inputs, and you'll have your answer.

Jan 22, 2008 | AudioBahn DUB Mag Audio DUB4001 Car Audio...

1 Answer

Zenith plasma


dont get mad like i did, report this problem to zenith, they seem to be aware of the problem with this particular model.
i gave them the model number and they requested the purchase date, then extended the warranty and gave a number for a local repair shop which came for my set a couple days ago.
so far so good. it may be a while until i know whether the repairs will work, however hats off to zenith, so far, which seems to be providing appropriate customer service and standing by their expensive products.

Jan 14, 2008 | Zenith Z50PX2D 50 in. Plasma HDTV

1 Answer

No Sound coming out of amp to subwoofer


check the fuse box and make sure there is no loose connection there. also check the wire that feeds power to that amp. good luck

May 23, 2007 | AudioBahn DUB Mag Audio DUB1002 Car Audio...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioBahn Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

xxxxxx xxx

Level 3 Expert

4861 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8267 Answers

Are you an AudioBahn Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...