Question about Audio Players & Recorders

Open Question

Technics su-g75 receiver not getting regular stereo output when in stereo mode surround sound works fine but when listen to stereo only plays out center channel and subwoofer why? Please help.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
furion187
  • 54 Answers

SOURCE: 4 ohm and 8 ohm speakers

You can plug in higher ohm speakers , the higher the ohm the higher the resistance is, it is a danger when you plug lower ohm speakers into a higer ohm Amp , at a high volume that will cause them to blow , the center speaker would be fine to use a higer ohm speaker , your best choice is to buy a Active Subwoofer, which means the sub has it's own power supply , and u can blast the thing as much as u like , thn u can turn the bass down on all the other speaker's so u can play it louder , and have the sub turned up has high as u like , this is the best way to get great sound with high volume , buy a Active sub woofer , any active subwoofer is ok , a active sub woofer has its own volume and inputs on the speaker ,

Posted on Dec 09, 2007

Ad
SirHanz
  • 145 Answers

SOURCE: subwoofer connection

if this is ao powered sub, that plugs into the wall, there should be no problems, if it is powered solely by the reciever it may work fine but be sure you dont exceed amperage on the subwoofer.

Posted on Jan 29, 2008

  • 4 Answers

SOURCE: Center, and rear surround speakers

Sounds like the rear volume is just turned down. Cant be the amp if the front and subs are working

Posted on Dec 09, 2008

ravichetty
  • 158 Answers

SOURCE: home stereo

POSSIBLY THE AUDIO IC IS BLOWN

Posted on Feb 10, 2009

  • 121 Answers

SOURCE: dayton sub-100 connection

You have it upon one of several truly odd "standards" in the AV industry but the answer is simple if not quite logical. You will use an RCA type cable from the Sub out or LFE on the receiver to just one of the two inputs on the subwoofer. I usually use the one on the right but it really doesn't matter. The other connectors would be for a system with out a sub out where the speaker wire would be run first to the subwoofer and then out to the speakers. This will not be used at all in your case.

Enjy!

Posted on Feb 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Technics SU-G75 owners manual download


http://www.manualslib.com/manual/926367/Technics-Su-G75.html?page=2#manual Technics SU G75 Service Manual Page 2

Sep 23, 2015 | Technics SU-G75 Amplifier

1 Answer

Want to download Technics SU-G75 service manual


Technics will not give it to you. Gotta pay the piper!

Did you try to google it - might get lucky - but don't hold your breath.

Sep 21, 2015 | Technics SU-G75 Amplifier

1 Answer

How do i hook my speakers to my amp


Your amp has separate outputs for rear channels. Simply connect your rear speakers to the outlets on the back of your amp set up for them.

Jun 11, 2015 | Technics SU-G75 Amplifier

1 Answer

My technics integrated receiver su-g75 is stuck in


The headphone jack is stuck, something got in there. Probably have to take it apart, but it might be a piece of a plug. Use flashlight...

Aug 28, 2014 | Audio Players & Recorders

1 Answer

Ok I have a technics integrated receiver su-g75 it


The amplifier power transistors could be bad, the speakers can be muted or a fuse for the speakers could have opened.

Aug 28, 2014 | Audio Players & Recorders

1 Answer

Technics SU-G75 has no sound


Hello
when the resistors are burned,means that the transistors are damaged, or the power module is damaged.
and in your case its the power module.
Hope this helps.


23392686-biweyzzz1swyjlxgbbebmoak-5-2.jpg

Feb 07, 2014 | Technics SU-G75 Amplifier

1 Answer

My technics amp SU-G75 keeps shutting off and reads OVERLOAD when played over the volume of -40 to -35. I kept playing around and it works fine when the bass dial is on half, but more bass shuts it off. I...


some amps are made more for low ohm loads (bass) and some are made for high impedence loads (mids/highs) and it seems you are asking too much from your amp.

Mar 05, 2013 | Audio Players & Recorders

1 Answer

Technics SU-g75 Amplifier. No longer any volume. Fuse is OK, display is fine, just no volume??


ALL speaker jacks must be loaded and closed for any sound to come out of this system. Missing one speaker, or one bad connection and you will get no sound or some will work and some will not. speaker wires need to go deep into speaker jack holes.

Aug 04, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

52 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5158 Answers

The Knight
The Knight

Level 3 Expert

74383 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...