Question about Heating & Cooling

Open Question

Honeywell T84 how to remove battery00C

How to remove battery from the honeywell T8400C?

Posted by Anonymous on

Ad

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 767 Answers

SOURCE: honeywell T8400c thermostat went blank. central

I would check the batteries in the thermostat. If the batteries are okay then you might have a blown fuse in the furnace or the furnace lost power check the breaker.

Posted on Jan 21, 2010

Ad
pendletonhea
  • 144 Answers

SOURCE: My honeywell t8400c also went blank. I can not

it should take a battery and it has wires coming from the unit for power as well the stat splits open from the wall leaving some of it mounted on the wall the batteries are in the part that pulls off the wall and the wires are on the part that stays on the wall the power wire is red on r terminal

Posted on Sep 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Honeywell thermostat t8400c


Probably no power (24 volt) to the unit. Check 3amp fuse in the air handler. Also check that it's wired properly.

Sep 19, 2013 | Heating & Cooling

1 Answer

I HAVE A HONEYWELL MANUAL THERMOSTAT NO BATTERIES ALL IT HAS ON THE BACK IS T8400C 1099 (2) 0710 1B HELP, IT DOES NOT SHOW ANY THING THE SCREEN IS BLANK


This model of Honeywell thermostat uses the 24v from the unit to power it. One of three things must have happened.

1. You have lost power to the furnace, therefore no power to thermostat.
2. You only have 4 wires hooked up on the thermostat and not 5. A lot of older homes had just 4 wire running to the thermostat, which will not work for this thermostat. You should have a wire connected to the (C) or (B) terminal on the thermostat, which ever one they have, I can't remember off hand. These are the Common terminals. They have to have the common from the furnace 24v power to operate.
3. Faulty thermostat, which will obviously have to be replaced.

Hope this helps and gets you to cooler days!

Jun 28, 2012 | Honeywell Heating & Cooling

1 Answer

Changed honeywell T8400C 1024 to Hunter 44760, I have five wires white, red, yelliow, green, blue. Hunter Thermostat reads "NO A/C Power.


Hi,
On the t-stat and the furnace make sure the wires are hooked like this...

Red to R
White to W
Green to G
Yellow to Y
Blue to C

then it should work..

Thermostat Wiring and Terminal Designations

heatman101

Jun 12, 2011 | Heating & Cooling

1 Answer

My honeywell t8400c also went blank. I can not find a battery anywhere and if plugs into the wall to get electricity. Everything works but the digital read out. Any suggestions


it should take a battery and it has wires coming from the unit for power as well the stat splits open from the wall leaving some of it mounted on the wall the batteries are in the part that pulls off the wall and the wires are on the part that stays on the wall the power wire is red on r terminal

Sep 23, 2010 | Honeywell Electronic Programmable...

1 Answer

I have a Honeywell T8400C 1024 thermostat. the last two nights, our heat continues to run without shutting off at the pre-set temperature. We have woken up to 81 degrees in our house. What is the...


Hello
Try taking the batteries out for 5 min,or disconnect power for 5min.
To clear it out.
Then re input all your times days and temps,

Is t stat in a cold location near a door or window?this could also override your settings,most progrmamble stats will go into override at 58.f im guessing this is not your problem.

If it continues after you reset,i would consider a new thermostat.

Hope this helps.

Jan 28, 2010 | Heating & Cooling

1 Answer

Honeywell T8400c thermostat went blank. central heating is not working although warm water is alright. any idea?


I would check the batteries in the thermostat. If the batteries are okay then you might have a blown fuse in the furnace or the furnace lost power check the breaker.

Jan 21, 2010 | Heating & Cooling

1 Answer

Honeywell thermostat t8400c intermittent blank screen


It actually sounds like the batteries are going dead if the 24v from the furnace are not providing the power to the thermostat.

Sep 28, 2009 | Honeywell Electronic Programmable...

1 Answer

Honeywell thermostat T8400c started flashing, heat/cool was off. Display flashes all icons (heat and cooling icons, temperatures, everything) and on the oppposite flash, the setpoint is displayed. The fan...


Based on the simplicity of this particular t-stat, I really think that it is bad and needs to be replaced. They do not make this particular model anymore. I have included a link to the operators manual for the stat. Good luck!

http://customer.honeywell.com/techlit/pdf/PackedLit/69-1491.pdf

Apr 05, 2009 | Heating & Cooling

Not finding what you are looking for?
Heating & Cooling Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Heating & Cooling Experts

paulcarew

Level 3 Expert

2519 Answers

Dan Webster
Dan Webster

Level 3 Expert

8220 Answers

Donni Steen

Level 3 Expert

659 Answers

Are you a Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...