Question about Creative Labs GigaWorks ProGamer G500 Computer Speakers

Open Question

Controller for gigaworks g500 dosent work

The power light is on but there is no light on the controller and there is no sound

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 99 Answers

SOURCE: Gigaworks S750

If you check the Creative forums there is a thread there where a few people have started to fix problems like this permanently and they have helped quite a few people fix their problems. I would only suggest checking it out if you have any electronics experience (soldering, and basic troubleshooting minimum). Otherwise I would send it back but keep in mind that this is one of a few common problems with the S750's and you are likely to have other problems in the future unless you take measures to fix the problem that creative has not.

I would also like to point out that your problem would be a short on one of the amp boards after the power regulators, very likely one of the STA575 amplifier ICs. Those are not easy to find but it is possible to find replacements.

Posted on Dec 16, 2007

Ad
  • 13433 Answers

SOURCE: User Manual Creative G500

Heres how to connect your speakers
http://creative.com/products/speakers/howto/?c=2&sc=1

Hardly anything available from creative
Heres the rest


There is no user manual available online, it only comes with the set. So if you want the manual contact creative directly
http://sg.creative.com/contactus/

Thank you,
Ekse

Posted on Jun 22, 2008

SOURCE: gigaworks s750

Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Posted on Aug 05, 2008

  • 1 Answer

SOURCE: creative labs gigaworks g500

cdnmember, I ve the same problem wit ma system . Hope you hav fixed your's , so please help me to find a solution; dunno hw to contact you, please send me a buzz to pinne13@yahoo.com

Posted on Feb 07, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Creative Gigaworks S700 i have checked both fuses still no power to control box


Stupid question: does the sound still work? it could be the LED just died after continual use (rare, since they last a long time, but not uncommon).
If not... it could be the controlling circuit board died. In which case, unless you have electronics repair experience, it would be probably more worthwhile to just replace the speakers, as pricey a model as it is.

Mar 23, 2012 | Creative Labs Gigaworks S750 Computer...

1 Answer

My system powers up then loses power immediatly if the power supply has failed can i replace it?


There really is not a way to replace the power supply for speakers. I would have to suggest you contact their tech support at 800-998-1000

Mar 04, 2011 | Creative Labs GigaWorks ProGamer G500...

1 Answer

When powered up, clicks and loses pwr immediatly


Sounds like a hardware failure in the power supply.

Feb 13, 2011 | Creative Labs GigaWorks ProGamer G500...

2 Answers

Creative labs gigaworks g500


http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&Item=270456737725&Category=3702&_trkparms=algo%3DLVI%26its%3DI%26otn%3D1

Jun 21, 2009 | Creative Labs GigaWorks ProGamer G500...

2 Answers

Subwoofer powers itself off


I Think its a loose connection in electric circuit. Due to vibration in the woofer the connection might be going off. Check the power circuit for any loose connections.

Feb 07, 2009 | Creative Labs GigaWorks ProGamer G500...

1 Answer

Audio control pod seems dead


You can see about getting a new control pod from ebay or craigslist but the problem is more likely inside the subwoofer. Below I have pasted a link to a forum thread about fixing the Gigaworks S750 systems. There is not much information there about control pod problems but at least the people on the thread will help as much as they can. If you are not familiar with electronics then some of the people on the forum thread can help if you are willing to ship the subwoofer box to them.

http://forums.creative.com/creativelabs/board/message?board.id=speakers&thread.id=8037&view=by_date_ascending&page=1

Nov 09, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

User Manual Creative G500


Gigaworks manual is just one sheet, you need to download both following links to pdf documents.
Link front
Link back


Jun 22, 2008 | Creative Labs GigaWorks ProGamer G500...

2 Answers

Audio control pod


I have a similar issue too, but my problem is that the sub has green light, and my control pod has an 'off' light, but it won't turn on :(

Jun 16, 2008 | Creative Labs Gigaworks S750 Computer...

2 Answers

Gigaworks s750


Same problem just went out after about 4 years.... weak lifespan for a 500 dollar system

Feb 12, 2008 | Creative Labs Gigaworks S750 Computer...

Not finding what you are looking for?
Creative Labs GigaWorks ProGamer G500 Computer Speakers Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Creative Labs Audio Players & Recorders Experts

Carlos L. Burgos
Carlos L. Burgos

Level 2 Expert

619 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Are you a Creative Labs Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...