Question about Alpine MRD-M501 Car Audio Amplifier

1 Answer

How to unlock my alpine mono power amplifier mrd m500?

I need help in my amp, I just need to know how to unlock my amp. It turns on and everything, but when i hook up the cables from the speakers to the amp it just doesn't sound... So my friend said that the speakers cables from the amp crossed each other, and that's how it got locked... if you have a solution i will hear it from you thanks

Posted by on

  • Anonymous Mar 16, 2009

    hi guys,i ve got the same problem.... is t expensive to repair the power supply????? greetz from Holland

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 737 Answers

Hi. If you shorted (touched) the speaker wires together, or let them touch the chassis of the car, then it may have locked out. Just turning the amp off and back on will fix this, so it sounds like you have done damage to it. Most amps have a speaker relay which gives a click sound when you turn on. If there is no click, then it may have a power supply failure.

Mark

Posted on Oct 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok i got a mtx 12' 500 sub matched to a alpine mrd-m500 mono amp. The deck powers the 4 speakers, as i turn the volume up on my deck (alpine cde 100) the sub/amp cuts out at around volume 20-22 and E-3...


Sorry,after rereading your problem,I gave a wrong answer.Do you have the deck sub RCA pre-amps connected to the amp,then the wires from the amp to the sub?If you do,you need to check what the sub and amp are rated as such as,peak or rms.They are 2 completely different meanings.Greg

Feb 11, 2011 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

Can i use a MRD-M500 for voice on my tweeters


not a good idea-its made to run bass- plus its a mono amp- so you would lose stereo separation-but if your mind is set on it....do what you gotta do and good luck

Jan 09, 2010 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

I have an Alpine M500 mono amp that works great, until you turn up the volume. I can adjust the bass down at the head unit, but at higher bass the amp shuts off. And then comes back on after a couple...


I don't think either, I believe your running theamp load too low with too low an ohm speakers and this cases the amp to produce more power but not stable and it overheats and the thermal protection cuts the amp off when the temp gets too hot to prevent damage.. Make sure your speakers depending on how they are wired do not exceed the amps load rating

Oct 26, 2009 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

Amp powers up and reads 14.4 volts... 0 amps.


Check to make sure amp is not in safe mode, you can turn this on and off in the menu.

May 19, 2009 | Alpine MRD-M1000 Car Audio Amplifier

1 Answer

Alpine MRD-M500 Amplifier


That is a code to inform you of an issue, and to help direct you to a particular area of concern

HOT & E-1 = both for heat issue

E-2 = for a voltage issue

E-3 = for a current issue.

While yours is a current issue, that reflects a problem with your input or output signal pairs. You should disconnect the subs at the amp, then operate the unit as normal to see if the code reappears. This is the start of your process of elimination, where as you will be able to determine the general location of the issue, weather it is before - internal - after the amp, hence If after the subs were disconnected, the code did not return then it would be obvious that you should focus on the subs and their signal pairs. troubleshooting in small increments until the issue is discovered.

Hope this helps...Good luck
Aduz

Mar 27, 2009 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

Need help!!!!!!!!!!!!!


ALPINE ELECTRONICS OF AMERICA, INC.
19145 Gramercy Place, Torrance,
California 90501, U.S.A.
Phone 1-800-ALPINE-1 (1-800-257-4631)

Mar 16, 2009 | Alpine MRD-M500 Car Audio Amplifier

1 Answer

Alpine mono power mrd m500 amp


Try switching the lowpass filter down to 80hz or lower, then adjust the bass boost to your liking.

Jun 28, 2008 | Car Amplifiers

1 Answer

Alpine mrd-m500


Hi SPDGOD,

 

Could not find exact, but close manual.  It is the MRP-M450 mono block amp from alpine.

 

Go to this url and view in Adobe. Print it if you need to

http://vault.alpine-usa.com/products/documents/OM_MRP-M450.PDF

Oct 19, 2007 | Alpine MRD-M1005 500W x 1 mono subwoofer...

2 Answers

Could you help


i have lost the instruction manual for my alpine v12 mono power amplifier mrd-m300 could you send me a print out of it by any chance. Without it i am unsure of the controls on the unit thanks.

Apr 27, 2007 | Alpine MRD-M300 Car Audio Amplifier

Not finding what you are looking for?
Alpine MRD-M501 Car Audio Amplifier Logo

Related Topics:

298 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alpine Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

Are you an Alpine Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...